1Password autofill inconsistent / not working from either the app or 1P mini

2

Comments

  • ag_yaronag_yaron

    Team Member

    Yep, that is definitely a solid suggestion @Ashiado .
    Thank you!

  • ag_yaronag_yaron

    Team Member
    edited December 2019

    @ibrennan I think you might have misread what he wrote in step 1 - he said:

    Uninstall 1Password X and then reinstall the regular extension...

    His suggestion is all about the regular extension :)

  • BenBen AWS Team

    Team Member

    @ibrennan

    I've replied to your message in the other thread you posted about this in: https://discussions.agilebits.com/discussion/comment/539239/#Comment_539239
    To avoid creating a duplication of efforts please pick one thread about this issue and stick with it. I understand the frustration this issues causes, but posting about the same problem in multiple support threads is not going to help get it resolved, and may delay answers to other folks waiting for help. Thanks for your consideration. :)

    Ben

  • ag_anaag_ana

    Team Member

    I see that you have been replying in multiple places, hence Ben's message. Let's keep everything in one discussion if possible :+1:

  • ag_anaag_ana

    Team Member

    :+1::)

  • Hi @Yaron -

    A quick follow-up on our earlier discussion about the workaround for this 1P bug (see my post from Nov 28, 2019). I just noticed something that (maybe) might help your development team.

    As previously mentioned, if I have a Firefox window open before I try to launch a site login from the 1P app or 1P mini, then 1P works just as it should: my login credentials get entered and all is fine. But if I do not have a Firefox window open, then I end up in this loop of things not working and login credentials not getting filled in. This is the case on all of 6 Macs in our family - not just individual computers. So the work around I have had so far is simply to open a window in Firefox (any window) before I try to use 1P.

    However what I noticed earlier today is that if the window I have open is either the Firefox Add-Ons window (about:addons) or the Firefox Preferences window (about:preferences), then this workaround does not work -- maybe because they are not "real" website addresses, not sure. Anyway I thought that was interesting and thought the 1P dev team might want to hear about it.

    Any ETA on the bug fix ? Happy new year!

  • ag_yaronag_yaron

    Team Member

    Hey @Ashaido,
    Thanks for the additional info! It does make sense because these settings pages are not considered as an active browser window/tab. Nice call though.

    The holidays slowed things down a bit but the deves do have some internal fix they are testing, hopefully it will be released soon and will make things better.
    Keep your apps up to date :)

  • Happy to find this thread! :) I've been seeing this issue for a long while, including the current version 7.4.3. @Yaron, do you know if the fix has been released?

  • ag_anaag_ana

    Team Member
    edited March 9

    @skyblue:

    Please make sure you update to the latest beta of the Chrome extension too if you are still seeing this issue, our developers have published a fix there: https://chrome.google.com/webstore/detail/1password-beta-desktop-ap/phicbbndgmmpogmijjkbmdhpioaieaha
    ;)

  • @ag_ana
    Unfortunately this issue is not limited to Chrome. It was — and still is — an issue with Firefox Mac. I've reported on this previously and have submitted extensive descriptions, diagnostic reports, screen grab videos, etc. to document this (communications with @Yaron). I was (and still am) running the most recent versions of Mac OS, Firefox, 1P app and 1P browser extensions. The issue remains unresolved on my end. I administer 3 Macs in my own household and another 5 Macs for family members — all running 1P and all with the exact same issue/bug as already described in my posts from October and November 2019. The "workaround" that I detailed in a post in December 2019 still works — i.e., making sure another Firefox window is open before trying to open any 1P logins. This workaround does help, but still, it really is not a fix as such. It really would be great if 1P would address this bug — and again, it definitely is not limited to Chrome, which I do not use and do not have installed on my computer... Thanks for your follow-up and thanks for working to support a (in most respects) really fantastic product.

  • ag_yaronag_yaron

    Team Member
    edited March 9

    Hey @Ashiado ,
    The issue that occurs when no browser windows are open looks identical, but it is a different issue and the developers are working on it separately. That issue indeed affects both Chrome and Firefox, and the workaround is to have an open browser window before trying to "Open and Fill" from the desktop app.

    The autofilling issue where trying to autofill from within the browser is one that affects Chrome only and was resolved with the beta extension.
    Thanks again for all your help on the matter!

  • Hi @Yaron, Thanks for the update and follow-up :):)

  • ag_yaronag_yaron

    Team Member

    Don't mention it :chuffed::+1:

  • Sounds like a systematic error in 1Password 7.

    What is the solution?

  • ag_anaag_ana

    Team Member

    @dmrgnacnt_runbox_com:

    Can you please confirm what browser this is happening with, and what version of the 1Password app on browser extension you are using? Thank you!

  • Thanks for your rapid response!!

    Firefox 80.0.1 (64 bit) and at least 1 year of version generations prior.
    1Password 7
    Version 7.7.BETA-9 (70700009)
    1Password Beta

    1Password Ext. 4.7.5.90 (the light grey icon on the firefox tool bar. The one that stays with the browser-dedicated extensions (aka Add-ons, I guess.)

    1Password X (The darker, double-circled icon located at the OS tool bar at the very top of the screen) Can't locate ver. #. I thought I got rid of it a couple of weeks ago, but then it appeared again yesterday.

    Another point. I've been using 1PWD for over 10-yrs. I've loved it. Through all its generational evolutions, I've stuck by it, as have my family members. We've all loved it. As other users have noted, however, 1PWD nomenclature now is so obviously confusing: 1PWD X, 1PWD Ext., 1PWD Addon, 1PWD Mini. It just seems puzzling, why would 1PWD choose to do this? Why does one even need 1PWD X?

    Again, Thanks for your rapid attention.

  • From: dmrgnacnt_run_box. Also, I am running 1PWD on MacBook Pro 13" 2017, 3.3 GHZ i5, OS Catalina. Ver 10.15.6 (19G2021). All up-to-date at time of execution this week.

  • gawgaw
    edited September 25

    @dmrgnacnt_runbox_com I agree with you. As 1Password has grown, more "apps" have been added and it is hard to understand when to use one over the other. I started back in March trying to figure it out and had almost given up. I could never get the 1PWD mini or 1PWD Ext regular to work. So I just use 1PWD 7 on my Mac (tagging and organizing), 1PWD X (saving new pswds and autofill), and the 1PWD web (manage family vaults).

    Curious if the two extensions (1PWD X, 1PWD Ext regular) are fighting each other. Perhaps it is an either/or. Not an AND.

    I don't have the legacy of use that you and others have so it is even harder for you all to either use the old tools that may / may not be getting updated or move to new tools that may not have all the functionality you are use to from the old tools.

  • @dmrgnacnt_runbox_com and @gaw: 1Password X is our newest extension, living completely in the browser without the need for the desktop app. It offers a streamlined Autofill experience with the latest filling and saving Brain. You can learn more about it here:

    https://support.1password.com/getting-started-1password-x/

    If you're using Chrome or Firefox (and have a 1Password membership), I suggest taking it for a spin. I think you'll like the experience.

    Curious if the two extensions (1PWD X, 1PWD Ext regular) are fighting each other. Perhaps it is an either/or. Not an AND.

    @gaw: you do not want to have both extensions running simultaneously. If you're newer to 1Password, I'd strongly suggest giving 1Password X a look. :smile:

  • Hi Ana, Michael, I hope you are well today. Is Michael's response today (4:45 am) intended to be the solution to the originating problem of this thread written by Ashiado in Oct 2019? Maybe I'm missing something, but telling us to "give 1Password X a look" is not a solution to the carefully detailed problem Ashiado brought forward in Oct 2019. In March 2020, ag_yaron (above) indicates this problem is still in the hands of the developers. ag_Ibrennan (Dec 2019 above) seems to point to another thread with the same or similar issue. We users are trying to help make 1Password a better product and want to work with you. We appreciate the challenge for us all. But we need clear answers, guidance and closure to do so. BTW, it's 12 years of use for me.

    As I have identified, the inconsistency in identifying fillins and then filling them in still exists, at least for me--I'm guessing for others too.

    Have the developers found a solution?

    P.S. Note I have found three different types of icons for 1Password that can appear on OS and browser tool bars. Unfortunately I can't post the screenshots in your "comment" space.

  • Hey @dmrgnacnt_runbox_com. I likewise hope you're doing well and staying healthy. :smile: My comment about giving 1Password X a look was more geared towards the comment about the extensions "fighting" each other and the comments about why the different products exist and their place in the 1Password ecosystem. The issue originally described has proven way more complex than originally thought, and so unfortunately we haven't pushed out a fix yet.

    If you do need to submit an image, you can do so here. Just please make sure there's no sensitive information in whatever images you post.

  • I'm sorry, Ana, I am still not finding a solution to my original question. On Sep 25 you requested more information on my system. I supplied that immediately. Can you please give me the status where you are with this question? Thank you.

  • ag_yaronag_yaron

    Team Member

    Hey @dmrgnacnt_runbox_com ,

    ag_michael showed you in the comment above how to add screenshots here so you can show us what you wanted. However, I believe I can explain the 1Password icons you are seeing on your computer screen and what each one of them is:

    • The little 1Password icon in your Mac's menu bar (where the clock and Apple logo is) is called 1Password mini. It is there for quick access to the 1Password 7 desktop app's content, and it also shows you that 1Password is running in the background. You can learn more about what 1Password mini is good for and what you can do with it here: https://support.1password.com/1password-mini-mac/
    • The 1Password icon in your Dock (usually located at the bottom of your screen) is a shortcut icon that will launch the 1Password 7 for Mac desktop app, which resides in your Mac's Applications folder. All the icons in your Dock are basically shortcuts to apps/folders, and 1Password is no different.
    • The 1Password icon on the top right corner of your browser is the 1Password extension. There are currently two extensions available - 1Password X, and the old 1Password extension. As ag_michael noted, we do recommend working with 1Password X, but it is up to you at this point.

    I hope this clarifies the 1Password icons you see across your system.
    As for the original issue you're referring to, can you please elaborate on what is the specific situation you encounter, and what are the exact steps/actions you take to reproduce it? a step-by-step description of your clicks/actions, where you perform them and what are their consequences would be best here.

  • Hi Yaron, Ana and Michael,

    First, I commend you for the work you and your CS colleagues do to help us. We are a grumpy bunch! And we must come across as morons and cry babies. A thankless job I'm sure. Mostly we appreciate 1PWD and want it to work; always we do appreciate you.

    Michael, Thanks for the explanation on adding attachments. An oversight on my part.
    Yaron, Thank you for the explanation of 1PWD icons. I had forgotten to include the one in the doc of the Mac. That's four. I know this is out of your control, but having three forms of 1PWD is just confusing. You've heard it many times I'm sure. We'll all have to live with it for now.

    Yaron, Regarding your request today (above) for "...exact steps/actions..." and "...step-by-step description...", It is less confusing to refer you to the original request initiating this thread by Ashiado, Oct 25 2019, and the dialog in each subsequent record of the thread. I and several others here, and others in other threads, in the past and currently, are all observing the same phenomena: 1PWD desktop, 1PWD-X and 1PWD mini do not consistently fill in the user names and pwds at the points where they are supposed to: they just don't more than they do. These complaints are coming from experienced users--maybe not fully proficient ones--but experienced none-the-less.

    I don't see herein that primary problem in this thread has been fixed, but only "work-arounds" offered, some by CS, some by users. These are cumbersome work-arounds not meeing 1PWD's high standards. I understand that 1PWD-X is problematic and beta versions have not fixed it yet; and that invoking it by "command-period" - with separate pwd entry is annoying and another problem but a fix is in the works. All good. I'm satisfied to leave that with the threads dealing with it.

    Here's a the proposal: Tell us here 1) if the "fill-in problem" is a common problem getting serious attention to correct it, or 2) we represent a minor problem in the 1PWD universe who's solution is esoteric to our systems. In the former case, we'll wait for some future fix; if the later, we'll continue seeking user-specific solutions, possibly too esoteric to continually pester you about with blow-by-blow recounting of our key strokes and the position of the stars. Ha!

    Thanks again! And keep covid-careful.

  • ag_yaronag_yaron

    Team Member

    Hey @dmrgnacnt_runbox_com ,
    Thank you for the detailed reply and kind words :)

    The reason I've asked for your specific description of the issue is because there are several ways to experience it, and these ways occur due to different issues that have a similar result, which is why I need to know the exact play-by-play of your actions so I can offer the most fitting solution.

    This is indeed a known issue(s) in the current version of 1Password, but the workarounds are rather easy to use and I'm sure the confusion you're experiencing can all be sorted out with a proper explanation of the setup you currently have.

    In order to move forward, you can either provide me with the details I need, or I can just list all possible reasons for this issue here and all of their solutions, then you can pick and choose the one that fits your scenario best. I'd rather to address your specific issue though, so it would really help if you can answer the following:

    • Which browser are you using? What is its version?
    • Which 1Password extension is installed in your browser? If more than one, please list them and their versions here.
    • What are the exact steps you take that trigger the issue? Are you trying to open and fill a login entry from the 1Password desktop app? Or are you already in your browser and trying to open and fill from the extension icon on the top right corner? The more details and information here - the better.

    Thanks again for your patience on this matter, I'm sure we're one clarification away from helping you out here :)

  • Hi Yaron,
    Thank you for your immediate response. I want to help solve this. I understand software issues are extremely complicated and details are needed to diagnose. Therefore I will make every effort to accurately provide you with as much step-wise detail in the various contexts in which the "Fill in inconsistencies" are occurring in my system. I will need at least a week to work it in my schedule. So please keep this case (thread) open while I work on it.
    Thank you and have a great week!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file