1Password mini keeps disappearing in the last beta (7.4.738) [Fixed in 7.4.741]

edited February 2020 in Windows Beta

After the last update, when the workspace locks, I click the Firefox extension icon, the login screen with Windows Hello authentication window is correctly displayed, but after unlocking the workspace, the mini app windows is shown only for a split second and then disappears.

This occurs with all of firefox extension icon, system tray icon, and firefox context menu option. Also, it happens randomly, sometimes the window stays open.

Screencast of the bug is below.


1Password Version: 7.4.738
Extension Version:
OS Version: Windows 10
Sync Type: n/a



  • After the latest version installed today, the Firefox extension no longer works. The icon is there and when I click on it, I am prompted for my master password, but there is no text cursor. I am able to type in the password and dismiss that screen, but the 1password menu never drop-down. There is a small progress spinner the first time and then it just blinks like it wants to load but it is failing.

    Windows 10 Pro 1909 - 18363.592
    Firefox 72.0.2

    Can't downgrade to previous version of 1P, says database format is different.

    Tried Edge Dev - works fine, but different extension which also updated when I launched it. Text cursor shows when entering password and menu appears.

    1Password Version: 7.5.738
    Extension Version:
    OS Version: Windows 10 Pro 1909 - 18363.592
    Sync Type: Cloud

  • Just noticed that 1P is definitely trying to open, you can see a faint outline of the program drop-down from the icon in Firefox, but it is quickly dismissed. Stuck copying and pasting logins and password - not fun.

  • bundtkatebundtkate

    Team Member

    I'm not having any trouble with this myself, @njitman. If you fill with your keyboard shortcut instead of clicking the icon in your toolbar, does that work? I'm wondering if it's technically working and some sort of rendering issue ...

  • It is definitely a rendering issue. I switched to 1Password X for the time being to get functionality. That is working fine, renders and CTRL-period works fine. So I uninstalled 1PX and installed the regular 1P FF extension. Now the text cursor is back and it renders. I know I uninstalled the extension and reinstalled it as part of standard troubleshooting, so not sure what is going on. But it is working!

  • njitmannjitman
    edited February 2020

    So I switched over to Firefox Developer, which I have not touched. It still has the regular Firefox extension installed from before. It does not render or fill in forms with CTRL backslash. The icon does not open to the menu and it just blinks the textbox that has focus.

  • Well - it stopped working in regular Firefox as well. So I am back to 1P X in both regular FF and FF Dev.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @finwe, I've merged your thread here because both of you are using Firefox with identical issues.

    I'm testing both Firefox and Firefox Nightly on two separate machines, I'm not seeing any issues like that. In fact, Sergey, our head Windows dev uses Firefox mostly.

    Just to be clear, if you close Firefox and open 1Password mini with Control + Alt + \, it appears fine? As soon as you open Firefox, it starts glitching?

    Could you guys send us your 1Password diagnostics report; use this guide to generate the report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • The issue seems unrelated to Firefox for me, it happens even when Firefox is not running, when clicking the 1Password tray icon, as I wrote, and also when using the keyboard shortcut.

    The Diagnostics report I just generated is empty, so I guess there is no reason to send it.

  • MikeTMikeT Agile Samurai

    Team Member


    when clicking the 1Password tray icon, as I wrote, and also when using the keyboard shortcut.

    Right, I just need to make sure because if Firefox is running, it can still affect both in a way.

    The Diagnostics report I just generated is empty, so I guess there is no reason to send it.

    That's odd. Was 1Password locked at the time?

    Try to generate it again to see if it fixes itself.

    If not, open 1Password, and go to the Help Menu > Troubleshooting > Show Logs. Can you zip up the logs folder and email that to us instead.


  • The workspace was unlocked, tried generating 3 times, always a ZIP with a 0 byte file.

    Sent zipped logs for a last week to the support e-mail address.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @finwe,

    Did you get an auto-reply from our BitBot? If yes, it should have a support ID, can you tell me that here? I cannot find your email and I checked all of the emails, not even anything found for finwe either.

  • No, I haven't received any reply, not even to spam.

  • MikeTMikeT Agile Samurai

    Team Member

    Just to confirm, you've sent it to [email protected], right?

  • MikeTMikeT Agile Samurai

    Team Member

    @finwe, we got the logs, there was an network outage at our support vendor, so we didn't get all of the emails right away.

    ref: LPE-62482-896

  • I switched over to 1P X because the regular FF 1P extension simply does not work after updating to 7.4.738 on 01/31/2020. 1P mini from the system tray works fine as does the 1P app. In Firefox, the regular 1P extension prompts for the master password but there is no text cursor, so there is already an issue prior to authenticating. Prior to version 7.4.738, the master password textbox has a standard blinking text cursor. So, I enter the master password and that box is dismissed. When I click on the 1P icon in FF, a very faint shell of the drop-down menu is shown overlaying the FF main window and then it rapidly goes away. I tried this on both FF and FF Dev and across 3 laptops that are all synced to my FF account - so when I make an extension change on one laptop, it is automatically reflected onto 2 other laptops. The 2nd windows laptop has the same issue whereas the MBP does not. So, I switched to 1P X extension which is not my favorite on windows because it is not integrated with the win app and therefore you have to enter the master password every time you close and re-open the browser. I can try reinstalling the regular extension and sending diagnostics. Let me know the process.

  • Just a follow-up, when you click on the 1P FF extension icon, the browser just blinks, so you know something is going on, but it is failing. Even using the keyboard shortcut, nothing is filled and the browser just blinks.

  • I wanted to go back to the previous version but 7.4.738 performed a database change that eliminates the downgrade option.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @njitman,

    In Firefox, the regular 1P extension prompts for the master password but there is no text cursor,

    Are you using a non-HiDPI / low-resolution monitor by any chance? I think that's a known Windows + .NET 4.7 (which we updated to in this beta) glitch with the missing text cursor sometime with regular DPI monitors. I believe the next monthly .NET update is supposed to fix it but I cannot be 100% sure. However, that doesn't explain the other glitches just yet.

    Can you email us your 1Password diagnostics report that I asked for earlier or are you not able to generate the report either?

    7.4.738 performed a database change that eliminates the downgrade option.

    We backed up your database before the database migration starts, so we can help you switch to the stable version with that database but we really need your help to figure this glitch out as no one on our team is able to reproduce this glitch on any monitors with Firefox or other browsers. At the moment, we only have two reports out of thousands of users using the beta right now.

  • Uninstalled 1P X and installed current version of 1P FF extension. Same behavior. Clicked the 1P icon in FF several times after signing in - browser blinks. It does accept the master password but no text cursor. I am using a Surface Book 2 - very high res display, so the graphics issues should not apply. Sent the diagnostic report to the email address requested.

  • I am OK with using 1P X in the meantime. I just leave the browser open all day - not a huge inconvenience. Where it is a problem is when I am debugging apps in a browser and IIS Express opens a new browser window every time, which requires me to enter the master password repeatedly if the app has a login page. That is just a local issue for me.

  • Another weird behavior is every time I click the 1P icon in FF, it does not show the menu, but it does scroll the page. I will see if I can capture of video of it so you can see what I mean. Like this forum page is several scroll segments down. If I click the 1P icon in FF, it will scroll the page up one segment at a time, just like I was clicking in the scrollbar.

  • See screen recording of me clicking the 1P FF icon and the browser scrolling.


  • MikeTMikeT Agile Samurai

    Team Member

    Hi @njitman,

    When we bring up 1Password mini, we have to simulate clicking the mouse on 1Password mini to focus it. If you or something else clicks outside, 1Password will just disappear because it got defocused.

    Your video looks like the mouse click went through without any window appearing and I think it clicked the scroller bar, thus the scrolling glitch you're seeing.

    The question is why is 1Password mini not rendering, especially since our code specifically says only send the mouse click when it is rendered first, so there's something wrong with what .NET or Windows is telling 1Password.

    very high res display, so the graphics issues should not apply.

    Which scaling % factor are you using on your SB?

    Can you switch to 100% and see if it changes anything?

  • OK, the graphics is the deal. Although I said I was using a SB2, FF opens on my second monitor, which is 1920x1080, 100% scaling. When I move FF window over to SB2 display, 1P mini displays. A third monitor connected to the same SB2 has the same res and scaling as the 2nd monitor and equally fails to display 1P mini. On my second laptop setup, same deal, external monitor at 1920x1080, 100% scaling.

  • But this is a new behavior introduced by 1P change in version, unless as you mention it is a .NET bug exposed by the new 1P version.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @njitman,

    During all of these testings, did you have all monitors connected? Can you temporarily disconnect all, test to make sure it is working fine on a single monitor, connect another monitor, test and see if it is working or failing right off the bat.

    I have two monitors but not able to reproduce it. We don't have any developers with three monitors, so I'm wondering if it is breaking on 2nd or third for you.

  • With just the SB2 only (no external monitors) or SB2 + 1 or 2 external monitors, it works on the SB2 display. I disconnected all external monitors and it continues to work on SB2 display. When I connect the 2nd monitor and move FF over to that monitor, 1P mini does not open and I get the scrolling effect. Same for the 3rd monitor (if I connect it as the 2nd) and same if I have all 3. If I change the external monitors to 125% scaling, the issue goes away and 1P mini opens. I can scale FF down to 90% to compensate. It is a workable solution, except that it makes any app running on those monitors larger, reducing real estate for working.

  • Confirmed 1P mini works for both external monitors set to 1920x1080, 125% scaling. 100% scaling introduces the issue.

  • Switched back to 1P regular extension in FF for windows and Mac laptops. All working as previously, except had to change scaling on the external monitors to 125%. I sometimes connect one of those external monitors (#2) to my MBP instead of SB2, depending on what I take when traveling, since monitor #2 is a portable monitor (GeChic 15" connected via mini-DP). I don't expect the second monitor issue to track to the Mac, since it sounds like you have identified .NET 4.7 as the culprit and 1P 7.4.738 switched to .NET 4.7 - is that correct?

  • I do notice difference from other FF extensions. 1P mini drops down to the right of the icon, such that the window edge is not aligned with the icon. Other extensions I use (Authenticator, Multi-Account, Containers, RESTer, etc.) all drop-down their menu right below the icon. Because 1P drop-down to the right, I believe that is what was enhancing the scroll bar issue - guess what I am saying is that during the 100% scaling issue, the 1P mini menu is actually off the screen, causing the scroll bar to trigger.

This discussion has been closed.