1Password desktop integration is not working

I am having issues with the desktop integration. I have a brand new mac running MacOS Catalina 10.15.4, chrome 81.0.4044.138, and 1Password X Beta 1.20.0. 1Password X has never successfully connected with the desktop app, and I have to manually put in my password to 1Password X Beta every time. In the past on my old computer, I have done a full reboot of the computer and this has solved it. On my brand new mac I haven't been able to get it to connect at all. I've tried restarting. I've tried disabling the integration, signing out of 1Password X, signing back in, then re-enabling 1PasswordX Beta desktop integration, and still nothing works. Any ideas?

1Password Version: 7.5
Extension Version: 1.20.0
OS Version: MacOS Catalina 10.15.4
Sync Type: Not Provided
Referrer: forum-search:desktop


  • ag_anaag_ana

    Team Member

    Hi @exile44! Welcome to the forum!

    If you are using 1Password for Mac version 7.5, make sure you actually install the beta of the desktop app (the latest beta version is 7.5.1.BETA-0): desktop app integration can only work when you are running the beta of both the desktop app and 1Password X.

  • thanks, forgot that you needed both BETAs. seems to be working now

  • kaitlynkaitlyn

    Team Member

    I'm glad to hear that, @exile44! If anything else comes up, please let us know. :)

  • Why hasn't this feature rolled to live, I don't want to run Beta Bits!! Please.

  • BenBen AWS Team

    Team Member

    I can appreciate the excitement for the feature @buckZor. I'm using it extensively as well and really appreciate the convenience of being able to unlock once and have that apply both to 1Password X and 1Password for Mac. I wish I had more encouraging news to share, but all I can say at this point is that it isn't quite ready yet and we're not trying to rush it. As soon as we feel it is ready for prime time we'll push it out to a stable release. :)


  • @Ben are there any new issues? with the most recent versions of the beta, it seems that it's stopped working. I don't even see a setting in 1PasswordX Beta about enabling the desktop integration anymore. I could have sworn there used to be a toggle there. I'm on 1Password 7.7.BETA-5 and 1 Password X 1.21.3. Can't say exactly when it stopped working, seems like it was about a week ago.

  • nvm, just saw the comment about removing it, quite a bummer...

  • ag_anaag_ana

    Team Member
    edited August 21

    Sorry for the disappointment @exile44. As the announcement says though, we are working on something that will work even better :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file