1Password X beta chrome extension is completely unusable

I've restarted Chrome multiple times and am still unable to login. When I enter my password the lock icon animates briefly as if verifying my password, and then doesn't log me in or display any errors. I have not changed my password recently. I've switched over to the non-beta version for now which seems to be working fine.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: OS X 10.15.4
Sync Type: Not Provided


  • phantom4phantom4
    edited June 2020

    Same for me as well. Looks like the extension was updated to version 1.20.2 today and that's when my problems started. I've seen this problem on 2 machines (MacOS 10.15.4 and 10.14.6). Both systems are running Chrome 83.0.4103.97. I also switched back to the non-beta version which works fine.

  • Similarly broken on Firefox also.

  • edited June 2020

    Same, after today's 1Password X beta installation, version 1.20.2: in the Chrome extension settings I've a problem with "missing connection with desktop app" warning.

    Reproduced with last desktop app beta 7.6.BETA-3 (70600003), macOS 10.15.5 (19F101).

    Chrome version 83.0.4103.97.

    No any issue on the desktop app.

  • kaitlynkaitlyn

    Team Member

    @purienne @phantom4 @awilchak @wizard86pz – Thanks for getting this on our radar! I wonder if this has to do with the 1Password for Mac beta, as that was recently updated too. Can you try the following steps for me?

    • Hold down the option key and click the 1Password icon in the right side of your macOS menu bar and select Quit 1Password Completely.
    • Right click on the Chrome/Firefox icon in your dock and select Quit.
    • Open 1Password.
    • Open your browser.

    Go ahead and visit 1Password X's settings by right clicking the 1Password icon in your browser toolbar and selecting Settings. Do you see an error on that page? If so, please share a screenshot with me here if you wouldn't mind.

  • edited June 2020

    Hi @kaitlyn, doing all the things listed, in that order, I've NO any warning of any error in the chrome extension settings.

    After the last point, I've

    • closed the settings of the extension
    • pressed on the extension icon to open it, using my fingerprint, but nothing happens, after the fingerprint request is closed
    • opening again the extension settings I've the this view, that means "impossible to establish a connection with the desktop app"

    Additional info: the fingerprint mechanism works, because the desktop app is unlocked if I open it from the macOS menu or in the dock, launching the app opening.

  • Same error (PasswordX: 1.20.2 Mac Desktop: 7.5) . However, It works when I disable "Integrate with 1Password Desktop Application"

  • ag_michaelcag_michaelc

    Team Member
    edited June 2020

    @jonashaspasswords: Integration only works with both apps being the beta versions—so you need to update to 7.6.BETA-3, from 7.5 (stable), to use Integration. That said, if this breaks 1Password X like the others above you, that's still not ideal.

    For anyone who's running into these issues, I'd like to ask you to save a console log from your browser and send it our way:

    Saving a Console Log

    Attach the log to an email message addressed to [email protected].

    With your email please include:

    That way we can "connect the dots" when we see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once we see the logs we should be able to better assist you (or know what issue to report to our development team, if necessary). Thanks very much!

  • Hi - I've got the same problem

    I've been a long time user of 1Password Mac client but using 1Passwordx Beta in Chrome Extension

    Please keep me updated

  • @ag_michaelc I've done all the necessary steps, and sent the extension console log. The assigned support ticket ID is: [#RPI-11446-788]

  • @damien1 if you mind it, you can send logs as I've done, following the instructions here: https://discussions.agilebits.com/discussion/comment/562369/#Comment_562369

  • Hi @wizard86pz already ahead of you thanks ... ticket id [#FCH-49743-922]

    but i couldnt see anything in the console when i was trying to unlock / click on the unlock icon

  • I see a lot of problem in the console log about extension and desktop app communication.

  • damien1damien1
    edited June 2020

    ... and randomly ... it's working again

    (but on checking there was a plugin update today)

    thanks guys :)

  • @kaitlyn @ag_michaelc - after last update to 1.20.3, nothing changed to me, and I still see the same error as here: https://discussions.agilebits.com/discussion/comment/562354/#Comment_562354

  • ag_michaelcag_michaelc

    Team Member

    @wizard86pz, it looks like my colleague Nhat has replied to your email. Let's continue the conversation there moving forward. 🙂

    ref: RPI-11446-788

  • ag_michaelcag_michaelc

    Team Member

    @damien1, I'm glad to hear things are working for you in the latest beta. We did identify an issue with unlocking and pushed out a hot fix this morning. :smile:

  • And after last update of extension to 1.20.4, now all is ok.

    CC @ag_michaelc

  • ag_anaag_ana

    Team Member

    Thank you for the update @wizard86pz! I am happy to hear this :)

This discussion has been closed.