1Password 7.6.776 beta, NVDA doesn't announce on the unlock view


Team Member
This discussion was created from comments split from: 🎉 1Password 7.6 for Windows Beta 1 is here with Watchtower notifications support..


  • Hi :)

    I use the NVDA screen reader as I am blind. Trying the bete and the unlock window isn't being announced properly and using the keyboard to navigate it doesn't seem to work. Pressing the "alt" key when the unlock window is up fixes it for me. Once unlocked, everything seems fine and navigation through the menus is faster.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @UberJase,

    Thanks for writing in. I've split your post into its own thread, so we can help with your issues directly.

    I'm testing with NVDA 2020.1 and when I bring up 1Password lock view, it does announce that 1Password is locked but it doesn't say the second string. I just tested with Windows' Narrator and it does repeat both strings for me.

    I checked my NVDA settings and I found that if I turned on the Report object descriptions option in the Object Presentation setting, it does announce the second string which is: One Password is locked enter your Master Password edit protected.

    Can you confirm that is to be the case for you?

  • Hi @MikeT
    Firstly thank you for the reply
    I tried changing the setting in nvda and there was no change. I then did a factory reset on nvda and still no change.
    I brought up the 1password unlock screen with my brother beside me(who can see) and he told me that it does fill in the password when i type but nvda announces the keys i press instead of stars.
    I also tried narrator and that works fine.

  • bundtkatebundtkate

    Team Member

    Could you share the version of NVDA you're using, @UberJase? It's admittedly been a bit since I was last looking into accessibility issues, but it wasn't too long ago that the update Mike is using was relatively new, if my memory isn't failing me. Might be this is something that was fixed in a more recent update.

  • Hi @bundtkate
    I was using NVDA 2020.1. 2020.2 beta 1 was released today and the unlock screen in 1password acts the same, although navigating through the item list is now much faster than it was using NVDA 2020.1. The previous non-beta version of 1password works fine on the unlock screen and both versions work in narrator.

  • bundtkatebundtkate

    Team Member

    Do you have any Windows updates available, @UberJase? None of us are able to reproduce this, but one of our development team did mention to me he remembers similar issues a while back that were resolved by a later Windows update. It's worth checking for updates directly and just making extra sure none are available. If any are offered, try installing them and let me know if behavior changes.

    Also, if you edit an item and type in the password field, are those characters announced as well? Any other software in addition to NVDA, such as Speak, that might allow for announcing password characters?

  • I think I've solved the problem. I was using the espeak synthesizer. I switched to one core and it seems to work most of the time so far.

  • Forget my last comment, after some more experimenting I've found how to get it to work with NVDA every time. I have to press the keys to bring up the unlock screen at exactly the same time. For example, if I press the shift slightly before the control and backslash, the window pops up but nvda doesn't seem to focus properly.

  • bundtkatebundtkate

    Team Member

    Very strange, @UberJase, but I'm glad you were able to sort it out. Does any of your other software use some combination of Ctrl, Shift, and \ to execute a task? Just a theory of what might lead to focus troubles.

This discussion has been closed.