Can't get Safari Technology Preview to work with 1Password

2»

Comments

  • As a product manager at a tech company myself, I 100% understand. But hey, if you don't ask, you don't get :chuffed:

  • ag_anaag_ana

    Team Member

    Asking never hurts @pauldunlop :):+1:

  • ruanruan
    edited July 2020

    7.7 beta just dropped for me and instantly solved the problem. Thank you!!!

  • ag_anaag_ana

    Team Member

    Thank you for the update @ruan! I am glad to hear this :)

  • Yay! Just tried and all working. Boom - amazing work 1Password team. Thank you! Loving the new inline form support in Safari (just migrated from Chrome, so presume that's one of the new things that came out of WWDC?)

  • mirvmirv Junior Member

    Got the 7.7 beta today and preliminary results with Safari Tech Preview are looking good. Login/pw info is getting filled correctly, in the correct window of the correct app! The cmd-\ shortcut seems to work fine. You guys are amazing.

  • ag_anaag_ana

    Team Member

    @mirv:

    You guys are amazing.

    Thank you for the kind words! :)

  • edited July 2020

    btw- same occurring with 7.7 beta as of right this moment. Would you like a dump from my setup here? And by 'same' I mean same errors/not working. I'll try a full uninstall / reinstall as per previous

  • BenBen AWS Team

    Team Member
    edited July 2020

    Yes please do try an uninstall/reinstall and then if that doesn't work please send us a diagnostic report. :+1:

    Edit: Note, Safari / STP should be quit completely before attempting to reinstall 1Password.

    Ben

  • @Ben - yep, I did, quit everything, deleted, reinstalled. Also tried disable extension, quit STP, quit-all-1password, trashed, rebooted, reinstalled 1Password... same.

    Just took a diagnostic w/ the tool and emailed.

  • BenBen AWS Team

    Team Member
    edited July 2020

    Thanks. :)

    Ben

    ref: RCM-33261-493

  • BenBen AWS Team

    Team Member
    edited July 2020

    Hi folks,

    As a follow up here, 1Password is not going to be able to work in Safari Technology Preview on macOS Catalina. It does seem to be working in STP on the Big Sur beta. I apologize for the difficulty. There isn't anything we're able to do on our end on this one.

    Ben

This discussion has been closed.