Read first: Previous version support information


Firefox 80.0: 1PX extension goes away

Hello.
My Firefox just updated to 80.0. It seems 1Password X addon is getting removed from the browser soon after it is installed. It happens within 10-15 minutes after it is installed. I had it installed before the FF update and saw it wasn't there anymore when I first ran the browser after the update. I reinstalled the 1PX extension and it goes away after 10-15 min.
The only thing I've changed in the 1Password X settings is for it to not lock automatically and for it to be available in Private mode.

As I work around, I've installed the companion app extension. I'm not sure if the companion app will disappear. But I will update the discussion thread if it does.


1Password Version: 7.6.780
Extension Version: 1.21.0
OS Version: windows 10 Version 1903 (OS Build 18362.1016
Sync Type: 1password families

Comments

  • GregGreg
    1Password Alumni

    Hi @JOeMTC,

    Thank you for reaching out!

    Could you please make sure to disable Always use private browsing mode option in Firefox on your side and check if the issue remains? 1Password X needs access to the local database to function properly and that's the issue with private browsing mode, I am afraid.

    If you installed 1Password companion extension, it should not behave like 1Password X. Let me know how it works for you. Thanks! :+1:

    ++
    Greg

  • JOeMTCJOeMTC
    Community Member

    Cool Makes sense. It's all good. Probably better for security to not let it work in Private mode. I was waiting for it to disappear and it didn't with the "Always use in Private browsing mode" is unchecked.

  • GregGreg
    1Password Alumni

    @JOeMTC: Cool beans. I am glad to hear that it works correctly now. :)

    Let us know if you have other questions, we are always ready to help. :+1:

    ++
    Greg

  • JOeMTCJOeMTC
    Community Member

    Thanks @Greg
    Have a good one!

  • bundtkatebundtkate

    Team Member

    On Greg's behalf, @JOeMTC, you are most welcome. Enjoy! :chuffed:

This discussion has been closed.