Safari Extension not opening in latest Mac OS Big Sur Beta

bryanschmiedelerbryanschmiedeler Junior Member

I have been running Mac OS 11.0 since about beta 3 and all has worked fine, including with the Safari 1Password extension.

The latest beta might have caused an issue. When I click the Safari Extension nothing happens. If I click the menu bar 1Password item then I get the screen that tells me to turn on the 1Password Safari Extension. I check and it is turned on already. I turned it off and on. I also reinstalled the 1Password extension, and restarted the computer, etc. No joy.

Is this a known issue?


1Password Version: 7.6
Extension Version: 7.6
OS Version: Mac OS 11.0 20A5374g
Sync Type: 1Password

Comments

  • ag_anaag_ana

    Team Member

    Hi @bryanschmiedeler!

    This is indeed a known issue if you are running Big Sur beta. Our developers are aware of this, and we will try to make sure this is addressed before Big Sur is officially released to the public :+1:

  • bryanschmiedelerbryanschmiedeler Junior Member

    That is fine.

    Thank you.

  • ag_anaag_ana

    Team Member

    You are welcome @bryanschmiedeler! Thank you for your understanding :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • A workaround for this is to go to the 1Password menu bar item, choose "Quit 1Password Completely" and then re-launch it. Then it will work in Safari.

  • BenBen AWS Team

    Team Member

    Thanks for adding that @TJLuoma. :)

    Ben

  • Of course what I'm trying to figure out is how to automate it, but I'm hoping the problem is solved before I figure that out :-)

  • BenBen AWS Team

    Team Member

    🙏🏻

    Ben

  • neokanneokan Junior Member

    Any updates on this issue? Would running the beta fix it in the interim?

  • BenBen AWS Team

    Team Member

    @neokan

    If you're running the Big Sur beta it probably does make sense to run the 1Password beta as well, though this specific issue has not been addressed. :+1:

    Ben

  • neokanneokan Junior Member

    Thanks. I was able to get it working by following TJLuoma suggestion above.

  • BenBen AWS Team

    Team Member

    Glad to hear it. :) Thanks.

    Ben

  • really frustrating that it does not work at all with Safari in Big Sur. Everything is up to date on my machine and 1password simply does not work. Has the bug not been fixed with the full release? Click on the extension and simply nothing happens, don't even get prompted to unlock 1password. Already did the "quit completely" and reopen workaround and it still does not work.

  • DidikoDidiko
    edited November 20

    Still no solution in sight?

    Discovered that the "open and fill" command in 1P application itself does not work anymore either!?

  • ag_anaag_ana

    Team Member

    @alle0409, @Didiko:

    I would like to ask you to generate a diagnostics report from your Mac and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Finally everything is more or less working fine (except "open and fill" on some websites but this is probably linked to the website itself).

    I had to completely shut down my Mac PRO and this morning it seems ok.

    It was a bit stressful as I keep all my 400+ logins in 1P...

  • ag_anaag_ana

    Team Member

    @Didiko:

    I am glad to hear that a reboot helped fixed things for you :) And thank you for the update! :+1:

  • DidikoDidiko
    edited November 21

    Actually, it had to be a complete shutdown, the reboot did not fix the issue ;-)

  • First thing old computer pros try. Power-cycling solves a world of problems for all kinds of gizmos. It's also helpful in establishing a consistent base condition from which to try various fixes to deal with a given issue.

  • ag_anaag_ana

    Team Member

    Indeed :+1::)

  • edited November 22

    I have a similar problem.
    Problem: field shows the 1Password icon, right click options:

    • Show 1Password mini
    • Hide 1Password on this page
      So

    • no autofill anymore

    • if you click Show 1Password mini, it suggests to"unlock 1Password" but if you click that, nothing happens

    macOS Big Sur vs 11.0.1
    1Password 7 vs 7.7 (70700016) Mac App Store

  • ag_anaag_ana

    Team Member

    @HalfBekend:

    no autofill anymore

    Does the new 1Password inline menu appear for you when you click on a username or password field?

  • edited November 22

    In the mean time I quitted the 1Password mini (via status bar right top of the display)

    Please describe the 1Password inline menu?
    What I see is the fields to be filled in with on the right side the 1Password- icon (with a little padlock).
    Then it asks me to Unlock 1Password (button).

    Now it does unlock and fills in the userid and pwd.

  • ag_anaag_ana

    Team Member

    @HalfBekend:

    Now it does unlock and fills in the userid and pwd.

    That is good to hear :+1: Let us know if this happens to you again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file