Idle timeout not honored with Mac Beta 10

With the latest beta update, 1Password now locks immediately when the display sleeps if an idle timeout is set and "Lock on sleep" is unchecked. I've attempted to toggle through all of the options, but the behavior remains:

1) Enable only "Lock after computer idle for ___ minutes"
2) Sleep the machine

Upon wake, 1Password is immediately locked.


1Password Version: Version 7.7.BETA-10 (70700010)
Extension Version: Not Provided
OS Version: OS X 10.15.7
Sync Type: 1password.com

Comments

  • Gilles9Gilles9 Senior Member

    There may be an issue here
    Not the same as the original poster
    but my set up here is lock after 30 minutes, it does not since beta 10

  • Gilles9Gilles9 Senior Member

    I can confirm. 1password never lock after hours of inactivity

  • ag_vendruscoloag_vendruscolo

    Team Member
    edited October 2

    Hi @SpaethCo and @Gilles9, thanks for taking the time to report your feedback. This helps us improving our apps :+1:

    I was able to replicate the original issue on my machine, and I've filed an issue to keep track of it. While I can't promise any date, I'd like to ask you to keep an eye on future release notes. :smile:

    @Gilles9 I tried setting it to lock after being idle for 1 minute, and 1Password locked shortly after that time passed. Can you please try lowering that value and see if it effectively locks? I wonder if there's anything else on the system that makes it think it's active.

    Keep us posted, thanks!

  • Gilles9Gilles9 Senior Member

    fixed with rebooting

  • ag_anaag_ana

    Team Member

    Thank you for the update @Gilles9! It's good to hear that a reboot fixed this for you :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file