Unlock with Apple Watch in Beta 10

edited October 2020 in Mac Beta

Since I updated to Beta 10, I've not been consistently able to unlock with my Apple Watch, in Safari, Chrome, and the desktop application.

Before this update it was working fine.

If I go in and turn off the Unlock Using Apple Watch option and turn it back on, it works for that day.
The next day, the same thing again. Click the 1password logo, it's asking for my master password and there is no Apple Watch logo at the bottom.
I do have it set to require the Master Password every 1 day, but before when I would unlock for the first time of the day, but the Apple Watch is offered as an option for all times after that. This is no longer consistently happening.

Example: This morning when I started work I went to open 1Password, and it didn't prompt for the the Apple Watch.
I typed in my Master Password.
For a number of times after that throughout the day I was prompted to use the Apple Watch to successfully unlock.
Now when I try, it's back to requiring the Master Password again.

Did something change with this behavior?


1Password Version: 7.7 Beta-10
Extension Version: 70700010
OS Version: OS X 10.15.6
Sync Type: 1Password Account

Comments

  • Realized instantly that I posted this in the wrong topic. Should be under Mac Beta. Sorry.

  • Confirmed that dropping back to Beta 9 resolves the issue.

    Also I can confirm that even on Beta 10, the Apple Watch still works for Mac-native unlock functions like entering the system password and unlocking the Mac itself. This seems to be enough to isolate the problem to something with Beta 10 specifically, and not with my Mac or Apple Watch.

  • ag_tommyag_tommy

    Team Member

    @mlangsottile

    Development is aware of a few issues that appeared in beta 10. Hopefully, they can get a new beta out to address those issues sooner rather than later. Yes, Apple Watch unlock seems to be one of those issues from what I have seen.

  • Any update on this? The beta has been out for a while now and this is definitely frustrating!

  • @ssgelm,
    A new beta is likely going to be released early next week, so please keep an eye on the release notes. In the meantime, you can downgrade to beta 9 as it shouldn't be affected by this issue.

    Thank you for your patience!

  • edited November 2020

    @ag_tommy @ag_vendruscolo This problem is still present in Beta 11.

    Also, I can't downgrade to Beta 9 where it was working anymore because after installing it just shows a "Beta Expired" dialog and the only option is to get the latest beta. Not ideal.

  • @ag_tommy @ag_vendruscolo I unchecked Unlock using Apple Watch and then re-enabled it. Like with Beta 10, that was enough to trigger the ability to use the feature right now, but I'll keep an on eye on things to see if the option to actually use the feature disappears again tomorrow (which was the original symptom).

  • BenBen AWS Team

    Team Member

    Thank you for the update. Please keep us in the loop. :)

    Ben

  • @Ben @ag_tommy @ag_vendruscolo Confirmed that the issue remains the same in Beta 11:
    Disabling and re-enabling Unlock using Apple Watch will allow that feature to work for the day.
    The next day, rather than just requiring the Master Pass once to re-allow the feature, it completely stops appearing as an option for unlocking the vault (No Apple Watch logo visible at the bottom of the unlock screen).

    Seems the only way to get it to show again is to manually repeat the disable->re-enable process.
    I'm going to try changing my settings for when to require putting in the password again to more than a day (even though that was my ideal setting) to see if the issue is dependent on that process and setting it to something like a week will let the feature work for more than a day at a time, or if that will make no difference at all.

  • BenBen AWS Team

    Team Member

    @mlangsottile

    Is the computer managed by an IT department at all? I'm wondering if perhaps MDM is getting in our way here?

    Ben

  • @Ben This is my personal Mac, so not connected to MDM or any IT department management.

  • nagymnagym
    edited November 2020

    Same problem as @mlangsottile, and can also confirm the same fix works by disabling and re-enabling unlock for a day. Same issue next day. Not on MDM either, and this issue has been ongoing since Beta 9. Can also confirm Beta 12 does not fix the issue. Please do advise if the crash log would be of help.

    On a high level, it's an EXC_BAD_INSTRUCTION error on com.apple.main-thread, with thread 0 (culprit) process identifier being libswiftFoundation. The specific task seems to be a protocol witness for Error._domain.getter in conformance (CFErrorRef + 35). Looking back in Console, since these crashes began it's been consistently the same thread with the same exception.

    Out of curiosity, are you guys testing at all on macOS 11.0.1? That seems to have been released around the same time as the troublesome beta, wondering if the two may be correlated.

    @mlangsottile are you on 11.0.1 as well?

  • The macOS 11.0.1 Release Candidate seems to have — knock on wood — potentially resolved this & some other Swift bugs, or at least I’ve been crash free despite best attempts to replicate earlier crashes.

  • Beta 12 has been released, and it includes a fix for an issue that prevented a menu item ("Unlock with Apple Watch") from being enabled if you had the lid closed. This doesn't have any effect on the issue we're discussing here.

    @mlangsottile I re-read your original post and would like to ask a few questions that might help us investigate this. Is your Mac a MacBook? If so, do keep the lid closed? And lastly, I get that the lock screen doesn't show any button (not even TouchID) below the Master Password field. Is this correct?

    Thanks

  • @ag_vendruscolo 2018 Mac Mini, so no lid and no TouchID.

    That is correct. The button is there when the feature is first enabled and works as expected. The next day: no button there at all, it’s not automatically offering the unlock with the normal dialog, and it seems there’s no way to bring it back except fully disabling and re-enabling.

  • Thanks for the details @mlangsottile

    What you see it's the intended behavior. If you set 1Password to ask for your Master Password once a day, when the 24 hours window closes, you'll have to type your Master Password again, effectively disabling (any form of) biometry unlock. I just tried on my MacBook (which is equipped with TouchID) and when the Master Password timeout expired, TouchID button (although there) did nothing. Unlocking by typing the Master Password reset the timer, and subsequent unlocks are allowed to happen using biometry.

    This means that what you were able to do with previous betas, although convenient, was just wrong. That "require Master Password every" setting is there for your security.

    Lastly, there're some reasons for which the button might not be there at all. For example, if you're not waring the Watch or it's locked, we don't show the button.

    Let me know if you have any other question :)

  • @ag_vendruscolo

    Let me clarify because there seems to be confusion:
    Once this happens, entering the master password on the unlock screen never brings the Apple Watch button or the unlocking feature back.

    Only going into the Preferences -> Security and fully turning off Unlock with Apple Watch, and then turning it back on will make it work again.

    What you describe was the normal behavior that I was experiencing before Beta 10. I had to type my password once a day, and then could use my Apple Watch to unlock for subsequent uses that day. Once the Beta 10 update was installed, it’s been misbehaving by seemingly permanently locking out biometry by the next day.

    Yesterday I changed the "require Master Password every" to 1 week as a test and it still has permanently locked out biometry by this morning.

    Also, you'll want to note that when I was still able to drop back to Beta 9, that completely resolved the issue. I waited for Beta 11 to try again, and the behavior was broken exactly as it was in Beta 10. I no longer can drop back to Beta 9 because when installed I get a "Beta Expired" dialog that won't let me do anything except update to a newer beta build.

  • @mlangsottile thank you. Just to make sure, is it happening on beta 12 too? I'd also love to understand whether you're hitting one those situations in which we explicitly hide the button as we wouldn't be able to perform Apple Watch unlock.
    Is the Apple Watch on your wrist, and unlocked?
    Are you perhaps keeping the main window always visible? We update the window's UI when it's activated, so if for some reasons (for example: Apple Watch is locked) we determine that we're not able to perform Apple Watch unlock, we hide the button. But then, if you unlock the Watch, we'll not update the UI until you activate the window. In this case you'd need to briefly switch to a different app and then back to 1Password to give us a chance to update the UI. Closing and re-opening the window is fine too.

    Let me know, thanks!

  • @ag_vendruscolo

    Apple Watch is on my wrist and unlocked. It can still successfully be used to unlock my Mac itself as well.
    In most cases I am in a browser, and I'm clicking on the 1Password logo to open the extension (as stated in original report, this is true for both Safari and Chrome).
    I usually only open the desktop application when I need to manually make changes to something in a vault, but I have tried that for testing purposes and the result is the same as in the browsers.

    I wasn't having any issue at all with it in Beta 9 and earlier. If my behavior has not changed, that would mean something had to have changed in the application itself pertaining to the activation/focus change of the windows, between Beta 9 and 10. If that's not true, then what you're proposing about the UI refresh isn't likely the problem I'm running into.

    I am in the middle of the work day so I have still been on Beta 11 so far. I don't normally install a new beta midday just in case it causes significant problems.
    I will do that now, but I won't know whether the problem persists until I try to use the Apple Watch to unlock tomorrow.

    I'll report back here with results on Beta 12.

  • Hey @mlangsottile thank you. If you're still facing the same issue while using Beta 12 I'd like you to grab a Diagnostic Report.
    You can create this report by following these instructions:

    https://support.1password.com/diagnostics/?mac

    When you're done, please mention this discussion in the body of your diagnostics email before sending it.

    Thanks!

  • @ag_vendruscolo Issue is still occurring on Beta 12 so I'll be submitting the diagnostic report shortly.

  • ag_tommyag_tommy

    Team Member

    @mlangsottile

    Development released Beta 13 yesterday evening. Can you update, and if you continue to experience the issue, submit a report?

  • @ag_tommy Issue is still present in Beta 13. I just sent an updated diagnostics report to the support email.

  • ag_tommyag_tommy

    Team Member

    Thank you. :chuffed:

  • NebesNebes
    edited November 2020

    I haven't got around to posting anything, but I haven't been able to successfully unlock with watch since maybe Beta 8? I can't confirm the timeline, since I wasn't keeping a detailed record, but think it might correlate with upgrading to WatchOS 7. I'm currently on the stable release, with no improvement. I've confirmed that I can unlock my Mac with the watch, but disabling and re-enabling 'unlock using Apple Watch' multiple times, including just now, hasn't made a difference. Any suggestions on what to try?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file