Bad image error message, reinstall not possible

1password app on Win10 stopped suddenly to work probably giving me This error message
This box requires like 10x clicking on the X to get rid off. The Ok button doesn't seem to do anything.
Not sure which version exactly I had before attempting reinstall, 7.6.x definetly since the system is a fresh reinstall from ca 2 weeks, so whatever version was out then must be the initial install.
Removed the app via windows. Downloaded latest installer, 7.6.785 and tried to install that and get the same message by the installer. (I have force-quit the application before that). The funny thing is, the app installs.

I should mention that clicking the away the error box does render the app usable but the error message comes back after a while.

All in all pretty annoying.

Don't have issues with browser extensions though.

Any suggestions?


1Password Version: 7.6.785
Extension Version: Not Provided
OS Version: Win10Pro 20H2
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @rhenium! Welcome to the forum!

    I would like to ask you to generate a diagnostics report from your PC and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Thanks and done.
    Support ID: [#PQY-42797-819]
    PS: I guess "reinstall not possible" is technically incorrect, the app is there, but it installs giving the same error message.

  • ag_anaag_ana

    Team Member

    @rhenium:

    Thank you! I confirm that I have managed to locate your diagnostics report in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: PQY-42797-819

  • ag_mike_dag_mike_d

    Team Member

    Hi @rhenium! I'm happy to hear that my suggestions helped to resolve this issue! As discussed via your ticket, thought it'd be a good idea to have some details in this thread for others that may run into a similar error.

    In this particular case, it was noted that another program was also throwing this same error (with the same .dll file). Using Windows System File Checker (SFC), @rhenium was able to repair/re-install this Windows .dll file, which in turn, resolved this "Bad Image" error with both the other program and 1Password.

    Thanks again, @rhenium!

  • Thanks for your fast reply and working through this issue. Much appreciated.

  • ag_anaag_ana

    Team Member

    On behalf of ag_mike_d, you are welcome @rhenium! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file