1P systray right-click behaviour

hawkiihawkii
edited January 2 in Windows

Hello, this is related to a query I previously posted about 18 months ago (https://1password.community/discussion/105704/1password-7-systray-behaviour). I would tack this onto the end of that thread but the discussion is now closed.

1Password is still the only icon in the 20+ or so in my systray that opens its content menu in the bottom-right corner of the primary display, and not in the corner of the screen next to the icon - as demonstrated in the screenshot on the previous post.

Every other app opens the right-click content menu either in the bottom corner of the screen the systray is located in, or at the point of the click. 1P pops the content menu up so far away from the cursor you wouldn't even realise anything had happened most of the time. It does not feel at all natural or conducive to a good workflow.

Since the previous post other than 1P and Windows updates the differences are:

Monitor 1 is now an AOC AGON AG241QG4 G-Sync compatible, 2560x1440, 144hz
Monitor 2 is an LG Ultrawide 2560x1080, 60hz. This monitor contains the taskbar and systray.
Graphics card is now a GeForce GTX 2080 Super (driver 460.89, but it's been doing it on every set of drivers since I installed 1P7)

Is there any chance you could make 1P act in the same way as every other app does? Thanks.


1Password Version: 7.6.785
Extension Version: Not Provided
OS Version: Win10 build 19041.685
Sync Type: Not Provided

Comments

  • BlakeBlake

    Team Member

    Hey there @hawkii 👋

    Even after attempting to reproduce the issue you're seeing again this morning, we're still not having any luck in doing so. In your previous post you mentioned that changing which monitor was set as "Primary" fixed this issue for you, is that still working?

  • Yup, switching the secondary monitor containing my taskbar as the "main display" results in the 1P right-click context menu reverting to behaving as I'd expect it to.

  • BlakeBlake

    Team Member

    Thanks for letting me know!

    This will continue to be the best workaround for the time-being, until we're able to determine why you're seeing this. You mentioned in your prior thread that you're running DisplayFusion, which is likely to add to the funny issues we're seeing.

    Are you still using DisplayFusion by any chance? Does disabling DisplayFusion fix things?

  • Yeah I am still using it, it's fully up-to-date. I tried disabling it after trying the primary monitor thing again yesterday, it made zero difference, still experiencing exactly the same behaviour.

  • BlakeBlake

    Team Member

    @hawkii

    Me and team will continue to attempt to reproduce this to see if we can narrow down what it might be, but based on your reports, this sounds like something that only you are capable of reproducing consistently..

    I'll be sure to pass our findings along to the development team as we find them, and I'll update you here as well if we're able to reproduce this ourselves moving forward.

  • I’ll try playing around with disabling anything else I can think of that might vaguely affect it, but as I say this is specific only to 1P, I can’t get any other app to produce the same behaviour

  • BlakeBlake

    Team Member

    Definitely let us know if you find anything of interest out, this one is certainly one that we can use any and all information we can get our hands on. 😊

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file