1PasswordAnywhere: 1Password.html file not written to Dropbox


New to the forums. I have recently started using 1password for iOS and wondered if there was a webapp to access my stored passwords. I've noticed there is a feature called 1password anywhere but I'm not clear as to whether it is only available for the desktop version of the app. I have enabled dropbox synching but the folder doesn't contain a html file.

Please let me know if this should be available to me.




  • thightowerthightower T-Dog Agile's Mascot
    edited January 2013
    Hey Eoghan

    I personally think its easier to get started on the Dropbox site. You can find the html on the desktop app. Its just a little harder. Lets get you started and then we can do more complicated things. :)

    Go to the Dropbox web site for example and look for the 1Password folder.

    Its like this Dropbox > 1Password (folder) > 1Password.agilekeychain (folder) > 1Password.hmtl


    You cannot take the html file outside the folder as it needs the info inside the folder to work properly.

    More info http://support.agile...-with-a-browser
  • Thightower,

    As I said, I don't have a html file at that location in the 1password folder; when I navigate there, I only see a folder called "data" and there are no html files anywhere in the 1password folder. I am guessing this is because 1password anywhere is only available for the desktop (Mac or Windows) version of the app and not for the iOS only version which I run. I am hoping someone can give me a definitive answer on this. If I should be able to access 1password via dropbox, I may need some assistance in figuring out what is going wrong with my installation.


  • thightowerthightower T-Dog Agile's Mascot
    Mmmmm I am pretty sure it should get created even using the iOS version. khad (admin) should be around in the the next day lets see what he says. I am not sure of his days off.
    Ill also send him a message.
  • edited January 2013
    I have precisely the same problem.

    It does not matter how I access DropBox, whether from Safari, from within 1Password or wherever.

    I have a folder named '1Password', which open to a folder called '1Password.agilekeychain'. When that is opened I have one folder named 'Data', and that contains no HTML file.

    I have 1Password on iPhone 4S and Ipad (4th gen), and am using Windows 7 and latest release of Safari.

    Having read a number of threads, I do not have a 'file repair' option on either my phone or iPad.

    I was thinking of buying 1Password for Windows, which how I got here, but I'm concerned that some functionality is missing from the newly purchased and downloaded 1Password App.

    This is not a 'I cannot open the HMTL file' question, but rather 'there is no HTML file'.

    Thank you

  • khadkhad Social Choreographer

    Team Member
    edited February 2013
    Welcome to the forums, Eoghan and Chris! Thanks for taking the time to contact us. I'm sorry that you are having some trouble.

    I was just able to reproduce this problem. For some reason the 1Password.html file required for 1PasswordAnywhere does not appear to be written to Dropbox by default in 1Password 4 for iOS.

    However, there is a simple solution.

    1. Make sure Dropbox syncing has completed in both 1Password on your iOS device as well as your desktop computer.
    2. In Finder on your Mac or Windows Explorer on your PC, make a copy of your existing 1Password.agilekeychain data from your Dropbox folder on your desktop as a backup.
    3. Enable iTunes File Sharing in 1Password on your iOS device (Settings > Sync).
    4. Open iTunes on your desktop computer and drag the 1Password.agilekeychain file from iTunes File Sharing to the 1Password folder within your Dropbox folder (overwriting the existing copy). Complete steps are in the User Guide if you need them.

    The copy of 1Password.agilekeychain you just dragged should contain the 1Password.html file which will allow you to use 1PasswordAnywhere as expected.

    I'll file this with the developers (RM4184) so we can get this resolved in a future update. The 1Password.html file should be written directly to Dropbox as part of the data file. This workaround should not be required.

    If we can be of further assistance in the meantime, please let us know. We are always here to help!
  • edited January 2013

    I'm glad it wasn't me doing something wrong! I really was starting to doubt my own sanity and intelligence.

    Thank you for the workaround, and I now have the function sorted.

    Obviously, these things happen in software development but they do cause confusion at this end. I appreciate the prompt response which allows me to get such a lot out of this valuable app.

    Hopefully, now the issue has been identified you can rectify it, and other users can see the (temporary) workaround.


  • khadkhad Social Choreographer

    Team Member
    It is my pleasure to help. It will definitely be resolved in a future update. I'm glad the workaround did the trick for you for now. :)

    Enjoy the rest of your week!
  • suewsuew
    edited March 2013


    I have just purchased 1password for IOS but am trying to get 1password anywhere to work on my windows pc,just "in case" i need access in the future. I have synced with dropbox and the chain is visible but there is no html file to click on. I am using firefox to view dropbox. I would be most grateful if you could point me in the right direction as I am paranoid about needing my passwords if I were to loose my phone.

    Many thanks

  • khadkhad Social Choreographer

    Team Member

    Hi suew! I moved your post to the iOS category and merged it with this existing thread. Please see my post above for an explanation and workaround until this issue is resolved.

  • Thanks Khad much appreciated. Sorry to be dense but just to confirm, how would I go about getting my passwords if I needed them on a pc that I couldn't sync with. For example if I went away for a few days didn't have my laptop with me and had my phone stolen? Presumably I would then not be able to access anything.

  • khadkhad Social Choreographer

    Team Member
    edited March 2013

    You were on the right track. You can use the 1PasswordAnywhere feature (accessible via that HTML file inside 1Password.agilekeychain) to access your 1Password data in any modern browser on a machine where you do not have 1Password installed.

    There just happens to be a bug right now where 1Password for iOS doesn't create the HTML file. You can either wait for the next update which will fix the issue or use the workaround I outlined in my post (#6) above. Then you will have an HTML file via which you can access 1PasswordAnywhere.

    Please let me know if you still have any other questions. :)

  • Thanks again, I think I might have to wait for the fix, don't want mess things up. I would just like to say how impressed I am with customer service. In my opinion this more than justifies the purchase price over free apps.:)

  • khadkhad Social Choreographer

    Team Member

    Thanks for your kind words! We'll work hard to get the update published in a timely manner. :)

  • Had followed the instructions under "Back up your 1Password data through iTunes" (http://learn.agilebits.com/1Password4/iOS/Sync/iTunes-File-Sharing/itfs-move-to-pcs.html) to have a backup from iPhone. Noticed that when I saved the "data" file to the PC, there is a directory containing a file called 1password.html and then a sub-directory with various files but no "1Password.agilekeychain".

    Had tried to add the 1password.html to iPad according to the step "Restore the data to your other iOS devices" (http://learn.agilebits.com/1Password4/iOS/Sync/iTunes-File-Sharing/itfs-ios.html). However, only the Master password present (i.e. need the Master password to login) but there's no entry inside the 1Password for iPad.

    Do I need to add each of the files in the sub-directory or miss something else?

  • khadkhad Social Choreographer

    Team Member

    Hi, AceOps! I moved your post to the iOS category and merged it with this existing thread. Please see my post above for an explanation and workaround until this issue is resolved.

This discussion has been closed.