1Password 7 Mac Beta 6 not working with non-Beta Microsoft Edge

Microsoft Edge non-Beta, so regular release, has been updated to be native with M1/Apple Silicon Macs.

Microsoft Edge is valid and notarized.

Using 1Password 7 Mac Beta 6 and get that it can't verify the identity of the browser.

Microsoft Edge downloaded from:
https://www.microsoft.com/en-us/edge
Version 88.0.705.56 (Official build) (64-bit)


1Password Version: 7.7.1.BETA-6 (70701006)
Extension Version: Not Provided
OS Version: macOS 11.1
Sync Type: Not Provided

Comments

  • Forgot to say that I closed both apps completely AND rebooted.

    Waited for 1Password to fully startup, then tried Microsoft Edge, same message.

  • ag_anaag_ana

    Team Member

    Hi @forumuser599! Welcome to the forum!

    I remember that 1Password 7 stable should support Edge stable, and 1Password 7 Beta should support Edge Beta. Since you are running 1Password 7 beta, can you temporarily upgrade to Edge Beta and see if that works?

  • BenBen AWS Team

    Team Member

    @forumuser599

    Please check the following items:

    If all of that is correct and you're still having trouble I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://1password.community/discussion/118555/1password-7-mac-beta-6-not-working-with-non-beta-microsoft-edge#latest
    • Your forum username: forumuser599

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here. Thanks very much!

    Ben

  • @ag_ana Thanks for your response.

    The first thing of note is that 1Password Stable runs in Rosetta. I have an M1/Apple Silicon Mac, therefore 1Password 7 Beta should be used as it has been built with M1/Apple Silicon support. To add to that, Microsoft Edge Stable no longer runs in Rosetta, it is now native to M1/Apple Silicon. My only thought on this interaction is that 1Password Stable worked with Microsoft Edge Stable because they both ran in Rosetta with no support for M1/Apple Silicon, but now that Microsoft Edge Stable runs native and 1Password 7 Stable runs in Rosetta, there may be a disconnect with 1Password being able to check the validity of the new Microsoft Edge Stable build.

    Microsoft Edge Beta is no longer the current version as the Beta version has been frozen and made Stable with the additional feature sets of the Stable version. Those feature sets are what I use between Mac and Windows, so when that was released, it made things alot easier for production. According to Microsoft Edge Insider, the next Microsoft Edge Beta version will be released next week, which I believe is coming from the Dev build, possibly Canary.

    Sorry for the explanation before getting to your question. I have tried 1 Password 7 Beta 6 with Microsoft Edge Beta and it also gives the same message.

    I am going to completely uninstall both 1Password and Microsoft Edge and reinstall, just to check that trying the different versions hadn't left something that might be interfering with one another.

  • @Ben Thanks for your response.

    I did check the items listed and all are correct with a JSON file living in the appropriate NativeMessagingHosts directory.

    I am going to completely uninstall 1Password and Microsoft Edge and cleanup any remnants that may be left behind, then I will reboot and reinstall 1Password Stable and Microsoft Edge Stable. After doing this, I will respond to this discussion with my findings and if it did not work, then I will also respond with the Diagnostics Report.

  • ag_tommyag_tommy

    Team Member

    @forumuser599

    Sounds good!

  • @ag_ana @Ben @ag_tommy

    I have great news!

    After uninstalling both Microsoft Edge and 1Password, deleting any remnants from my ~/Library folders, and then restarting. I did the following:

    1st Trial - 1Password 7 Stable and Microsoft Edge Stable
    1. Install 1Password 7 Stable and verified that the Extension Helper process was running
    2. Install Microsoft Edge Stable and the classic 1Password extension (not 1PasswordX)
    3. Extension was working successfully!

    2nd Trial - 1Password 7 Beta 6 and Microsoft Edge Stable
    1. Install 1Password 7 Beta 6 and verified that the Extension Helper process was running
    2. Install Microsoft Edge Stable and the classic 1Password extension (not 1PasswordX)
    3. Extension was working successfully!

    In short, after cleaning something that might have been left over from previous installs, 1Password 7 Stable AND 1Password 7 Beta 6 are working with Microsoft Edge STABLE!

    I am glad that I am able to use 1Password 7 Beta with the now native M1/Apple Silicon Microsoft Edge Stable. I should have remembered to clean out any remnants and restart the machine before truly considering this a bug.

    At least for 1Password, it's now good to know that Microsoft Edge Stable is native on M1/Apple Silicon and works with either branch of 1Password! :)

    Thanks for a great product!

  • ag_anaag_ana

    Team Member

    Thank you for the update @forumuser599! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file