1P wallet missing types, icons

Hi,

When creating a new item under "wallet", I used to be presented with many different types of "cards" (drivers licence, credit card, etc). Now I see only three: Membership, Passport, and SSN. Existing entries of the missing types still exist, but they have no accompanying icon. I cannot create new items of the missing type.

This began when I migrated the 1P data file to a new laptop. What has happend? How can I fix this?

Thanks.

Comments

  • Hi there,

    How did you transfer the actual 1Password app? The templates for those cards are within the app, so it sounds like the app got damaged.

    Could you try reinstalling it and see if it'll work?

    1. Visit the 1Password download page
    2. Click on the Download Now button under 1Password 3
    3. Quit your web browser and 1Password, if it's running
    4. Drag the newly downloaded version of 1Password to the Applications folder -- replacing the old copy of 1Password
    5. Run 1Password at least once and then your web browser

    Your information is stored in a data file separate from the application, so it will not be harmed by this procedure.

    I hope this will fix the problem, please let us know.

  • troubleshooter
    troubleshooter
    Community Member

    Thanks Mike,

    Originally, I transfered the directory ~/Library/Application Support/1Password from my old laptop to my new one. I downloaded a new application from your site.

    I've also tried your instructions, as well as clearing the cache and rebuilding the data file. This hasn't fixed the issue. Any other suggestions?

  • troubleshooter
    troubleshooter
    Community Member

    Followup:

    I still have my old laptop, and I just double-checked to make sure 1P wallet is working ok there. It is. All my wallet items are there, all have correct icons, and clicking "+" brings up "Add New Item" with all the options I expect (not just the 3 listed above). To be certain, I copied the 1P binary (version 3.8.20 build 31499) from my old laptop to my new laptop, closed 1P and browsers, and ran the old binary. The result is the same: missing icons and options in the wallet. Just to be extra sure, I ran an md5 over both binaries and they're identical. So I believe the issue is with the data file, not the 1P binary.

    Unfortunately I have made too many changes to my 1P data since migrating laptops and I don't want to go back to my old data file. Can you suggest a way to repair it?

  • Hi @troubleshooter,

    It shouldn't be affected by your data file, the templates for the items are stored within the main application bundle, your data file are just a bunch of data with a template ID to fill into the template that the app builds for you. That's why the reinstall should've fix this, the bundle may have been corrupted if it was moved improperly, but it's not the case here.

    It looks like we'll need to see your diagnostic report to get an idea of what's going on. Can you open 1Password and go to the Help Menu > Troubleshooting > Diagnostics Report, then attach the entire file to an email to us at [email protected].

    Please add a link to this thread in the email body, so that we can connect the dots.

    Thank you!

This discussion has been closed.