Cannot use autofill in Google Chrome

LagPickLagPick
edited February 15 in 1Password in the Browser

I cannot use autofill in Google Chrome in the latest version. I simply don't show the account list.


1Password Version: Not Provided
Extension Version: 1.23.0
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • kaitlynkaitlyn

    Team Member

    Hey @LagPick! 👋

    Thanks for getting in touch. What happens when you click the 1Password icon in your browser toolbar? Do you see the pop-up along with a list of items to fill on the current page you're visiting (if you have any stored)?

  • Yes, they are still there. The issue only happens with the password boxes' autofill.

  • ag_anaag_ana

    Team Member

    @LagPick:

    Can you please post a screenshot of what you see exactly when you click on a password field? I am curious to know if you at least see the 1Password icon inside the password field.

  • LagPickLagPick
    edited February 16

    Something like this!

  • ag_yaronag_yaron

    Team Member

    Thanks for the screenshot @LagPick .

    This means 1Password either doesn't have a login item for this website, or that your login item for Gmail has a different domain in the URL than the page you are currently visiting.

    I believe the latter is the case here, so please make sure the domain of the login page of Google is identical to the domain that is listed in your login item:
    1. Open your 1Password.
    2. Find the login item for your Google account and select it to view its information.
    3. Under the username and password, you'll see the website URL. Make sure that it has the same domain name as it appears in your browser's address bar when you visit the page.

    If you are on "accounts.google.com" in your browser when you log into your Google account, but your login item has "gmail.com/login", then these are two different domains and is the reason why 1Password doesn't suggest this item when you visit the page. Edit your login item and copy the URL from your address bar into the website field in 1Password so that 1Password will know to suggest this login item on that website/page.

  • Hi. I have been using 1Pasword for a few years and I know how to use it. I use this login form every day and I have at least 20 items.
    This happens randomly. That's why I only report it now after 2 weeks of trouble.

  • ag_anaag_ana

    Team Member

    @LagPick:

    For confirmation, what is the value of the website field in this Login item that is not showing up?

  • LagPickLagPick
    edited February 17

    I wonder why you still try to prove that I don't know how to use 1Password instead of investigating the issue from your end? Your support is the reason why I choose your product to use but why It becomes so bad now?

  • ag_yaronag_yaron

    Team Member
    edited February 17

    Hey @LagPick ,

    There are very (very) few reasons why a login item won't show up on a website, and we're going over them with you right now. If we had any other lead we would also pursue it, but this is the only one that makes sense at the moment until we get the answers we're looking for.

    Your screenshot contained some personal info so I removed it. But I did investigate it before doing so and you did not show the URL of the login item in that screenshot, so I wasn't able to determine whether or not your login item has a URL that matches the website's URL you were visiting.

    Can you please take another screenshot, but this time when you open 1Password and select an item, scroll down a bit (below the username and password of the item) so we can see what is the URL that this login item contains? Also, please censor/blur out any personal info like your email address. Alternatively, you can send it to us privately via email if you prefer: [email protected]

    https://us.v-cdn.net/5020219/uploads/editor/iq/f96heou87z8k.png

    Thank you for your patience and cooperation on the matter. Looking forward to hearing from you.

  • LagPickLagPick
    edited February 21

    SCREENSHOTS REMOVED

    Here are they.

  • ag_yaronag_yaron

    Team Member

    Thanks for the additional screenshots @LagPick .

    The first screenshot of Facebook shows that 1Password identifies the page as a registration page rather than a login page. What happens if you click the "Suggestions" under the generated password and select "Logins"? Does it suggest your logins then? Also, I noticed that your login item for Facebook has HTTP and not HTTPS in the URL, I'd suggest you edit it and put in HTTPS in it.

    When you're on Facebook's main login page (and not this page that in your screenshot), do you get proper suggestions? You can reach it by logging out of your account and logging back in.

    On the 2nd screenshot of Google, it does seem like it should work, unless the vault these logins are in is hidden in 1Password's settings:

    1. Right click the 1Password icon on the top right corner of your browser and select "Settings".
    2. Scroll to the bottom of the settings page and check if all vaults and accounts there are enabled. If one of the vaults/accounts is disabled, that may be why you are not getting suggestions from it. Enable it back on.
    3. Test and see if you are now getting suggestions when visiting these pages.

    Let us know what you find.

  • LagPickLagPick
    edited February 21

    What happens if you click the "Suggestions" under the generated password and select "Logins"? Does it suggest your logins then?

    --> No

    Scroll to the bottom of the settings page and check if all vaults and accounts there are enabled.

    All were enabled.

    Just to let you know that all the accounts are still there if I click to the 1Password extension icon.

  • ag_yaronag_yaron

    Team Member
    edited February 21

    Thanks for the additional info @LagPick .

    There are two things we should check here - Whether or not this happens with a new login item, and whether or not this happens in a clean environment.
    For the first test, simple save a new login on Facebook or Google's login pages (you can use made up credentials for this test). After you saved a new login, refresh the page and see if 1Password suggests that new login.

    If 1Password did suggest the new login, then we'll have to dive in deeper into your existing login items to see why they are not being suggested while new logins are working properly.

    In case 1Password did not suggest the new login, let's try things in a new user profile for a cleaner environment:

    1. Create a new user profile in your Chrome: http://support.google.com/chrome/answer/2364824
    2. Switch into the new user profile.
    3. Install only 1Password in that new profile: https://support.1password.com/getting-started-browser/
    4. Test and see if 1Password still does not suggest your logins on these pages.

    Looking forward to hearing the results.
    Thank you for your patience on the matter, we'll get to the bottom of this eventually :)

  • Hello @ag_yaron I'm sorry for my late reply. Since this happens randomly so I need to try to reproduce it.
    After removing the extension and reinstall it, I cannot reproduce the issue anymore. Both Facebook and Google site autofill work correctly.
    Will update you as soon as I can reproduce it again.

  • ag_anaag_ana

    Team Member

    Sounds good @LagPick, thank you for the update!

  • Found it!

    • I tried to login from admin.google.com
    • Google will redirect me to https://accounts.google.com/ and ask me to login
    • Pick my account on the list of "Choose an account"
    • Notice that autofill doesn't work on login screen
  • ag_anaag_ana

    Team Member

    @LagPick:

    Thank you for the instructions! I have tested your steps and I was able to get 1Password to fill my email on accounts.google.com, even after being redirected there from admin.google.com, so this should definitely work for you too. At this point I wonder if there is something in your browser that is interfering with this.

    Do you have other extensions installed? Have you tried testing this in a new Chrome profile, with just the 1Password extension installed?

  • I installed a lot of extensions actually. Will test with a new Chrome profile and update to you.

  • ag_anaag_ana

    Team Member

    Perfect, thank you!

  • Sho here is the result:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file