Newbie having lots of issues

AngelfireAngelfire
edited February 22 in iOS

Hiya folks. I'm in my first day of my trial period and having some issues. It doesn't help that I'm also trying to learn the Apple system on a new MacBook Pro. It's probably also not helping that I'm integrating PC/IOS/Mac at the same time. I would really appreciate any insight to these issues.
1. Regarding Twitter, both the IOS app and Safari (on the phone/iPad). I keep getting "an error has occurred. Please try again later (Bad Request)" when I use 1P to populate the username/password fields. Any ideas?
2. When I visit a site to log in, I get pinged by 1P asking if I want to add this to my vault. That's great except it asks me 3 times. I enter a Username, I get pinged. I enter the password, I get pinged, then I log in and get pinged again. What's worse is if I say Yes to the username request, I see a new entry in my vault that only has a username and no password. Similarly, if I choose yes for the password, but not the username, I only get a password. It seems the only way this works is to fully log in and then respond to the request by 1P to save the entries....is this normal?
3. While trying to log into a bank site, I went to change my password to increase it's security. With the issues shown in item 2 above, I ended up with multiple entries for this one site. I deleted all of them and started over. Used 1P to create a password for me and things seemed ok until I checked it out in the vault. The password had been severely truncated to the point it was no longer very secure......why did this happen?
4. Not necessarily related to 1P but I'm considering making this a family account after I flush out all the bugs and get more familiar with it. Is there a solution out there for the likes of Amazon.....I don't want my Amazon password to be readily available to the rest of the family but yet, I need to have it readily available for the likes of Prime streaming. I suspect this would also be an issue with Google/Youtube as well. I don't believe these large companies with multiple products allow for different passwords for their various offerings but thought I'd ask if anyone has come up with a novel solution.

I thank you in advance for any insights you may have.
Cheers.


1Password Version: 7.7
Extension Version: 1.23.0 (edge);
OS Version: Big Sur, Windows 10, iOS 14.4
Sync Type: 1Password

Comments

  • and another issue just cropped up. Another bank site. First page is where I enter the username. Saved this to 1P. Next page is where I enter the password. 1P would not give me the ability to save the password against the username saved on the previous page. Ugh. So went in and manually updated the username entry in my vault to have the password. Went back to the site. 1P enters the username just fine but then on the next page for password, it has no suggestions. I may have bought off more than I can chew here and may need to just go back to my Excel spreadsheet! :)

  • ag_tommyag_tommy

    Team Member

    @Angelfire

    Try using our instructions to create a logins across multiple pages. That may help resolve that problem.

    Save a login for a website where the username and password are on different pages

  • ag_tommyag_tommy

    Team Member
    edited February 18

    @Angelfire

    You're doing well, considering all you are trying to work with. Please pick one issue that you want to work with first and let us know. Then when you're ready, we can move on to the next one.

    I don't want to send you a wall of text and exasperate the frustration you may be feeling. :wink:

  • Thanks. Regarding the login across multiple pages, I followed the instructions completely and it doesn't work. On the first page, I enter my username. 1P prompts me to save this. I did that. Moved to the next page, typed in my password. Clicked the 1P icon to save and it only offers to save it under a new entry, not the one created at the username page. I tried to type in the name of the entry that was saved when I saved the username but all it did was create two entries titled the same in 1P. It did not offer to "Update Existing"

  • ag_tommyag_tommy

    Team Member

    @Angelfire

    Is the site one that you can share with us so that I can try it on this end?

  • AngelfireAngelfire
    edited February 18

    It's a banking page so without a Username for that particular bank, you won't get to the password page. You're welcome to look at the site to see what you think: www.slfcu.org I could also do some screen captures if you think that would be helpful?

  • AngelfireAngelfire
    edited February 18

    Here are a couple images.
    On the first image, you can see 1P is creating a new entry and everything looks good. On the second however, it isn't linking to the entry created at that Username page but instead is creating a separate entry. I've tried this on both the Mac and PC with the same results. Note: The images uploaded in reverse. The 2nd image is actually the Username entry and the first image shows what's happening at the Password page.

  • ag_yaronag_yaron

    Team Member
    edited February 18

    Hey @Angelfire ,
    Thanks for the screenshots and additional information.

    Looking at this website, you start your journey on www.slfcu.org where you enter your username, but then when you need to enter the password, the website sends you to a completely different domain: https://online.banking-slfcu.org/Authentication/QA

    That is why 1Password cannot link between the username page and the password page, they are literally two different websites :)
    However, the fix is simple:

    1. Open your 1Password.
    2. Select the login item for this website and click on the "Edit" button to enter edit mode.
    3. While in edit mode, under the username and password fields you will see the website field that contains one of these website addresses. Under it there will be another website field that is empty. Copy the website address that is not currently present there and paste it into the empty website field, so that both websites will be listed in that login item.
    4. Click on "Save" to save your changes, then try autofilling and see how 1Password suggests the same login item on both pages.

    Here's how your login item should look like when you are done:

  • ahhhh, many thanks! That worked a treat adding the second web address. All good on that front. How about we now try to address the Twitter issue? It works fine everywhere except iOS where I get the error mentioned earlier (Bad Request)?

  • ag_anaag_ana

    Team Member

    @Angelfire:

    Out of curiosity, if you temporarily create a new Login item for Twitter in the 1Password for iOS app, and copy and paste your username and password there, are you able to login without error messages to the website?

  • Hello. Here's what's strange. In iOS, I can see my login information in 1P including the password and all is good. I open the Twitter app and it allows me to use 1P to fill the username field. However, when trying to input the password field, 1P is not populating it. I did a copy/paste from 1P on the password (still in iOS) and put that into Twitter manually and it works fine. I haven't tried to delete Twitter from 1P and then re-create it starting in iOS yet but will. Busy day so probably won't get to it until this evening. Cheers.

  • ag_anaag_ana

    Team Member

    @Angelfire:

    I haven't tried to delete Twitter from 1P and then re-create it starting in iOS yet but will.

    Thank you! Deleting the existing Login won't be even necessary, you could just create a new one manually, and for a little bit keep both, to see if the new one works :+1:

  • Still struggling a bit with the Twitter. creating a new log in did nothing to fix the issue. So I'm back to one Twitter login in 1P that has both Username and Password but as before, when I go to log into Twitter, I get the username fine but no joy on the password. Again, this is only on iOS. I've verified I have Keychain off and Autofill is set exclusively to 1P. hmmmm.

  • Success! I completely deleted Twitter from my vault. Created a new log in manually and now it appears it is working in iOS. Something must have been a bit amiss on the original login created.

    Now, I think most of my issues have been resolved (or I have learned the correct way to do things). One item I'm still struggling with is how to deal with the likes of Amazon/Prime. They only allow for a single username/password which gets you into their shopping site as well as their Prime Video. I want to be able to allow the family access to Prime Video but not Amazon shopping. I suspect there is no solution but thought I'd check to see if there was some novel work around out there. Cheers.

  • ag_anaag_ana

    Team Member

    @Angelfire:

    Success! I completely deleted Twitter from my vault. Created a new log in manually and now it appears it is working in iOS. Something must have been a bit amiss on the original login created.

    Thank you for the update! This is great to hear :)

    Now, I think most of my issues have been resolved (or I have learned the correct way to do things). One item I'm still struggling with is how to deal with the likes of Amazon/Prime. They only allow for a single username/password which gets you into their shopping site as well as their Prime Video. I want to be able to allow the family access to Prime Video but not Amazon shopping. I suspect there is no solution but thought I'd check to see if there was some novel work around out there. Cheers.

    If the account is actually the same for both services, I don't believe there is any workaround: sharing those credentials will allow access to both services. I know this is the way Amazon accounts work, so I don't believe there is much you can do here.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file