1Password Updater fails due to "miscellaneous error"

pimlottcpimlottc
edited March 5 in Mac Beta

I am getting an error dialog pop-up from the 1Password 7 desktop app:

The application "1Password Updater" could not be launched because a miscellaneous error occurred.

When I dismiss it, it comes back again later. I also get the same dialog if I open 1Password and select "Check for updates".


1Password Version: 7.7.1.BETA-9 (70701009)
Extension Version: Not Provided
OS Version: 11.2.2
Sync Type: Not Provided

Comments

  • ag_tommyag_tommy

    Team Member

    @pimlottc

    If you are clicking on the updater icon in the Dock or it is set to run automatically at startup, you will receive this error. The updater is not meant to be run manually. The reason you see the updater at all is because of a part of macOS that keeps recently used items in the Dock. Prior to this macOS feature, users would not have seen the updater and not experienced this issue.

    It's best to check for updates in one of two ways.

    1. From the menu bar at the top of the screen, select 1Password > Check for Updates ...
    2. Open 1Password > Preferences > Updates > Check now

    To remove the updater icon from your startup items, use the following instructions.

    Right-click the Updater icon > options and uncheck the option for "Open at Login". - No checkmark will be present.

    To remove the updater from the Dock. *Recommended

    Click on the updater icon and hold the click. Drag the icon off of the Dock towards the middle of the screen. Once you see the word "Remove" appear near the icon, release the click.

  • pimlottcpimlottc
    edited March 5

    Hi @ag_tommy,

    I am not clicking the updater icon in the Dock, and I have not set the updater to run at startup. I have not done anything to try to change how and when the updater runs. This just started happening on its own.

    1. From the menu bar at the top of the screen, select 1Password > Check for Updates ...

    This is what I meant when I said "if I open 1Password and select 'Check for updates'." I get the same error dialog.

  • ag_tommyag_tommy

    Team Member
    edited March 5

    @pimlottc

    My apologies. Well, let's come from a different point of view and replace the old beta with the current beta version.

    1. Quit all open web browsers.
    2. Look for our helper in the menu bar near the WiFi indicator and the clock. Right-click on the helper and select quit 1Password completely.
    3. Drag 1Password from the Applications folder to the Trash. Do not use an "app cleaner" or "uninstaller" tool to remove the app or additional files. If prompted, enter the password you use to sign in to your Mac.
    4. Restart the Mac for good measure.
    5. Download the latest beta version of 1Password from the 1Password website and install.
  • Okay, cool. That was going to be the next thing I tried, but I wanted to let you guys know about it first.

    So now I've gone ahead and uninstalled/reinstalled; I'm now running 7.7.1.BETA-11 (70701011). Unfortunately, I am still getting the same error message when I select "Check for Updates..." from the menu bar. I'll see if it also happens when the updater tries to run automatically in the background.

  • ag_tommyag_tommy

    Team Member

    @pimlotttc

    I am running the same specs 11.2.2 here and not seeing that behavior. Have you given the Mac a restart lately? Does the message provide you with any error numbers? Maybe a diagnostic report will shed some light on the subject. Could you send one to us?

    How to send a 1Password diagnostics report

    Be sure to include the following information in your submission.

    Your user name here in the forum. pimlottc
    A link to this topic. https://1password.community/discussion/119524/1password-updater-fails-due-to-miscellaneous-error#latest

    • Please do not post your diagnostic report to the forum. This is for your privacy and security.
      The report will be in zip format. Please send the entire file.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file