Browser Integration Not Working

I am unable to get the browser integration working in 8.0.27 using either chrome or firefox. It's worth noting that I am running sway as my window manager (which uses wayland). I had to manually add my accounts and one does not unlock the other, nor does anything I do in the browser open in the app. Could you describe at all how the browser -> app communication works so I can try to figure out what piece is missing?


1Password Version: 8.0.27
Extension Version: 1.24.4.beta
OS Version: Debian Testing (Bullseye)
Sync Type: Not Provided

«1

Comments

  • nake89nake89
    edited March 13

    I cant get it to work either. Very frustrating.

    EDIT: Reinstalled the extension. Now works.

  • Hi there.

    I have a similar issue although I can get some amount of communication between the two. The extension does open the 1password app when I click the icon or use the extension shortcut, but it doesn't seem to pick up whether the app is locked / unlocked, and I can't get the auto-fill to work.

    I'm running on Arch Linux, using i3wm.
    1Password Version: 8.0.27 (from the AUR package)
    Extension Version: 1.24.4.beta (from the link in the pinned "1Password for Linux beta #27" thread)

    No amount of reinstalling / re-linking has worked so far, last test a few minutes ago.

  • BlakeBlake

    Team Member

    Hi everyone!

    We're attempting to reproduce this ourselves internally to see what might be going on. Stay tuned and we will update everyone here shortly!

  • Dayton_agDayton_ag

    Team Member

    Hey everyone, I've been working on reproducing this and 1Password seems to be able to establish a good connection to the extension in Firefox in Arch-based Manjaro. We released a new version of the beta today (.28), could you give the steps below a try and let me know how it goes?

    1. Update 1Password: https://support.1password.com/getting-started-linux/#update-1password
    2. Enable browser communication in the 1Password desktop app (Settings -> Autofill -> Share information with 1Password in your browser).
    3. Quit the desktop app and re-run it.
    4. Open your browser and ensure you're running version 1.24.4 of the extension.

    After a few moments, 1Password should establish contact with the extension, and it should clear the lock icon.

    I look forward to hearing back! :smile:

  • Hi, the browser communication is working for me, on Arch with bspwm, 1Password 8.0.28 and browser extension version 1.24.4 on Firefox 86.0.1. But I noticed that when I lock 1Password through the extension, the desktop client likes to crash. It can also crash when locking through the desktop client itself (but not always). The error message is

    ERROR 2021-03-16T19:35:01.355 ThreadId(23) [1P:ffi/core-node/src/lib.rs:302] Failed to call into Javascript notifier callback
    

    But the biggest issue is that even if it does not crash I can no longer unlock the browser extension until I restart Firefox. It is constantly Loading....

  • Gave it another shot, and the issue has resolved on my end. Not sure if the update has anything to do with it (I don't see anything in the release notes that would indicate any difference in the connection to the browser extension), I tried to do it clean which might have been enough, even though I tried the same process before:

    • Uninstalled the beta extension
    • Disabled the pure browser extension (which used to be 1passwordX but has changed name) that I kept as a workaround
    • Quit the desktop app
    • Reinstall the beta extension
    • Restart the desktop app

    Hopefully the issue resolves for everyone as well. And thanks for the massive effort for the linux community recently, it feels great when an app does not treat us as second class citizens. <3

  • Dayton_agDayton_ag

    Team Member
    edited March 22

    @kRYOoX:

    That's great, I'm glad that the update/clean restart got things up and running for you! Thanks as well for your positive feedback - we're thrilled that we get to bring 1Password to Linux! :chuffed:

    @sjoerdsein:

    I've been trying to re-create this crash on my end, but haven't had success yet. I'd like to grab some more information from 1Password on your device to get a better understanding of what's going on - let's continue our conversation over email. Shoot me an email at [email protected], and I'll follow up with you there.

    When you write in, you should receive an automated response with a conversation ID that looks like this: [ABC-12345-678]. Once you've received it, please paste it here so I can find your email on my end. :smile:

  • Still not working for me. Does the connectivity between the two rely on and particular system process to be running?

  • Update: it also didn't work under gnome running under wayland or x11, so my best guess is that I am missing some expected piece of the connectivity. Would it be possible to explain a little about how the communication between the browser and the app works so I can try and debug it further?

  • nickmcguirenickmcguire

    Team Member

    Heya @sjoerdsein 👋🏼 With the most recent 1Password in the browser beta (1.24.5), 1Password for Linux crashing will no longer leave you in the "Loading..." state.

    Heya @ssgelm 🔎

    That doesn't sound very good, but I'm guessing it could be one of a couple things. To narrow it down, could you send us the logs found in .config/1Password/logs to [email protected] so I can confirm. We have some checks to ensure that the browser is who we expect and our communication helper also has some checks for itself.

  • Hi @nickmcguire, I can still reliably get the extension to hang on "Loading...". The desktop client usually does not crash. Steps to reproduce:

    • Open Firefox
    • Click on 1Password extension icon -> 1Password desktop opens
    • Log in on 1Password desktop -> Extension works as intended
    • Log out of 1Password (Firefox or desktop) -> Desktop client exits
    • Click on 1Password extension icon again -> Nothing happens
    • Click on 1Password extension icon again -> Desktop client may or may not open after a few seconds. If so, log in
    • Click on 1Password extension icon again -> Loading...

    After waiting a few minutes with the extension and desktop client closed and opening the extension again it asks for the password in the extension instead of the desktop client. Closing the extension without logging in and opening again now opens the desktop client and it works again as intended.
    I now have version 1.24.5 of the extension, rest is the same as my previous post. I have not yet contacted support. Should I?

  • nickmcguirenickmcguire

    Team Member
    edited March 26

    Heya @sjoerdsein, would you mind sending the browser extension logs (https://support.1password.com/cs/extension-console-log/) from a time you've made this occur and send it to [email protected] and I'll take a look through it!

    ref: XSC-87737-396

  • OK, the logs helped me a lot. Two separate issues here:

    • I use google-chrome-unstable. 1Password explicitly only looks for google-chrome and google-chrome-beta for installing the NativeMessagingHost config. I worked around this by symlinking ~/.config/google-chrome-beta to ~/.config/google-chrome-unstable which gets the json config put into place.
    • 1Password doesn't support firefox ESR, which is what I am using in Debian. The error is:
      /usr/lib/firefox-esr/firefox-esr isn't a supported browser
      I haven't figured out a workaround for this but I also don't really need to use firefox at the moment so not a problem for me.
  • Dayton_agDayton_ag

    Team Member

    @ssgelm That's great, I'm glad Nick and the logs were able to help get things working for you. Let us know if we can help any further. :smile:

  • @Dayton_ag do you intend to add support for the two browsers I mentioned?

  • Dayton_agDayton_ag

    Team Member
    edited March 29

    @ssgelm, I can't comment on future plans for supported browsers, but I'll make sure to let the Development team know that you'd like to see support for browser integration with google-chrome-unstable and Firefox ESR. :smile:

    ref: /dev/projects/customer-feature-requests/#628

  • It's worth noting that firefox ESR is the only version of firefox that's installable from the debian stable/testing repos so I'd imagine it has a lot of users.

  • Dayton_agDayton_ag

    Team Member

    Thanks so much! I'll make sure that information is added to the internal issue. :smile:

  • @nickmcguire I think I never mentioned that this bug only occurs when I have the setting "Show 1Password in system tray" (app.keepInTray) disabled. With it enabled all works perfectly.

  • Dayton_agDayton_ag

    Team Member

    @sjoerdsein:

    Ah, that seems to be the ticket! I can now reproduce this issue over and over:

    With keepInTray set to False:
    1. Launch the 1Password app and sign in.
    2. Launch Firefox, and click the extension - 1Password data loads.
    3. Lock from the extension - 1Password closes.
    4. Click the extension again - spins for a while, then defaults to standard extension behavior (no integration).
    5. Dismiss extension and re-call it - 1Password desktop launches and requests Master Password.

    Once I re-enable keepInTray, 1Password resumes normal behavior again. Just to confirm, is this the same behavior you're seeing?

  • @Dayton_ag Is there a supported browser list available, or required paths that will pass validation? I'm using Firefox 87.0, and with XBeta 1.24.7 and Linux Beta #32, I'm getting this error in the logs:

    $ cat 1Password_rCURRENT.log 
    INFO  2021-03-31T17:13:16.104 main [1P:native-messaging/op-browser-support/src/main.rs:47] Starting 1Password-BrowserSupport
    INFO  2021-03-31T17:13:16.105 main [1P:native-messaging/op-browser-support/src/browser_verification/linux.rs:24] Verifying browser "/usr/local/firefox/firefox-bin"
    WARN  2021-03-31T17:13:16.164 main [1P:foundation/op-sys-info/src/process_verification.rs:123] binary permission verification failed for /usr/local/firefox/firefox-bin
    ERROR 2021-03-31T17:13:16.170 main [1P:native-messaging/op-browser-support/src/main.rs:52] BrowserProcessVerification(BinaryPermissions)
        Happened in: native-messaging/op-browser-support/src/browser_verification/linux.rs:34
        Additional error context: Failed to verify browser permissions
    
    $ ll /usr/local/firefox/firefox-bin
    -rwxr-xr-x. 1 mroche mroche 507472 Mar 24 16:42 /usr/local/firefox/firefox-bin
    
  • MikeTMikeT Agile Samurai

    Team Member

    Hi @mroche,

    We are checking it in the path of /usr/lib/firefox/firefox.

    Can you tell me how you originally installed Firefox and which Linux distro this is?

    In the next update, we'll be extending support to Firefox-ESR as well (/usr/lib/firefox-esr/firefox-esr)

  • Since different distros often use slightly different paths is there a secure way you could allow adding additional allowed paths in settings?

  • Sorry for the double post there, didn't mean to do that!

    @MikeT My installation is on a RHEL 8.3 system, using the official Mozilla tarball extracted into /usr/local (and renamed the dir to firefox from the long-release name).

    In Fedora and RHEL, Firefox is stored in /usr/lib64/firefox (mainline and ESR respectively, but RHEL doesn't use the -esr naming convention). Having the ability to add custom paths would be helpful.

    Cheers,
    Mike

  • edited April 3

    @Dayton_ag Yes that is the exact behavior I'm seeing, now with extension version 1.25.0. With the steps I posted earlier I started with the desktop client closed. So the behavior depends on whether or not the desktop client is open when the extension is launched initially.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @ssgelm / @mroche: The ability to customize the list is something we're looking into, we're just trying to find something that is safe to do. Stay tuned though, we might have something.

    @sjoerdsein, thanks for confirming that for us. We'll look into this.

  • bpiwowarbpiwowar Junior Member

    I have also problems with browser integration. I updated 1password to the latest version (8.0.33-13.BETA) on ubuntu. Firefox version is 87.0, and 1password addon version 1.25.1

    Looking at the addon log, I just have

    💫 Looking for desktop app com.1password.1password background.js:2:24020
    📤 Sending <NmRequestAccounts> message to native core <1189198548> background.js:2:25555
    Desktop app port disconnected. Error: None background.js:2:24449
    

    No error message is printed by starting 1password with --log trace (apart from problems with keyring), and the browser extension file is installed into .mozilla/native-messaging-hosts/com.1password.1password.json.

    I am not sure where to look to see what is going wrong.

  • Dayton_agDayton_ag

    Team Member

    Hi @bpiwowar, could you confirm that browser integration is still enabled in the desktop app? To check, click your account name in the top-left corner of the 1Password for Linux beta app, then click Settings, and switch to the Security tab. We'll want to ensure that Share information with 1Password in your browser is enabled.

  • bpiwowarbpiwowar Junior Member

    @Dayton_ag yes of course - forgot to mention that; also, with the same settings (same version of firefox and 1password) on my laptop, this is working perfectly fine. The only difference is that I am using gnome on my laptop (where this is working), and i3 on my desktop.

  • MikeTMikeT Agile Samurai

    Team Member
    edited April 8

    Hi @bpiwowar,

    Can you expand on the keyring problems you're seeing, it is required for the browser integration to work.

    Also, what is your Linux setup and which package did you use to install 1Password (snap, appimage, deb, rpm, etc)?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file