1Password 7 Version 7.7 (70700016) Mac App Store won't update to 7.8

When I click on the "Update" button in the Mac App Store for 1Password, an error message pops up that says 1Password must be quit first. I click on "quit" and/or "quit all" and then nothing happens. It just sits there forever. The only way to back out at that moment is to click on the "Ignore" button and clicking on that makes it try to update regardless of its thinking that 1Password is running. Then, another error message pops up, this one saying it couldn't update because 1Password is running. When I go to Force Close in the Apple menu, 1Password is not listed. I've rebooted my Mac and immediately gone to the Mac App Store to update 1Password, but it always pops up the error message that it thinks 1Password is running and needs to be quit before updating.

How can I get around this so that 1Password updates to Version 7.8?


1Password Version: 1Password 7 Version 7.7 (70700016) Mac App Store
Extension Version: Safari
OS Version: 11.3 Beta (20E5196f)
Sync Type: Where do I find this???
Referrer: forum-search:1Password 7 Version 7.7 (70700016) Mac App Store won't update to 7.8

Comments

  • Can confirm. Turned off everything. Rebooted. Just hangs.

  • I’m having the same issue.

  • schmollywoodschmollywood Junior Member

    +1

  • Alfred.DeRoseAlfred.DeRose Junior Member

    +1

  • +1

  • +3 times tried to update and it failed each time

  • ag_anaag_ana

    Team Member

    Hi everyone! Please make sure 1Password mini is not running in your menu bar when this happens. If it is, please try quitting 1Password completely (right-click on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely), and you should be able to complete the update :+1:

  • I have also been unable to update 1Password 7 (Version 7.7 - 70700016 - Mac App Store) to 7.8 on Intel macOS 11.2.2 even after completely quitting 1P as described above. I've tried a few times over the last few days.

  • D'oh - sorry. I restarted my Mac, quit 1Password completely as advised above and then the update applied successfully! So not an Agilebits problem it seems...

  • ag_anaag_ana

    Team Member

    Thank you for the update @michthom! I am glad to hear that you managed to complete the update :)

  • Excellent :) turning 1Password Mini off solved my update issue

  • Completely quitting, including Mini solved it. Too bad the User Experience for this requires this obscure, extra step with no advice about this in the error message. Also, too bad this relatively “simple” fix isn’t highlighted in the FAQ or this Forum’s pinned Q&As. I spent a while searching for the answer before posting this question and - based on the amount of commenters - I’m not the only one.

    It would be great if AgileBits put some time and effort into resolving this UX issue.

  • ag_anaag_ana

    Team Member

    That's great to hear @Martin153 :)

  • ag_anaag_ana

    Team Member

    @bob1downs:

    Thank you for the feedback!

  • wakko1999wakko1999
    edited March 18

    I didn't have such luck.... I got the message that 7.8 was avail, began the download and it started over on its own three times before saying validation failed. closed the window, browser, etc... went to go open 1password app and got a message saying you don't have permission to run this app. then the 1password icon in my dock disappeared. When I looked in the Applications folder the 1password item is there but the icon is just a gray box. Even after reboot now I cannot open the app.... Mac mini M1

    update:
    Just went back to app store and donloaded it again...luckily it picked up all the existing vaults and settings so everything is status quo. Not sure what the deal was with that breaking like that .....

  • ag_anaag_ana

    Team Member

    It sounded like a permission issue in macOS @wakko1999, but I am glad to hear that things are working again now :+1:

  • ag-ana,
    my big sur MacBook doesn't have a password mini in menu bar to quit completely, how do you quit completely with out it?
    Thanks

  • ag_anaag_ana

    Team Member

    @pslawing:

    You can try the keyboard shortcut: Control‑Option‑Command‑Q.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file