1Password Mac Safari does not work at all on M1 Mac now.

2»

Comments

  • @rudy @ag_ana If you can give me an email I can send a message to, I may be able to shed some light on things I cannot discuss on a public forum.

  • ag_anaag_ana

    Team Member

    @MajorHavoc:

    You can use [email protected] After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Hello @MajorHavoc. This morning, I was seeing a similar Safari extension issue that you had on your M1 MacBook Pro from several weeks ago. On my M1 MacBook Pro, I'm running macOS Big Sur 11.4, Safari 14.1.1 (16611.2.7.1.4), and 1Password 7 Version 7.8.4 (70804004) from the Mac App Store. If I recall correctly, the 1Password7 Safari extension was working as it normally should in Safari prior to doing the Big Sur update to 11.4 about 8 days ago. I guess I didn't need to use the 1Password7 Safari extension in the time since that macOS update.

    I used your method to get it working again as outlined in your post on April 28th by adding 1Password7 to Input Monitoring. Once 1Password7 was added to Input Monitoring, I did not quit and restart 1Password7 and just went for it. Works like a charm in Safari now.

    I then did your test from April 29th and deselected 1Password7 in Input Monitoring and quit 1Password7. When I clicked on the 1Password7 Safari extension, I got the proper 1Password7 login in Safari and again it works as expected.

    I will leave it the way it is in Input Monitoring with 1Password7 deselected to see if the error condition comes back.

    Thanks for your post in the 1Password Support Community and saving me a lot of time trying to figure this issue out.

  • Thank you for coming up with a solution @MajorHavoc ! I did the steps you did which were summarized by @Kingsfordgolf and 1Password in Safari works again.

    Though I was not running the most recent version as those above, the steps outlined still work, so I thought I'd add my input so others may try them.

    M1 Mac mini macOS Big Sur 11.2.3 (oops! thought I had the most recent version of macOS!)
    Safari Version 14.0.3 (16610.4.3.1.7)
    I've also updated everything to the latest version.

  • ag_anaag_ana

    Team Member

    Thank you both for the feedback and the updates :)

  • Just to follow up on this, 1Password has been flaky for me for years on Safari. Works fine on Chrome but, lately, it’s been so bad* I’ve actually disabled it on Safari (my main browser) and reverted to using Keychain.

    • Simply not working when its browser icon clicked — or fighting with Keychain’s pop-up the few times it does
  • @designICU: I have noticed the same thing with Safari. It seems that 1Password the app needs to be unlocked for it to open properly at times. Other times, I see the box to login just fine. Not sure the difference.

    Currently, on my M1 Mac with the latest update, it seems to be working. It still has its new annoyances about unlocking and requesting the password again and again (Ill get that right eventually), but it works. I consider keychain, but I need my passwords on several other systems, including Windows and iOS, so Keychain is not a great answer. I am using another password manager that is browser based as a backup that is less annoying, but I do not trust it like I do 1Password, so I only keep non-critical things in there.

  • designICUdesignICU
    edited June 29

    @MajorHavoc So I tried your tip of adding 1Password to the Input Monitoring panel and that does seem to have fixed the issue for me, for now! So thank you for writing that up and getting it online — and for using the words "1Password" and "flaky" which is how I found this post via Google.

  • Glad it helped.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file