1Password failed to connect to 1Password mini

chrschrs
edited April 13 in 1Password 3 – 6 for Mac

I have an issue with 1Password failing to connect to 1Password mini, and the main app not being able to open the Vault.

This started happening today, April 13. It worked fine the day before.

If I open 1Password from scratch, it will open 1Password mini and the main app. The vault is locked at this point. I cannot enter my master password from the 1Password mini, as it seems unresponsive to any input (although it is still responding). If I try to open my vault (entering the master password), the main app indicates that it is trying to open the vault (by fading and disabling the input). However, 1Password mini indicates that it is open, and I can access my passwords from there, but not the main app which stays disabled.

If I close the main app, keeping 1Password mini running, and re-open the main app it displays a popup about trying to connect to 1Password mini. This then fails with the message "1Password failed to connect to 1Password mini".

What I've tried so far:

  • Restarting the OS (multiple times)
  • Reinstalled 1Password 6.8.9 from the Download section — not using App Store
  • Resetting Launch Services and VRAM/PRAM
  • Quit all running apps and only run 1Password

None of these have worked, unfortunately.

I did find a similar post about this from 2017 and have gone through the thread but couldn't find a working solution for the issue. There is a mention that this could possibly be due to expired certificates.

A negative implication this has for me is that I cannot access my vault to edit and add passwords. No am I able to do any manual backups or manage my vaults. Would love to get this solved as soon as possible.

Edit:

I have tried quitting the main app and the mini, which doesn't work anymore either. If I try to force quit through Activity Monitor, the 1Password Mini app instantly reopens.


1Password Version: 6.8.9
Extension Version: Not Provided
OS Version: macOS 10.15.7
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @chrs!

    Is the 1Password app installed in your Applications folder of your Mac? If the app is anywhere else, it will fail to connect to 1Password mini, and this message would appear.

  • Yes, it's located in /Applications/1Password.app

  • ag_anaag_ana

    Team Member

    @chrs:

    Thank you for the confirmation! I would like to ask you to generate a diagnostics report from your Mac and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Sent the diagnostics to support; the ticket no. is [#JZI-45757-358]

  • ag_anaag_ana

    Team Member

    @chrs:

    Thank you! I confirm that I have managed to locate your diagnostics report in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: JZI-45757-358

  • chrschrs
    edited April 13

    Just an update on my situation: I started trying to troubleshoot the issue myself, and have somehow fixed it – at least temporarily.

    For anyone else who may run into this issue:

    After digging through the diagnostics myself, I stumbled upon the app's sandbox folder (~/Library/Group Containers/2BUA8C4S2C.com.agilebits/) – note: the 2BUA8C4S2C is the team identifier of the developer and may be different for your particular version of 1Password.

    I moved this entire folder into another place (e.g. my desktop) and restarted 1Password — and it worked. It opened the main app correctly, and I could type in my master password and open my vault. The only thing not appearing is the 1Password Mini app, but it is running in the background for some reason. Not sure why.

    1Password should automatically re-create this folder upon startup with your license (if the license is stored in the 1Password Vault).

    I don't know if this is what fixed the issue, or what the initial issue was, but likely due to a problem with the cache.

    Hope this helps.

  • ag_anaag_ana

    Team Member

    @chrs:

    Thank you for taking the time to share this update with the community!

This discussion has been closed.