Excessive update checking with account switching

cdjcdj
edited April 21 in Mac Beta

I've noticed that 1P behaves weird when switching between multiple Mac accounts on the same computer. If I updated 1P on one account, then switch to the other, it checks for new updates every 5 minutes or so and pops up with "thank you for running the latest version". It's interrupting my workflow as it brings that window into focus.

It seems as though one account is still stuck with the old binary in memory and the other is using the new code. I noticed Brave browser having the same issue (updates on one account makes every new tab crash instantly and a restart of the app is necessary).

I noticed too that when I checked the version the first time it still said 7.8.1 BETA2 and when I rebooted my machine it said 7.8.1.

I know this is all a bit vague so let me know what I can do to make this report more clear.


1Password Version: 7.8.1 (70801003)
Extension Version: 4.7.5.90
OS Version: 10.15.7
Sync Type: 1P.com

Comments

  • rudyrudy

    Team Member

    @cdj,

    Beta builds check extremely aggressively, and what you describe does sound like your in-memory beta in the other account is absolutely continuing to run the pre-update binary until you quit completely or restart your system.

  • I don't mind 1P beta checking aggressively. What I mind is that it is notifying me every 5 min that it did not find any updates and congratulating me for being up to date.

  • ag_anaag_ana

    Team Member

    @cdj:

    Have you tried either quitting 1Password completely, or restarting your system, as per Rudy's suggestion? Did you notice any improvements?

  • cdjcdj
    edited April 20

    yes I did. I know that rebooting my system solves this issue. But I hope there is a better, more elegant solution to this. An update process that is not disruptive to multiple accounts using the same computer at once. It's more of a feature request (if it's not a bug).

  • ag_anaag_ana

    Team Member

    Understood @cdj, it's good to hear that a reboot solves this issue. We can certainly look at this some time in the future and see if there is anything we can do to improve this behavior :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file