A better way to unlock 🔓

nickmcguirenickmcguire

Team Member
edited May 5 in Browser Beta

Hey everyone! 👋🏼

It's been a minute since we posted an update but since launching our integration with 1Password for Linux we've gotten some great initial feedback, resolved some issues, and we've got some more news to share.

I'm happy to say that with today's release of 1Password for Mac and Windows, we have enabled the connection with the current beta of 1Password in the browser (1.25.5)

With these new betas, you can now enjoy:

  • Unlocking 1Password will automatically unlock 1Password in the browser
  • Restarting your browser will leave 1Password in the same lock state
  • Using biometrics to unlock 1Password in the browser is now possible

For those following along on the Linux releases there are some things available which haven't made it to Mac/Windows yet, but will be included in future updates.

We're all looking forward to you getting a chance to give this a shot and get back to filling passwords without fear of closing down your browser 🔐

https://support.1password.com/betas/

«13

Comments

  • LeighKLeighK ✭

    Huzzah! Thanks! I've tested this in Firefox on Mac with touch id and it works well. I assume this will also work on Windows using Windows Hello?

  • BlakeBlake

    Team Member

    I assume this will also work on Windows using Windows Hello?

    Absolutely! Go give it a whirl! 😊

  • I just got the update notification but it disappears so fast I barely saw the biometric and came over here. FYI it's actually hard to know if the Mac desktop app is updating or if the Chrome extension is.

    So I am using the Beta Extension (1.25.5) but when I open the desktop app (Beta 7.8.2.BETA-0) it still says to install Chrome extensions. What else do we need to update? I just tested and no unlock through Touch-ID. Thanks!

  • klepp0906klepp0906 ✭

    Where on earth is the thumbs up/like button? :P

  • zhaowenyzhaoweny ✭

    I tried but it did not work for me.

    My setup:

    • Firefox 89.0b8 (64-bit)
    • 1Password Browser Extension 1.25.5
    • 1Password for Windows 7.6.800
    • Windows version Dev (OS Build 21370.1)

    My attempt to test this feature:

    • update 1Password for Windows to 7.6.800, unlock it with master password
    • authorize via Browser Extension initial setup
    • lock both Browser Extension and 1Password for Windows
    • unlock 1Password for Windows via Windows Hello (PIN)
    • Browser Extension should be unlocked but it does not in my case.
  • Doesn't seem to work for me yet, unfortunately:

    • macOS Big Sur 11.3.1
    • 1Password 7.8.2.BETA-0
    • 1Password Extension 1.25.5

    I tried both Brave and Chrome, but biometrics (touchID, Apple Watch) don't work to unlock the browser extension. Also, closing the browser and reopening opens with the extension locked.

  • serenseren ✭

    Just to add a datapoint, it's working on:

    • MacOS Big Sur 11.3
    • 1Password 7.8.2.BETA-0 (70802000)
    • Firefox 88, 1Password Beta extension 1.25.5
    • Chrome 90, 1Password Beta extension 1.25.5

    Locking and unlocking is synchronized across the main app, browser extensions, and menu bar icon. Clicking the browser extension icon bring up a biometric prompt. Yay!

  • Quit Chrome and reopened and its working now, yay its finally back!

  • joschafjoschaf ✭
    edited May 5

    Thanks very much, I was desperately waiting for this, and it works perfectly for me with

    • macOS Big Sur 11.3.1 (M1)
    • 1Password 7.8.2.BETA-0
    • 1Password Extension 1.25.5
    • Brave 1.23.75

    Awesome :)

  • ag_yaronag_yaron

    Team Member
    edited May 5

    We're glad to hear all the excitement from you guys!
    If something is not working for you, please relaunch the browser and 1Password like so:

    On a Mac:

    1. Right click the little 1Password icon on the top menu bar of your Mac (where the clock is) and select "Quit 1Password Completely".
    2. Quit the browser by right clicking its icon in the Dock and selecting "Quit".
    3. Open and unlock 1Password.
    4. Open the browser and test if it is working properly.

    On Windows:

    1. Right click the 1Password icon in the taskbar (where the clock is) and quit 1Password.
    2. Close the browser completely.
    3. Open and unlock 1Password.
    4. Open the browser

    A restart to the computer might also get things in order so give that a try when all else fails.
    If you are still experiencing issues, please send us an email to [email protected] with the info and we'll be happy to help!

  • zhaowenyzhaoweny ✭

    I tried the same setup but with Chromium Edge, it works :).

    • Firefox 89.0b8 (64-bit) Microsoft Edge 90.0.818.51
    • 1Password Browser Extension 1.25.5
    • 1Password for Windows 7.6.800
    • Windows version Dev (OS Build 21370.1)
  • ag_yaronag_yaron

    Team Member

    That's great @zhaoweny .

    This should also work in Firefox though. Make sure that Firefox is not set to "Always use private browsing" and that it can remember history.

  • ag_yaronag_yaron

    Team Member

    Hey @Naxterra ,

    Can you please check your Firefox settings as I mentioned in the reply above?

  • riverclikorivercliko ✭

    Working!

    macOS Big Sur 11.13.1
    Firefox 88.0
    1Password for Firefox 1.25.5
    1Password for Mac 7.8.2.BETA-0 (70802000)

  • ag_yaronag_yaron

    Team Member

    @Naxterra Can you send us the extension's log to [email protected] with a description of the issue?
    https://support.1password.com/cs/extension-console-log/

  • carstenlangecarstenlange Junior Member ✭

    Finally - thank you guys.

  • ag_anaag_ana

    Team Member

    You are welcome @carstenlange :)

  • ag_anaag_ana

    Team Member

    @Naxterra:

    Thank you! Have you received a ticket number already?

  • DenalBDenalB ✭

    Great job! Works nearly as expected in Windows 10 and Vivaldi browser. :+1:

  • ag_yaronag_yaron

    Team Member

    Thanks for the feedback guys :chuffed:

  • We’ll done on the Mac and Chrome integration. My use case was maybe unique, so great job enabling it.

    I can now use the 1Password beta extension cross-platform on Chrome. If the desktop app is there on my Mac, then TouchID is available and works. If I’m inside a Virtual Machine, which may be Windows, my browser extension syncs over as it should, but since the desktop app isn’t there, I just have to login via password since biometrics isn’t available.

    Perfectly seamless!

  • How do we report any bugs to help?

  • DenalBDenalB ✭
    edited May 5

    Just create a new discussion here in the Browser Beta forum with your issues or questions. ;)

    https://1password.community/categories/1password-x-explorers

  • I had some issues at first unlocking the Firefox extension (got confused when I pressed the shortcut to unlock in the browser and the desktop window came up!). Once I unlocked the desktop app, the browser extension was just spinning at the unlock screen. Once I went into the extension settings, disabled and then re-enabled "integrate with 1Password app," everything worked!

  • ag_yaronag_yaron

    Team Member

    Thanks for the info @crazycaveman .

    If you encounter the issue again, before fixing it grab the extension's log and send it to us via email to [email protected]
    Here's how to grab the log: https://support.1password.com/cs/extension-console-log/

    I hope you'll have smooth sailing from here on out!

  • MacSupportMacSupport ✭

    Which extension in FireFox is "1Password in the Browser"?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file