A better way to unlock πŸ”“

2

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @MacSupport,

    The first one. Please disable the 1Password extension (desktop app required) one and restart the browser, it should work.

  • MacSupportMacSupport ✭

    No luck. I still get the locked 1Password icon.

  • MacSupportMacSupport ✭

    FYI: Here are the console logs:

    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. background.js:2
    Vk moz-extension://d489f0ca-1ceb-ce4f-9249-173fa5eaf4cf/background/background.js:2
    Unchecked lastError value: Error: PrecompiledScript.executeInGlobal: Argument 1 is not an object. background.js:2
    Ow moz-extension://d489f0ca-1ceb-ce4f-9249-173fa5eaf4cf/background/background.js:2

  • edsparedspar ✭

    What great news!

    Is this meant to work to support Biometric unlock and save unlock state with only the browser extension itself and no desktop app?

  • stfsstfs ✭

    Must say that I'm not loving the UX here. I'm using Brave (Chrome) on Mac.

    When the 1Password browser extension is "locked" and I enter a page that needs a login, I see the 1Pass icon inside the password field. If I click that I get a button "Open 1Password"... why? Why not just open 1Password? I clicked the logo, I shouldn't need to click the button again now.

    So... I click the button (which I would like not to have to do) and then I get prompted with the biometric lock prompt and I can use my fingerprint to unlock 1Password. That's good.

    However, once I've done that... the little window with the "Open 1Password" button is still visible and doesn't update to a list of possible credentials to use. I need to click outside that window so it disappears and then re-click the 1Password icon in the password field to get a list of the possible credentials to use.

    I've updated both the extension and the application to the latest (beta) version and I've rebooted the browser (and actually the computer as well). I'm still seeing this after doing that.

    Is anyone else experiencing this or is it just me? Is this possible a Brave specific problem?

  • rudyrudy

    Team Member

    @edspar,

    No, this requires the desktop app.

  • edsparedspar ✭

    @rudy Thanks for the clarification. Working great here with desktop app.

    Is there plans to have this work with only the browser extension in the future?

  • Tertius3Tertius3 ✭

    Many thanks for the update! Sharing the unlock works great here (Windows 10 & Chrome). No issues.

  • purpliskpurplisk ✭

    Ahhhhhh this is working so good - thanks very much.

    Mac OS Catalina 10.15.7
    Chrome Version 90.0.4430.93 (Official Build) (x86_64)
    1 Password Beta for Chrome 1.25.6
    1Password 7
    Version 7.8.2.BETA-0 (70802000)
    1Password Beta

  • chauiechauie ✭

    it's back!!!

  • ag_yaronag_yaron

    Team Member

    Hey @MacSupport ,

    You'll need to install the latest beta version of 1Password in the browser. Your screenshot shows you are using the stable version.
    Please disable the extension in your browser and make sure you have the latest beta version (both of 1Password in the browser and the desktop app): https://support.1password.com/betas/

    @stfs
    Thanks for the info here.
    We show an extra button to unlock 1Password to prevent websites from being able to trigger that prompt for you, which might have malicious intent. That's why the unlock button is in our own inline menu and not directly on the page/inside the field.

    Are you able to reproduce the issue where the "Unlock 1Password" stays visible after you unlocked it on demand? If so, can you please email us the details and a screen recording to [email protected] ?

    Thank you kindly.

  • JCarlockJCarlock ✭

    I followed the instructions on the other thread.

    Installed beta 1.25.5 yesterday (then .6 today).
    Quit browser
    Quit 1PW completely
    Rebooted Computer
    Logged in to 1PW Mac app (using touch)
    Launched Chrome
    1PW Extension - Locked

    Did I do something wrong?


    1Password Version: 7.8.1
    Extension Version: 1.25.6
    OS Version: OS X 11.2.3
    Sync Type: iCloud

  • ag_yaronag_yaron

    Team Member

    Hey @JCarlock

    You need to install both 1Password beta in the browser and the 1Password beta desktop app. If you only have one of them in beta, it won't work :)
    You can get the desktop app's beta here: https://support.1password.com/betas/

  • ByscriptsByscripts ✭

    Here it is again!

    Updated macOS app and MS Edge extension, it works fine.

    Thank you!

  • ag_anaag_ana

    Team Member

    Nice! Thank you for the update @Byscripts! :+1::)

  • CruncherCruncher ✭

    When can we expect the final release? I am not a big fan of using Beta version on my productive system.

  • On my browser the extension takes a while to respond to any autofill spaces. It has about a few seconds delay and sometimes I even accidentally dismiss it by manually pressing the 1Password butoon.

    On an unrelated note, I notice when I right click, there is an option to show 1Password, but it seems to do nothing. Is that intentional?

    OS: Windows 10.
    Browser: Microsoft Edge.

  • chauiechauie ✭
    edited May 7

    Mine went back to requiring the password instead of using fingerprint. I'm on MacOS 11.3.1, Chrome 90.0.4430.93, 1PW extension 1.25.6, 1PW beta 7.8.2

    edit: followed the steps in another thread about quitting 1pw and browser completely and it works again

  • BeOSBeOS ✭

    Just FYI, it doesn't work with the following combination:

    1. OS: Distro: Linux Mint 20.1 Ulyssa (Cinnamon)
    2. Browser: Vivaldi 3.8.2259.40
    3. 1Password app version: 1Password for Linux 8.0.33-79.BETA
    4. Browser extension version: 1.25.6

    Also clicking on the 1Password extension icon in the browser locks it.

    The same combination but with Chrome instead of Vivaldi worked without any problems.

  • agatonagaton ✭

    Are beta versions of browser add-ons not allowed in the Microsoft edge add-ons site? I notice that I need to install the beta from the Chrome web store to use it in on edge browser.

  • ag_yaronag_yaron

    Team Member

    @Cruncher We don't have an ETA on a stable release, but things are looking pretty good with the beta so far so hopefully it won't be too long.

    @Alexei_Drekker Can you please test this on a new user profile in your browser and see if 1Password is still lagging? Simply open a new user profile in the browser, switch to it and install 1Password beta, then test and see how things go.

    @BeOS I think Vivaldi is not supported in Linux, but you might want to open a new discussion about this issue in the Linux forum here.

    @agaton We only release the beta version in Chrome so it would be easier to handle and manage. It's tough having different versions of the same extension for each extension store as is, so for the sake of keeping things easily managed, beta versions are only available in Chrome :)

  • @ag_yaron I did that. It is slightly faster, but still delayed, unfortunately.

  • ag_yaronag_yaron

    Team Member

    @Alexei_Drekker If there's been an improvement in the speed/response time in a new profile, it indicates the slowness is most likely from an external source.

    Would you be able to test this in safe mode with networking?
    You can also email us a video and the extension's log via email so that we can investigate a bit better if you'd like. Send it to [email protected]
    https://support.1password.com/cs/extension-console-log/

  • hulksavehulksave ✭

    Couple of issues with running for Windows. On beta builds for both Chrome extension & Windows desktop app, 1.25.6 & 7.6.801 respectively.
    When exiting the desktop app while Chrome extension is already authenticated, desktop app then requires additional re-authentication to unlock again rather than detecting that the chrome extension is still authenticated.
    Secondly, the edit function from the browser extension for an individual password record used to spawn a my.1password.com instance & open the specific record you want to edit on the web, now it asks if you want to open the desktop app instead & doesn't open the edit function for that specific PW record. Perhaps having the option for both/either?
    Regardless, happy to see the progress. The integration seems to work pretty well otherwise.
    Looking forward to continuing to test.
    Thanks

  • hulksavehulksave ✭

    Additionally, the browser extension, once the desktop app is exited, seems to time out of its independent authentication & lock again w/o additional user input. Ideally the authentication relationship should be bi-directional & unlocking or remaining authenticated in either, should signal to re-open the other without authentication when launched.

  • ag_yaronag_yaron

    Team Member

    Hey @hulksave ,

    Editing and Open & Fill are not yet implemented with the integration, but once it does, when you click on "Edit" it will launch the desktop app properly.

    Can you please check what are your desktop app's auto-lock timer settings are? If it is set to lock up after 10 minutes, it should lock both the desktop app and the extension in 10 minutes of idle time. Closing the app should not lock the app immediately unless that's how you set it.

  • ubayubay ✭

    its been a long time. but thank you very much. its a much better UX now.

  • BenBen AWS Team

    Team Member

    πŸ₯°

    Ben

  • @ag_yaron I just had the issue again in the Edge browser. I was able to capture the info and sent it your way. Haven't received a response, so don't have a case # yet.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file