Change hot-key?

Greetings!

Under 20.04 LTS Desktop, I noticed the hot-key for 1Password conflicts with the hot-key to do react-emojis in Slack ( Ctrl+Shift+\ ). I haven't found a place where I can rebind this hot key or disable it.


1Password Version: 8.0.33-69.BETA
Extension Version: Chrome 1.24.2
OS Version: Ubuntu 20.04.2 LTS
Sync Type: Not Provided

Comments

  • Dayton_agDayton_ag

    Team Member
    edited May 19

    Hey there @mjuarez , welcome to the 1Password Support Community! 🎉

    Thanks so much for writing in! Yes, you can change the keyboard shortcut for 1Password to avoid conflicts - here's how to do it:

    1. Paste and run the following code in terminal:
    • gedit ~/.config/1Password/settings/settings.json
    1. Once the page opens, add this line to the file:
    • "keybinds.open": "yourShortcutHere" - as an example, your shortcut could be "CtrlOrCmd+Shift+."
    1. Save the file.

    This should set your new keyboard shortcut. Could you give that a go, and let me know how you get along? :smile:

  • Set it to "" to disable. Worked perfectly! Thank you!

  • Dayton_agDayton_ag

    Team Member

    Hey @mjuarez, not a problem! Let me know if I can help out with anything else. :smile:

  • lodelode

    Hi, I'm having the same issue.

    It seems I can't adjust the shortcut, I changed it to "keybinds.open": "CtrlOrCmd+Shift+." or "keybinds.open": "CtrlOrCmd+Shift+\\", but no result. Only if I remove that setting does 1P normally follow Ctrl+Shift+\ to open the app.

    Btw, I'm a bit confused, as the shortcut for Slack's emoji reactions is Ctrl+Shift+\, and 1P's shortcut help shows that the shortcut to open 1P is Ctrl+\. This last isn't true though, using Ctrl+\ doesn't open 1P and Ctrl+Shift+\ does. This seems like either a documentation error or an implementation error.

    Would be great if both these could be fixed! I hope it is a implementation error and the documented Ctrl+\ is intended, because then there wouldn't any conflict with Slack anymore. Although I don't know which other programs would have issues with that.

  • Hi, I've changed this setting but it didn't work. I added that config into the file, restarted the app, go to the desktop, tried the key combination but 1Password window didn't show up.

  • roustemroustem AgileBits Founder

    Team Member

    Hi @lode,

    I wonder if changing CtrlOrCmd to CmdOrCtrl would make a difference?

    The documentation is wrong, it should be showing Ctrl+Shift+\. We'll get it fixed in the next update.

  • lodelode

    Yes, thanks @roustem, that made it work.

    It would be nice btw if these overridden shortcuts are also shown in the in-app documentation.

  • BlakeBlake

    Team Member

    Glad to hear that worked for you!

    I agree, it'd be nice to see the listed keyboard shortcuts dynamically change according to what's set as a custom shortcut. I'll make sure that's brought up to our development team to see what it would take to make something like that happen.

    Let us know if there's anything else we can help with. 😊

  • I also came here looking for how to make Ctrl+Shift+\ keep working for Slack. :smile:

    I thought I'd put 1Password on Super+1. I found https://www.electronjs.org/docs/api/accelerator, which I believe are the magic names of all the keys for use in the config file. But I'm having mixed results with Super+1. I have to do it twice in quick succession to bring up 1Password, and the first time enters a 1 into whatever application is in the foreground.

    I then also went into my OS Settings and added a mapping there for Super+1 to run 1password, and now it seems to work as expected. But it's a little awkward to have to set my shortcut in two places.

    FWIW, I'm running Pop!_OS 20.10 x86_64 (which is basically Ubuntu) with default GNOME 3.38.3.

  • Dayton_agDayton_ag

    Team Member

    Hey there @lorrin, thanks for mentioning this!

    I just did some testing, and I find that no matter what I set to accompany the Super accelerator, launching 1Password always requires a second press of the final key in my shortcut sequence - this seems to only apply to the Super key, though, and I find I can wait even 5 seconds before actuating the key the second time, and 1Password still gets called. Could you confirm if this is the same for you, and if the behaviour resolves when using Ctrl or Alt?

  • SavanniSavanni

    Team Member

    Hi, @lorrin and @tunix. I don't know whether you're still having problems, but do you happen to be running in a Wayland environment? You can find out, after starting your desktop environment, by opening and terminal and entering this command:

    printenv | grep WAYLAND
    

    If you get a result, then you are running in Wayland. I believe it is impossible for an application to set system-global shortcuts in Wayland. This was a deliberate choice by the developers since a system-global shortcut mechanism could be used as a key logger. So, instead, you would always have to set such shortcuts in your desktop environment's configuration. For Gnome Shell, that is in Settings > Keyboard Shortcuts.

    Please let us know if that helps.

  • tunixtunix
    edited June 9

    Hi @Savanni ,

    Please see this thread. I'm on Pop!_OS 20.10 which has GNOME 3.38.3 and X11. I also tried it on Ubuntu 20.10 which had the same GNOME and X11 and wasn't working properly.

    I think the issue had to do with different keyboard layouts. Mine is Turkish and that's probably why I have issues.

    Also, I think 1Password itself can set its keybindings through GNOME's gsettings or by some API that allows it. It shouldn't matter whether one uses X11 or Wayland.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file