How to change Language

Hello,

I've just installed the native Linux app and I can't find a setting to change the language.

My native language is Brazilian Portuguese (pt_BR), but I use all my systems in English for learning/practice, my system language is set to English, but the format for numbers, dates and everything else is set to pt_BR.

Does the app get it from one of the locales? Is there any way to change the language at this moment?

This is my current locale

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE=pt_BR.UTF-8
LC_NUMERIC=pt_BR.UTF-8
LC_TIME=pt_BR.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=pt_BR.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=pt_BR.UTF-8
LC_NAME=pt_BR.UTF-8
LC_ADDRESS=pt_BR.UTF-8
LC_TELEPHONE=pt_BR.UTF-8
LC_MEASUREMENT=pt_BR.UTF-8
LC_IDENTIFICATION=pt_BR.UTF-8
LC_ALL=

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • SavanniSavanni

    Team Member

    Thanks for writing in @leandrojmp . Please try setting LANG=pt_BR.UTF-8. That should be the key one that triggers it.

  • edited May 18

    Hello,

    Sorry, I didn't explain the problem correctly.

    I do not want to change the language to pt_BR, the app is already in pt_BR, I want to change the language to en_US, which is the language of the system, pt_BR is only used to format numbers and dates.

    LANG is already set to en_US.UTF-8, as this is the language of the system, but the app didn't get the locale from this variable.

    This is in the logs:

    INFO  2021-05-18T11:33:01.325 ThreadId(10) [1P:op-localization/src/lib.rs:154] system locale detected as 'pt_BR'
    INFO  2021-05-18T11:33:01.325 ThreadId(10) [1P:op-localization/src/lib.rs:180] selected translations for PT_BR based on detected locale pt-BR
    

    I think It should have got the locale from the system language, but it got from somewhere else.

  • ag_maryamag_maryam

    Team Member
    edited May 18

    Thanks for writing in @leandrojmp . Would you please try setting LC_CTYPE=en_US.UTF-8.

  • Hello @ag_maryam, it works only if I open a terminal, export LC_CTYPE and start 1password from the same terminal with 1password.

    I tried to export it in my profile (.bashrc) and logout and put in /etc/default/locale and reboot and none of them worked.

    Don't know from where it is getting the variable.

  • ag_maryamag_maryam

    Team Member

    Thank you for your respond @leandrojmp , I have asked my colleagues and they suggested to override your system locale using the environment variable OP_LOCALE=en-us

  • Hello @ag_maryam, it worked.

    I needed to add OP_LOCALE=en_us to the file /etc/environment and login again, after that the UI language was in English.

  • SavanniSavanni

    Team Member

    Interesting! Would you mind sharing what OS that you are using? I've actually not seen that file before. My NixOS machine doesn't have it at all, but my Fedora machine has an empty file there.

  • I'm on Ubuntu 20.10, I think that /etc/environment is common in Debian based systems, but for what I know it is deprecated (but still works).

    It would be nice to have the option to change the language from an UI setting.

  • BlakeBlake

    Team Member

    Adding a language configuration options is certainly on the list of things for us to do, it just didn't quite make it into the Stable release.

    I'm glad to hear you were ultimately able to get things working properly. Sorry for the headache!

  • Erik_1PErik_1P

    Team Member

    I had a look into this and we aren't using the locale related environment variables correctly. I've created an issue to fix it and conform to _POSIX _.

    The workaround is as @leandrojmp shows until we have a fix. Apologies for the oversight.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file