How the browser integration works?


How the browser integration should work?

I thought that if unlocked the desktop app it would unlock the browser extension or if I clicked edit in anything in the browser extension it would open the desktop app for edit, none of those things are working.

I already removed and reinstalled the browser extension following the link in the app, but it seems that they are not talking with each other.

I'm on Vivaldi (Chromium based).

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • I thought that if unlocked the desktop app it would unlock the browser extension

    That is how it should work, yes. Do you have the beta version of the browser extension?

  • BlakeBlake

    Team Member

    Howdy @leandrojmp 🤠

    Vivaldi isn't on our list of browsers that we support by default, instead, you'll need to do a few things to get this working.

    1. Ensure that 1Password for Linux is installed along with 1Password in your browser, and that browser integration is enabled from Settings → Browser.
    2. Close 1Password completely.
    3. Pop open a terminal, and run sudo mkdir /etc/1password (if you've done this already, you can skip it).
    4. Run cd /etc/1password.
    5. Run sudo gedit custom_allowed_browsers.
    6. Paste in the appropriate browser code - such as opera or vivaldi-bin.
    7. Save the file.
    8. In terminal, run sudo chown root:root /etc/1password/custom_allowed_browsers && sudo chmod 755 /etc/1password/custom_allowed_browsers
    9. Run 1Password - it will read our new config file and make the appropriate connections.
    10. Launch your browser!

    Let me know if that fixes things!

  • What is the browser code? I am currently running Microsoft Edge Dev version, what should I enter into that file? Is it something like a ps xa output?

  • Thanks @Blake, it worked, now when I unlock the app, the extension is unlocked in the browser.

    @ranger I think that the browser code is the binary name, for vivaldi is vivaldi-bin.

  • BlakeBlake

    Team Member

    Fantastic! I'm glad to hear that got things into working order!

    Let me know if there's anything else I can help with. 😊

  • @Blake, I tried using the desktop <-> browser unlock possibility, but it does not seem to work for my main browser. Do you have any pointers on what I can do to fix it? I'm on Debian and am using Firefox Nightly as my main, for which it does not work. However, for Firefox ESR it does work. In both browsers I have got the 1password extension (non-beta) installed.

    I tried adding the browser code 'firefox-bin' according to your answer above, as it lists as such in ksysmanager, but this does not seem to resolve the issue.

    Something that might be related is the warning that's shown in the 1password browser extension pop-up when it's still in locked state: 'Firefox has an update available. Restart Firefox to to install the update and reconnect with 1Password.'


  • BlakeBlake

    Team Member
    edited May 19


    If Firefox Nightly reports itself as firefox-bin, as you mentioned, then it should work just fine. Since it's not, then it sounds like there's more going on than meets the eye here.

    Could you go ahead and zip up the logs found in .config/1Password/logs/BrowserSupport and then include them an email to [email protected] so me and my team could take a closer look at things?

  • @Blake ... just curious. You are requiring the config file to have the execution bit set (755). Why? It's a config file ...
    I just tested 644 but this didn't work .

  • BlakeBlake

    Team Member

    It's a side-effect of using the same code for some different use cases since the custom browser list was a first attempt with a few rough edges.

    We'll get this fixed up in a release in the near-future and correct this. Thanks a bunch for pointing this out!

  • @Blake

    Thanks for your quick response, I'll zip up the logs as requested. I hope I don't clutter the thread here, but I'd just like to share that it seems to be a permission issue of some kind, for anyone interested:

    INFO main(ThreadId(1)) [1P:native-messaging/op-browser-support/src/] Starting 1Password-BrowserSupport
    INFO main(ThreadId(1)) [1P:native-messaging/op-browser-support/src/browser_verification/] Verifying browser "[...]/firefox/firefox-bin"
    WARN main(ThreadId(1)) [1P:foundation/op-sys-info/src/] binary permission verification failed for [...]/firefox/firefox-bin
    ERROR main(ThreadId(1)) [1P:native-messaging/op-browser-support/src/] BrowserProcessVerification(BinaryPermissions)
    Happened in: native-messaging/op-browser-support/src/browser_verification/
    Additional error context: Failed to verify browser permissions

  • Dayton_agDayton_ag

    Team Member

    Thanks so much @tobiasvd! We'll look forward to helping you out over email. :smile:

  • edited August 17

    Well, after switching to Fedora 34 using GNOME 40.3 I seem to have an issue when using Vivaldi (not beta):

     # cat /opt/1Password/resources/custom_allowed_browsers
    # This file, when placed into /etc/1password/custom_allowed_browsers will allow for
    # custom browsers to be defined that can work with 1Password for Linux's browser extension
    # integration.
    # 1Password for Linux custom browser allowlist
    # To add a browser here, add the filename of the browser. Multiple can be seperated by a `\n`.
    # Any lines starting with `#` will be ignored.
    # Example:
    # opera

    I checked Connect with 1Password in the browser, restarted browser and restarted 1password linux app. I even chmod'ed the file to 755.
    But I do not get the connection between browser and app. I always have to type in the master password twice ...

    App: 1Password for Linux 8.1.1
    Browser Plugin: Version 2.0.5

    Any ideas? What did I miss?

  • PeterG_1PPeterG_1P

    Team Member

    Hi @basurerito, sorry to hear that 1Password isn't working with Vivaldi yet for you. If you contact us at [email protected], and include your logs from .config/1Password/logs/BrowserSupport, I'll be happy to dig into the specifics for you to find out what might be going on with your config.

    Our team will look forward to getting you fully up and running!

  • @PeterG_1P - during installation custom_allowed_browsers is written to /opt/1Password/resources. But the linux app verifier needs this file to be iin /etc/1password.

    This has been confirmed by your team, here @Dayton .. thank you :+1: (slightly modified)

    With root privileges:
    1. modify /opt/1Password/resources/custom_allowed_browsers
    2. mkdir -p /etc/1password
    3. cp -p /opt/1Password/resources/custom_allowed_browsers /etc/1password/custom_allowed_browsers

    --> this file should be written to its "correct" location under /etc/1password during installation to avoid confused people like me :blush:

  • PeterG_1PPeterG_1P

    Team Member

    Thank you @basurerito. We will note this going forward! 👍 Thanks for detailing this here.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file