Cannot launch, SIGSEGV

On Archlinux, when I try to launch the app, nothing happens. If I launch it from a terminal, I get "Job 1, '1password' terminated by signal SIGSEGV (Address boundary error)"

Installed via instructions, clone repo and makepkg -si.


1Password Version: 8.0.34-1
Extension Version: Not Provided
OS Version: Archlinux
Sync Type: Not Provided

Comments

  • I'm not sure what changed, but now it instead fails with:

    The futex facility returned an unexpected error code.
    1password' terminated by signal SIGABRT (Abort)

  • ag_Christianag_Christian

    Team Member

    Hey there, @layeggistrue

    I tried reproducing your issue with the latest version of 1Password in the AUR (8.0.34) but wasn't able to get the same result. My testing device is using Manjaro. This is the output of running uname -a on my machine: Linux <hostname> 5.9.16.1-MANJARO #1 SMP PREEMPT <date> x86_64 GNU/Linux.

    Would you mind running the same command? Please also try running 1password --version from the terminal and seeing if that aborts too. If it doesn't, please try checking out the applications logs at ~/.config/1Password/logs and looking for any errors?

    Looking forward to your reply.

  • Linux 5.12.8-arch1-1 #1 SMP PREEMPT x86_64 GNU/Linux

    --version and --help do not abort. Everything else does. There are no logs in the config dir. I also tried the AUR package, but same result.

    I sent along strace output to support, but nothing obvious popped out at me.

  • SavanniSavanni

    Team Member
    edited June 4

    Hi, @layeggistrue . I've seen this problem as well, but when I was bundling 1Password for NixOS. I don't think that the things that I learned will apply in your case... but maybe?

    One thing is that not all of the libraries that you need will actually cause electron to abort with a helpful error message. So, here's a list of the libraries I had to include:

    • alsalib
    • at-spi2-atk
    • at-spi2-core
    • atk
    • cairo
    • cups
    • dbus
    • expat
    • gdk-pixbuf
    • glib
    • gtk3
    • libX11
    • libXcomposite
    • libXdamage
    • libXext
    • libXfixes
    • libXrandr
    • libdrm
    • libxcb
    • libxkbcommon
    • libxshmfence
    • mesa
    • nspr
    • nss
    • pango
    • systemd

    The other problem I had may be really, really specific to NixOS, but we have to patch pre-compiled binaries in order to handle the fact that ld isn't stored in a normal location.

    I'm not sure where to go from here, so I'll work on trying to reproduce this myself. I saw that you're using a rather "minimal" Arch, which could mean a lot, but I'll try building a machine that has very little more than 1Password and a window manager.

    Here's a link to the NixOS install script: https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/misc/1password-gui/default.nix

  • SavanniSavanni

    Team Member

    @layeggistrue Hi, again. I just worked with another user and they discovered a solution that may be more relevant to you.

    Are you running a Wayland display? If so, could you please ensure that XWayland is installed. Alternatively, could you try launching 1Password in XWayland mode as described in this week's release posting?

    If this works for you, I'll see if I can find a way to detect this scenario and make a more helpful error message.

  • I actually am that other user, haha. Success!

  • Dayton_agDayton_ag

    Team Member

    Ah, that's great @layeggistrue! I'm glad @Savanni was able to help you out here. :smile:

  • SavanniSavanni

    Team Member

    Well, thank you, also, @layeggistrue!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file