Chrome autofill not working

pbhoganpbhogan Junior Member
edited June 7 in 1Password in the Browser

As of the last 1Password update or so, when I click the 1Password extension button in Chrome, it dutifully comes up, selects the right site login but when I double click the entry or click autofill it opens a new tab instead of filling in my credentials on the current page like it has for years.

Is this a known bug, or some new default I need to change? I combed through the settings and the only thing I found was the setting for whether autofill should fill in a new tab or new windows, etc. I just want it to fill in the current page.

1Password 7
Version 7.8.5 (70805000)
Mac App Store

Google Chrome
Version 91.0.4472.77 (Official Build) (x86_64)

1Password Extension
Version 4.7.5.90


1Password Version: 7.8.5
Extension Version: 4.7.5.90
OS Version: macOS 10.15.7
Sync Type: Not Provided

Comments

  • pbhoganpbhogan Junior Member

    For what it's worth, I tried "Quit 1Password Completely" and restarted both 1Password and the browser.

  • Nhat_NguyenNhat_Nguyen

    Team Member

    Hello @pbhogan,

    This issue usually occurs when you have two 1Password extensions in Chrome when you use the classic extension to autofill your websites. Can you open your browser > copy and paste this text to the browser's address bar: chrome://extensions/ > Press enter / Return. You should see either "1Password - Password Manager" or "1Password extension (Desktop app required)". For the best experience, I recommend you keep "1Password - Password Manager" and remove "1Password extension (Desktop app required)" since we no longer release new updates for it.

  • pbhoganpbhogan Junior Member
    edited June 7

    Thanks, that solved that problem (more or less) but now the new extension seems to be having trouble integrating with the 1Password app. When I try to unlock it stalls after entering my password while saying unlocking and then won't do anything anymore. I did the whole quit completely dance restarting everything, and it keeps doing it.

    It does actually unlock the 1Password app, but the extension doesn't seem to realize it.

  • pbhoganpbhogan Junior Member

    I uninstalled the extension and reinstalled it and that seems to have fixed the connection.

    Boy, the extension has gotten SO unreliable over the last few months and years. Every time something updates it breaks and you have to restart one or both or reinstall something. For crying out loud... I'd gladly opt into some less secure mode to stop it doing that all the time. This much friction just makes people want to stop using a password manager entirely.

  • ag_yaronag_yaron

    Team Member

    Hey @pbhogan ,
    Thanks for the update and additional information.

    We hope your experience would be much more stable now with the new extension as you got it running properly. It does have some improvements on that front and should keep working even if the connection to the desktop app is severed (you will have to unlock with your Master Password though), so hopefully you'll find these new improvements helpful.

    If you encounter any other issues, we'll be happy to help!

  • I have the same issue and only have one extension in chrome. I have tried the same with rebooting. I noticed that this occurs when

    1. I can't remember my password / login combo and then do not allow "save in 1Password"
    2. log back out of the website (now that I remember the combo)
    3. now attempt to save into 1password via the browser.

    that it will fill in the login automatically but not the password. In the past, i worked around it by creating a new pass/login combo within the app directly. That didn't work this time. Sigh.

    Chrome
    Version 92.0.4515.159 (Official Build) (x86_64)

    MacBook Pro 2016
    Big Sur 11.5.2

  • ag_chantelleag_chantelle

    Team Member

    @anikapur

    Can you confirm which version of 1Password you're using in Chrome? Also, is this happening on one site in particular - or is this behaviour consistent across all the sites you visit?

  • Hi it's the same for me. Mine is:
    1Password 7
    Version 7.8.7 (70807004)
    1Password Store

    Chrome:
    Version 92.0.4515.159 (Official Build) (x86_64)

    It opens a new tab everytime when I try to autofill. The problem is for every site.

  • ag_anaag_ana

    Team Member

    @quincreatives:

    What version of the 1Password browser extension are you using in Chrome?

  • It’s 2.0.5

  • @quincreatives

    If you go to chrome://extensions, do you have more than one version of 1Password installed? When you click Autofill is it from a grey icon in your browser toolbar or the blue 1Password icon?

  • The same is happening for me:
    mac 11.5.2
    chrome 93.0.4577.63
    freshly reinstalled 1Password app and extension: Version 7.8.7 (70807004) - reinstalled because of the issue

    1. The desktop app never auto-fills but opens a new tab and still leaves all fields blank.
    2. The window randomly works with different shortcuts: either cmd+\ or option+cmd+\
    3. Chrome extension sometimes gives empty suggestion box at password field or not, but always empty.
    4. In the last few months I constantly had to reinstall the chrome extension because the desktop app did not find it, now it is completely broken.

    When I switched from Lastpass a few months ago I totally loved the service but now it is a complete mess, behaves differently across computers, in general, it wastes a lot of time.

  • ag_yaronag_yaron

    Team Member

    Hey @msiger ,

    Sounds like multiple different issues here. We'll need to take a look at your setup in order to clear everything out and get things working properly.
    Can you please email us all this info, alongside a diagnostics report to [email protected] so we can troubleshoot this with you?

    Thank you.

  • @ag_yaron submitted

  • ag_anaag_ana

    Team Member

    @msiger:

    Thank you! Have you received a ticket number already?

  • Hey! I'm having the same issue but without the double extension. The only extension I have is: 1Password extension (desktop app required)

    The 1password icon in my top toolbar is gray. Once I have the 1password window open and the site I'm trying to log into open, the "Autofill" button is blue. When I click it, it opens a new window.

    1Password 7
    Version 7.8.7 (70807004)

    Google Chrome
    Version 93.0.4577.63 (Official Build) (arm64)

    macOS Big Sur
    Version 11.5.1

    Thank you for your help!

  • @brachela

    Do you have more than one version of 1Password installed in your browser? You can verify under chrome://extensions. If you have multiple profiles, it would be useful to confirm there as well.

  • No, just the one.

  • @brachela

    It might be useful for us to get a deeper look at what's going on on your Mac. I'd like to ask you to create a diagnostics report from 1Password on your Mac and send it to us at [email protected] with a link to our current discussion. One of our team members will have a look and let you know what we find.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file