UI Issue: HiDPI Scale scales twice in Kubuntu 21.04 Making it Extremely Large

As mentioned. The problem is the scaling factor which may have been changed by the system itself. If there is a scaling factor also in 1Password itself, it perhaps needs to be removed to re-fit the system scaling factor. This is done possibly by the system (or KDE) for the purpose of unifying the scaling making a better UX.

It shall be noted that the Brave Browser also had this problem since the update of Kubuntu 21.04 but quickly had it fixed. So far, not yet for 1Password.


1Password Version: 8.1.0-45
Extension Version: Not Provided
OS Version: Kubuntu 21.04
Sync Type: Not Provided

Comments

  • SavanniSavanni

    Team Member
    edited June 22

    Hi, @Wieczorkiewicz . Are you running KDE on Wayland or on X11? I have something for you to try, but this is a problem that I'm running into with a lot of applications right now and I don't have a good solution. For the moment I have simply reduced the resolution of my monitors and turned the scaling factor down to 1. It works... usually.

    If you're on Wayland, please try launching 1Password in wayland mode and let me know how it goes. It would be an interesting additional data point for me.

  • Thanks for the response. It's X11 because I use nvidia cards both on desktop and laptop. Desktop is a standalone card and laptop is a hybrid. Both have the same symptom with the scaling factor set to 2.0 and 2.5 respectively. The 1Password Application scales in the same way. And there is no way to set the factor down to 1 because everything will be tiny to see and work with.

  • SavanniSavanni

    Team Member

    Okay, I'll switch over to X11 and see what I can do about this. It certainly is annoying, so I'll see about figuring it out.

    Do nvidia cards not work even with Gnome-shell or Plasma? I know that the Sway developers have rejected them, but I haven't read any statements from the other groups.

  • SavanniSavanni

    Team Member

    Hi, @Wieczorkiewicz . This looks like it will take a lot longer than I expected, as I cannot actually reproduce the problem on an Xorg based system. I just want you to know that I haven't forgotten you.

  • same here, just updated to 8.1.1, the previous version is fine.

    using i3 and scaled with xrandr.

  • SavanniSavanni

    Team Member

    @Wieczorkiewicz I just ran some really extensive tests, and discovered some... interesting things. For your purposes, you'll be interested in my KDE X11 results, which are like so:

    On scales of 1, 1.5, and 1.75 (which I tested), everything seems totally normal. But for scale 2, KDE seems to communicate a scale of 4 to 1Password. If you're on a 3840x2160 screen, this means that 1Password is being rendered as though it's on a 960x540 screen. Hence, it is huge.

    So, please try this on the command line for me: 1password --high-dpi-support=1 --force-device-scale-factor=2, and let me know how that goes.

    @LeoDT I haven't looked at i3 yet, but that's coming up.

  • SavanniSavanni

    Team Member

    @LeoDT, could you tell me what xrandr parameters you are using, and the native resolution of your monitor? For me, if I use the --scale parameter (in exactly the opposite direction of everything else, I never dreamed that --scale 0.5 would be how I say zoom in...), 1Password is able to detect a reasonable screen resolution.

  • LeoDTLeoDT
    edited July 8

    @Savanni

    xrandr --output DP-1 --scale 2x2 --pos 0x0 --primary --output eDP-1 --pos 5120x0 --mode 3840x2400

    tried with 1password --high-dpi-support=1 --force-device-scale-factor=2.5 looks fine for me.

  • edited July 31

    I can reproduce this as well. 4x scale. My system:

    GDK_DPI_SCALE=0.5
    GDK_SCALE=2
    

    The suggested workaround (1password --high-dpi-support=1 --force-device-scale-factor=2) works as expected.

    However, ideally it should be working out-of-the-box, without those custom flags. 1password is the only GTK application in my system that is scaling 4x, all others are correctly scaling 2x. This seems to suggest it's a bug from the 1Password side.

  • Update: The suggested workaround does not work as expected in all scenarios.

    If you press Ctrl+Shift+X in a browser (e.g. Chromium) then the 1Password Desktop App is still opened with 4x scale, even with the above workaround.

  • Dayton_agDayton_ag

    Team Member

    Hey @thiago_101, thanks for highlighting this! I've filed this internally for @Savanni and the rest of the Dev team to look into, particularly the notes regarding GDK_DPI_SCALE and GDK_SCALE. Thanks again for sharing your results (and apologies for my delay here)! :smile:

    ref: /dev/core/core/#9370

  • Although not explicitly announced in the Release Notes, this issue seems to have been fixed in 1password-beta 8.2.0_56.BETA-56. My settings are the same as my previous comment, and the resolution is now correct. Did you fix it? :-)

  • Dayton_agDayton_ag

    Team Member

    Hey there @thiago_101, I'm glad things are scaling properly now! There's no direct changes to address this particular issue, but it's possible that a combination of updates cumulated in a resolution. The Dev team will be looking into the issue itself to see what could've caused this originally, and ensuring proper rendering/scaling is maintained going forward. :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file