Copy Password doesn't work

Hi Team,
when I click in the Early Access version on Copy Password it doesn't work, even if it shows that it copied the password.
I need to enter the Edit Mode and Copy the Password with the Control+C.


1Password Version: 8.1.2-82.BETA
Extension Version: Not Provided
OS Version: Windows 10 Build 19043.1110

Comments

  • ag_anaag_ana

    Team Member

    Hi @KevM92!

    I have just tested it and I was able to copy the password and paste it here.

    For confirmation, is this the Copy button you are referring to?

  • Maybe somewhat related (1Password for Windows 8.2.0-56.BETA), I also noticed the copy functionalities of the following items not working:

    • Account Dropdown -> Setup Another Account
    • Both the Copy of the Secret Key (maybe others) and the Copy Link for the sign in link do not work.
  • For me copy also does not work on Windows.

    It does work on macOS.

  • DenalBDenalB
    edited August 19

    For me copy also does not work on Windows.

    I'm on 1Password for Windows 8.2.0-56.BETA and have no problems with copying passwords or my secret key. I'm able to paste it e.g. into the notepad.

    EDIT: On 1Password for Windows 8.2.0-61.NIGHTLY copying works also without any problems.

  • robrob Agile Customer Care

    Team Member

    Hi, folks. It looks like we've seen a report before of the copy functionality intermittently not working on Windows, but we haven't been able to track it down. For those of you who have seen it not working, does it always not work or does it work sometimes?

    ref: dev/core/core#8718

  • I've definitely been affected by this, but not only on 1P8, but also 1P7 for Windows. I just tried copying different passwords in 1P8, and everything worked without a hitch, so it's absolutely intermittent.

  • @rob copy never works for me in the desktop app, but it works in the browser extension

  • I can have it working for quite a bit but then also have hours (or even days sometimes) that it won't work When it doesn't work I am able to past in the search field in 1password itself but never inside another app (browser, notepad, etc.). Haven't find how to trigger it though.

    Had it on earlier versions but just updated to 1Password for Windows 8.2.0-56.BETA and still experience it.

  • robrob Agile Customer Care

    Team Member

    When it doesn't work I am able to past in the search field in 1password itself but never inside another app (browser, notepad, etc.)

    Oh that's very interesting. I've passed on that note. Does anyone else here see this behavior when it's not working?

  • I can confirm it's NOT ALWAYS working. And I have the same problem on the latest beta / or nightly v8 on both mac & Windows. It's driving me mad tbh, I use it a lot for work in VM or login in games.

    It can work at boot or for some times, then nothing (you paste whatever was in your clipboard but not the "copied" item). Sometimes it will work again, but I couldn't track if I did something that helped. I'll check if I can past in the 1p search field.

    Changing "the clear password after xx time" setting didn't change a thing. I hope you crush this one soon because it's DAMN annoying...

  • @rob I can confirm that it works INSIDE 1P but not outside. I can C/C in the 1P search field but not pasting anywhere else. And the clipboard don't show it.

  • PeterG_1PPeterG_1P

    Team Member

    Thanks for this, @Cafeine. We will try to see if we can track this one down and figure out what it's about. The details do help!

  • Thanks and good luck! I hope you'll find that bug asap, because it's ANNOYING gnnnn. (and just to be clear, it's happening on macOS AND Windows.)

  • BenBen AWS Team

    Team Member

    Thanks @Cafeine. I've added a note to the issue indicating it is happening on both platforms for you.

    Ben

  • xeyrxeyr Junior Member
    edited September 10

    I'm seeing intermittent clipboard issues in Windows as well. I've seen some cases where I copy from 1P and it does not paste into Firefox (previous contents of clipboard are pasted), but if I go to notepad, it will paste the copied info from 1P (without hitting copy again) - so it seems like it's going somewhere, but not universal.

    80202032, on NIGHTLY channel

  • PeterG_1PPeterG_1P

    Team Member

    Thanks for this @xeyr, I've added this intriguing detail to our discussion around the issue. Thank you for the keen observation!

  • I've experienced the similar behavior under Windows in the last weeks, and even when using the most recent nightly build. Sometimes (unfortunately there is no easily identifiable pattern) when copying passwords from 1PW, it could not copy to some apps, but only to select ones. For example it's usual to me that sometimes passwords could not be copied to Remote Desktop Client, Remote Desktop Manager app, or even to Word, however it's always possible to copy it to Notebook. After copying to Notebook, and then copying it from Notebook, it finds it way to the correct place of the clipboard and it's possible to copy to Word/RDP/etc.

  • I believe this issue is due to the way the 1Password Beta app copies the password into the clipboard.

    Using NirSoft's InsideClipboard, I can see that 1Password only sets the CF_UNICODETEXT value but doesn't replace any previous values on the clipboard such a CF_TEXT and any images which are on the clipboard.

    I believe the solution would be to ensure the app replaces the entirety of the clipboard as well as setting the CF_TEXT value with the thing copied, not just CF_UNICODETEXT

    I noticed the issue because I can paste things into Notepad and search bars just fine, it's just when I have anything previous on the clipboard and paste into an app that can read those previous rich values, it doesn't read the text the 1Password app put in the clipboard.

  • BenBen AWS Team

    Team Member

    Thanks for the additional notes, folks. I've added these details to the issue referenced above. Hopefully we can track this one down quickly (thanks for the pointer @binaryoverload!).

    Ben

  • Hello,

    just noticed a weird behavior : copy is not working when your copy-paste from 1pw8 to browser but work if you paste in a text editor.
    After launching notepad and paste in it, copy is working in any browser (which was not the case before launching and paste in notepad).

    Thanks

  • I can confirm the behavior described by @binaryoverload. 1Password is not writing to all clipboard streams resulting in pastes intertwined with previous values depending on the value type supported by the receiving app.

  • PeterG_1PPeterG_1P

    Team Member

    Thanks for this, @Ashokleyland and @SixFive7. We're definitely pursuing this issue and appreciate you sharing what you've noticed about this on your device. Many thanks!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file