MRC Convert Issue

Hey,

Using mrc-converter-suite a while back to convert one of my bitwarden instances to a 1Password vault and it worked fine. I've come to use it this weekend and getting the following error:

Use of uninitialized value in join or string at
C:/Users/username/mrc-converter-suite/./Utils/PIF.pm line 684 (#1)

Line 684 is showing: debug " tags: ", unfold_and_chop(join('; ', @{$rec->{'openContents'}{'tags'}}))

Any idea's what's causing this? The script believes it's imported X amount of items but when importing the 1pif file, nothing gets imported into the vault.

Thanks!


1Password Version: 7.7.810
Extension Version: Not Provided
OS Version: Windows 10

Comments

  • MrCMrC Community Moderator

    @jlmo

    The error is suggesting that the Tags value for a particular entry is not something the converter is expecting.

    I presume this is the bitwarden converter? And what version?

    The lack of import from 1Password will occur if the converter creates a malformed 1PIF file, and this generally only happens when it’s input is an edge case I wasn’t aware could happen, or the input data is inappropriate.

    So, we should focus on the Tags value for the entry that triggers the error. Can you rerun the converter with debug enabled, and take a look at the output near the error.

    I’ll look at the converter tomorrow to review how this can happen.

  • @MrC Thank you for the quick reply.

    I'm using your 2021-06-18 release and yep it's Bitwarden. The only thing that's around the output of that error is:
    create_pif_record : key test(password): blanked-password Use of uninitialized value in join or string at C:/Users/username/mrc-converter-suite/./Utils/PIF.pm line 684 (#1) create_pif_record : tags:

    The tags value is blank, what's weird is it doesn't have any issue with other entries that has blank tags.

    Hope this helps.

    Cheers

  • MrCMrC Community Moderator

    @jlmo

    There are only two thigns added in the bitwarden export that can trigger adding tags:

    1. The item is a Favorite, and then a "Favorite" tags gets appended to the Tags list.
    2. The item contains a FolderID (i.e. it is part of a folder in Bitwarden).

    Both of these get added to the Tags.

    So one of the other one of those, in one of the BitWarden export entries has something funny with these values. Use the error message you see to help guide you to what BitWarden record is causing the anomaly. Does anything look incorrect about those values for said record?

  • @MrC Looking through the export, all looks ok to the naked eye.

    I forgot to mention that this is from Vaultwarden, not the hosted bitwarden service. Though after doing a quick test export from a hosted bitwarden, it's worked....
    I'll do some tests and will report back :)

  • MrCMrC Community Moderator

    @jlmo

    Ah, that explains it. I did not know about Vaultwarden.

    This situation not uncommon - open source password managers get re-worked, and their exports no longer match the expected export format of the original password manager, causing hiccups.

    Cheers.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file