1password app stopped working on Ubuntu 18.04.5

Since 1st September the 1password v8.2.0 app no longer works. The application runs up but appears as a blank window.
Is this a known bug and will it be fixed?
Thanks


1Password Version: 8.2.0
Extension Version: 2.0.5
OS Version: Ubuntu 18.04.5

Comments

  • edited September 3

    Hi,

    this sounds exactly the same issue that I had in this thread https://1password.community/discussion/123167/1password-snap-update-schedule#latest

  • PeterG_1PPeterG_1P

    Team Member

    Hi @dorothyDorothy, I'm very sorry to hear about this. I'll loop in our developers to see what can be done about this issue. Thank you for letting us know!

  • PeterG_1PPeterG_1P

    Team Member

    Hi @dorothyDorothy, a quick question: did you install 1Password through Snap? This may help us narrow down the issue. Thank you in advance!

  • Yes, this was installed via Snap

  • Hi there, I came looking to see if this was reported anywhere, as it's also happening to me. Happens when I install using the Debian package downloaded from your website, and also from my distro's built-in software installer.

    1PasswordX still works in the browser, as does the manually installed tar package, but I'd really prefer to use the .deb.

  • PeterG_1PPeterG_1P

    Team Member

    Hi @stevethepirate, sorry to hear this has affected you as well. We are actively tracking this issue and working to fix it.

    Just to double-check:

    1. Is it true that this issue occurs for you when installing using the installation instructions for Debian from our website here?
    2. What's the built-in software installer for your distro?

    So far this has seemed to be a Snap issue - if that's not the case for you, we'll certainly want to know. Thanks for helping us get to the bottom of this!

  • Interesting, when I installed 1Password via the command line using those directions, it worked no problem. Just to confirm I wasn't going crazy, I uninstalled it (again with command line), rebooted, and tried to use the built-in software installer to install. Once again, with the software installer version, I just get a blank window when I launch.

    One possibly relevant thing I noticed: through the command line, it reported that around 260 MB of space would be used by the install. The software installer is reporting that its version only takes up around 87 MB to install. Not sure if that's an expected difference, but it seems pretty huge. I confirmed that the software installer thinks it's pulling the same version (8.2.0) that was installed from command line.

    As for the software installer, it's just called "Software." Here is the detailed information it provided about itself. Let me know if there's anything else you need on that.

    Thanks for looking into this.

  • icoleicole
    edited September 7

    I am also getting this using either the Snap package or the RPM on openSUSE Tumbleweed. Tried the latest beta with no luck as well.

  • 1P_Claudio1P_Claudio

    Team Member

    Thank you for letting us know this worked for you @stevethepirate and for the additional info. I've passed this along to our development team so we can get a fix in place as soon as we can.

    @icole I'm sorry to hear that you're experiencing the same issue despite trying a different install method and the beta. If you could reach out to us at [email protected], we'll be happy to work with you to get things running as they should. :)

  • The 1password app (8.2.1) is now working very well. Thank you for the fix

  • PeterG_1PPeterG_1P

    Team Member

    Hey @dorothyDorothy, it's great to hear this worked for you. We've been very excited about getting this set right! 👍

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file