Accented/non-US English keys not accepted in keyboard shortcuts [investigating]

Gilles9Gilles9 Senior Member
edited September 9 in Early Access

On a French Canadian Keyboard, to use "command \" we need to use the upper case key ( command -uppercase-\ ) as the symbol "\" is an uppercase ( key below the esc key, which as "/" as the normal key, "\" as an uppercase key, and "|" as an option key )

and that short cut "command-uppercase-\" is used by Safari to "show Tab overview"

so it is unusable, and even if it was usable, using 3 keys for a shortcut is not very user friendly,

are you folks going to give us an option to use anything we want as a shortcut ?

( in Version 7 and prior, my shortcut key was "command-à" which was simple and easily usable )


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided

Comments

  • roustemroustem AgileBits Founder

    Team Member

    @Gilles9 it should be available today:

    1Password 8 Preferences

  • Gilles9Gilles9 Senior Member

    @roustem

    are you saying that customizing the "Fill in Browser" is to be customizable today ? so I can use "command-à" as a shortcut

    As from beta 8.2.2 beta 23 and Nightly beta 29 it is NOT customizable

    Maybe we did not understand each other clearly

    Thanks

  • BenBen AWS Team

    Team Member

    @Gilles9

    Could you please post a screenshot of what you see in 1Password > Preferences > General while on the latest nightly?

    Ben

  • Gilles9Gilles9 Senior Member

    @Ben

    This is what I see:

    The problem is that if I type "command-à" in the "Fill in Browser" field it ends up showing "command-\"
    if I type another letter than "à" then it works

    makes me think that 1Password does not recognize my keyboard ( French Canadian) keys correctly as it shows "\" when I type "à"
    ( it also shows " ' " when I type "è")
    so the preference field for "fill in browser" thinks or consider I have an English USA keyboard

  • BenBen AWS Team

    Team Member

    @Gilles9

    Thanks! So, it is customizable, but cannot be customized to use à or è. Is that correct? Does it work with letters on your keyboard that do not have an accent?

    Ben

  • Gilles9Gilles9 Senior Member
    edited September 9

    @Ben

    Yes it does but not for any keys that are different from the English US and the French Canadian keyboard
    example: é,ç, " ^ " etc...

    plainly the customization only works for an English US qwerty keyboard
    needs some localisation for 1Password V 8

  • BenBen AWS Team

    Team Member

    Gotcha! Thanks for letting us know @Gilles9. I've opened an issue for our development team to investigate.

    Ben

    ref: dev/core/core#9977

  • Gilles9Gilles9 Senior Member

    @Ben

    I would add that any key I use, just does not work at all

  • BenBen AWS Team

    Team Member

    @Gilles9 Does this mean that for example if you set the Fill in Browser shortcut to ⌘', Fill in Browser does not activate when you use that shortcut (assuming it is not already in use for something else)? Note that Fill in Browser currently only works on sites where you have exactly 1 Login item that matches. It doesn't currently do anything if there are 0 or more than 1 match.

    Ben

  • Gilles9Gilles9 Senior Member
    edited September 9

    @Ben

    Yes this is what I meant

    using any "command- anykey" does not fill in on any site, that I have 1 match only

    as if, my keyboard is not recognize by 1Password

    note in version 7 or prior, of course 0 match did not work, but multiple match would give me the choice ( hope this will come as well in V8)

  • BenBen AWS Team

    Team Member
    edited September 13

    Thank you for the additional information @Gilles9. Also, yes, we do have plans to support the case where multiple item matches exist.

    Ben

  • viswizviswiz
    edited September 13

    I have a very similar problem with German keyboard layout. Traditionally the 1Password shortcut was CMD #. If I try to assign this with 1Password the # is immediately replaced by . It seems your shortcut editor doesn't respect the actual keyboard configuration. Another example. The German keyboard layout exchanges Z and Y compared to the US layout. Trying to assign CMD Z an a German keyboard becomes CMD Y in 1Password.

    I've hit CMD Z or "Fill in Browser"

    "Select Locale" in 1Password's Preferences is set to "Use system defaults" just in case it matters.

  • BenBen AWS Team

    Team Member

    Thanks @viswiz. We were able to reproduce this internally. Hopefully that means we'll be able to find a way to fix it soon. :)

    Ben

  • Would be great if this could be fixed. I'm also using a German keyboard and stumbled about this issue too. ;)

  • ag_anaag_ana

    Team Member

    @DenalB:

    I will let the developers know, thank you for the feedback :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file