1password 7 beta expired

1password 7 Beta version expired, download stable version from website, installed, it found updates, downloaded and installed, then expired again.

Are we be pushed to use 1Password 8 for beta now?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided

«1

Comments

  • Yep, this happened to me too... Seems like something has gone wrong.

  • I have had to disable the beta builds in the preferences for now... It just goes in a loop.

  • ag_anaag_ana

    Team Member

    Hi @Leon Guan!

    It sounds like you installed the stable version, but then checked for beta updates once again. Since there has not been a new beta update recently, if you try to search for beta updates, it will just find the expired one. For now you would need to disable the checkbox to include beta results from the settings, until the next beta is published.

  • ag_anaag_ana

    Team Member

    @neddy:

    I have had to disable the beta builds in the preferences for now... It just goes in a loop.

    Since the last beta is expired, this would be correct, or you would keep installing the expired version. You can re-enable that option once the next beta becomes available :+1:

  • I would think this could be managed better. I signed up for the beta to help out, seems weird that it just expires without warning and goes in a loop after it expires, continuously trying to download the beta until you realise what it's doing and go and uncheck the 'include beta builds'. I can guarantee a lot of uses would not figure that out. Just my 2 cents...

  • kezza25kezza25 Junior Member
    edited September 22

    Hi - this morning I'm being told my beta build of 1Password is out of date. I've downloaded the latest beta, and installed it, but this message is persisting and I can't open the 1password app.

    Any ideas?

    Thanks


    1Password Version: 7.8.8
    Extension Version: Not Provided
    OS Version: Not Provided

  • Same with me. I re-downloaded 1password 7 app. And it got fixed. I also unchecked the box "include the beta builds".

  • kezza25kezza25 Junior Member

    Thanks, 7.8.7 (non beta) works fine - that'll do for now - silly not to think of that :)

  • kezza25kezza25 Junior Member

    My 7.8.7 is auto upgrading to 7.8.8 beta so fingers crossed it works this time!

  • kezza25kezza25 Junior Member

    Nope, it's broken it again!

  • ag_anaag_ana

    Team Member

    @kezza25:

    Have you unchecked the box to include beta builds, as geoblis suggested? Since the latest beta is expired, you will keep getting the same error if you keep trying to update to the beta channel.

  • ag_anaag_ana

    Team Member

    Agreed @neddy :+1: To be honest, this is the first time I see a beta build expired on macOS, and I think it's because of all the development work that is currently going towards the 1Password 8 Early Access version. I think it would be great if the 1Password app could revert to the stable channel in these cases, or at least not try to update to the latest beta version automatically.

  • kezza25kezza25 Junior Member

    ah, good point - no I didn't (multitasking badly)

  • ag_anaag_ana

    Team Member

    No worries @kezza25! Let us know if unchecking that box helped :+1:

  • kezza25kezza25 Junior Member

    fingers cross that's sorted it.

  • ag_anaag_ana

    Team Member

    Perfect :+1::)

  • @ag_ana Is there a plan on releasing another, unexpired beta version so that we can all at least stay on the beta track?

  • F451F451 Pretzel Logistician

    I am running into the same issue. I reverted back to the release vs. the beta version and then tried to download the beta via the 1P preferences and ran into the same issue. Had to revert again to current standard release version 7.8.7.

    7.8.8.BETA-0 (build #70808000) does not work.

    I live life one beta at a time...kindly give me my beta back. Thank you.

  • teacy123teacy123 Junior Member

    I downgraded from beta to 7.8.7 but it seems browser plugins are currently not working. They pop up in the right fields, but the Unlock button does nothing.

  • verdi1987verdi1987
    edited September 22

    @teacy123, I experienced the same as you, but a logout and login resolved it.

  • Same problem here. It just kept downloading the 7.8.7 pkg. I checked in my downloads folder and noticed that once it downloaded the 7.8.8 Beta -0 pkg, and I was able to install it, but when I try to open it from the Applications folder I get the same Beta Expired message, and the program won't launch. Same happens when I try to use the Browser Assistant, so now I have no 1-PW.

  • OK, so suddenly a 1-PW Update notification for the 7.8.8 Beta-0 opened on my desktop, so I thought maybe it was fixed, so I allowed it to install. Nope, same problem: Beat Expired notice keeps popping up, even when trying to use the browser plugin. Then I tried to install the 7.8.7 pkg -- Installation Failed. So I tried again, and this time it worked, and the plugin is working, too. So I have 1PW back, but no Beta.

  • edsaiedsai Junior Member

    Any chance betas can be updated before their expiration causes a user some trouble?

  • With respect, this is not "perfect". I experienced a loop of beta expired, downloads the same beta, rinse, lather, repeat. If the beta is expired, the code (even if "allow beta" is checked) should not consider it for download/update. No other software that I allow beta's for would re-try the download of the expired beta.

    Waste of 30 minutes to sort it out.

  • TomDTomD Junior Member

    Same here. I had to download the most recent stable version.

  • I see that 7.8.8 Beta-1 has been released; it downloaded w/o issues and all is working well now. Thank you! 😊

  • F451F451 Pretzel Logistician

    My life is once again complete...7.8.8.BETA-1 fixed said issues. Thank you!

  • Complete and utter failure from 1password.

  • This is stupid that the beta cannot be installed, some big changes are coming to the software I'm certainly on the look around for something better any ideas?

This discussion has been closed.