Browser Autofill Shortcut does not work

SventekSventek
Community Member

Hi everyone,

I am a long time happy 1Password user and always enjoyed filling my passwords in Safari and Chrome by using the Cmd+\ shortcut whenever I encountered a sign in form.

Today, I decided to give the 1Password 8 Beta and the newest browser extensions a try (versions see below). In principle, everything still seems to be working as expected (extensions show in the Browser toolbars and I can manually fill credentials using the respective buttons in the extension UIs), but the mentioned keyboard shortcut no longer works (neither in Safari nor in Chrome).

In Safari, there is no reaction at all. In Chrome, the Mac menu bar flashes to 1Password for the fraction of a second, but no credentials are filled. This applies to all sites.

I double checked 1Password preferences and the shortcut seems to be set correctly. I tried to re-set the shortcut, but that didn't help.

My system is set to German and I'm using a German keyboard layout – maybe that may be a contributing factor?

I would appreciate any help. Thank you!


1Password Version: 8.2.2, Build 80202060
Extension Version: 2.0.6 (Safari), 2.1.0 (Chrome)
OS Version: macOS 12.0

Comments

  • ag_anaag_ana
    1Password Alumni

    Hi @Sventek!

    Our developers are aware of some problems with keyboard shortcuts on non-US keyboards, so this might actually be the same problem. I will let them know that you are also encountering this :+1:

    ref: dev/core/core#7697

    I double checked 1Password preferences and the shortcut seems to be set correctly. I tried to re-set the shortcut, but that didn't help.

    Out of curiosity, when you say "re-set", do you mean that you also tried a different keyboard shortcut before setting this one again? Did you have the same issue also with a different shortcut?

  • SventekSventek
    Community Member

    Hi @ag_ana, Thanks a lot for your reply!

    Out of curiosity, when you say "re-set", do you mean that you also tried a different keyboard shortcut before setting this one again? Did you have the same issue also with a different shortcut?

    Yes, I tried an alternative shortcut (a simple one without special characters) and then changed it back to the default. None of them worked. Interestingly, all other shortcuts (except Fill in browser) work fine – it's just the one that doesn't show any effect.

  • @Sventek

    Thanks for confirming those details. I have a feeling your suspicions are correct, that the German layout may be applicable here. If you change your keyboard to a US keyboard layout, for testing purposes, does the shortcut work for you then?

    ref: dev/core/core#7697

  • SventekSventek
    Community Member

    Hi @ag_chantelle, I just tried doing that (changing MacOS to the US layout, reregistering the shortcut and then testing it), but unfortunately, the issue remains.

    Just to clarify: is the shortcut setting in the main 1Pass app (as shown in the screenshot below) supposed to have an impact on the new standalone browser extensions at all, or do these extensions have a their own shortcut settings somewhere and I just didn't find them yet? As I mentioned before, the three other shortcuts work perfectly fine.

  • @Sventek

    Just to clarify: is the shortcut setting in the main 1Pass app (as shown in the screenshot below) supposed to have an impact on the new standalone browser extensions at all, or do these extensions have a their own shortcut settings somewhere and I just didn't find them yet? As I mentioned before, the three other shortcuts work perfectly fine.

    Yes, as long as you have integration enabled the shortcuts will work. The only default shortcuts in the browser are activate or lock the extension. That said, we've had some versions where the shortcut only behaved in certain circumstances. For example, if you had a single Login saved for the site it should autofill immediately, but if you have multiple Logins then filling from the inline menu would be the way to go.

    I'd be interested to know if the behaviour improves with the beta version of 1Password for Chrome. Would you be willing to give it a try? You can install it from here: https://support.1password.com/betas/#install-a-beta-release-of-1password-in-your-browser. Be sure to disable your current version before testing.

    Let me know how it goes. I'll be here to help.

  • SventekSventek
    Community Member

    Hey @ag_chantelle, I think you figured it out!

    That said, we've had some versions where the shortcut only behaved in certain circumstances. For example, if you had a single Login saved for the site it should autofill immediately, but if you have multiple Logins then filling from the inline menu would be the way to go.

    This indeed seems to be the issue. I hadn't noticed initially, because I have multiple sign ins for many of the sites I regularly visit, but the shortcut indeed works for sites where there is a single suggested set of credentials only. This also applies to the latest Chrome beta (I think I have it, it's version 2.1.3).

    I have the inline menu disabled because it optically clashes with my Safari password suggestions which I still use in parallel, so I think it would be awesome if the shortcut would show some kind of UI prompting me to pick the login I wanted to use in case there are more than one. That's also how previous browser extensions seem to have handled cases like this. My reasoning behind this is that once my muscle memory is trained on pushing Cmd+\ once I see a login prompt, the shortcut should always result in some kind of response, even if it doesn't take me all the way immediately.

    Thanks for the great input, I already feel a lot better. 😄

  • SventekSventek
    Community Member

    Hi @ag_chantelle, would you happen to have any news about this issue? It's a month later and my muscle memory is still confused when I hit the shortcut and nothing happens for sites where there is more than one suggested login. 😄

    Thank you!

  • SventekSventek
    Community Member

    I'm glad this works again for you @m4gr01ino, but thanks for resurfacing this thread!

    Indeed, the new Browser Extensions still don't show the UI to pick a login when the shortcut is pressed if there is more than one sign in for a page. This still feels weird to ma after a few months, so I would again like to suggest changing the behavior to the one shown by the classic extensions:

    1. If there is a single matching sign in, fill it immediately.
    2. If there are more than one sign ins, show a UI to pick one of them.
  • SventekSventek
    Community Member

    Ah, is it showing the in-page dropdown menus (attached to the form) for you when you hit the shortcut in the new extensions? I got these globally disabled for the same reason as you, so maybe that's why I'm not seeing anything.

    The classic extension then shows the regular extension UI (from the browser menu bar) instead and allows the user to pick a login, which I always thought of as a great alternative to the UI showing up in forms and clashing with my iCloud keychain recommendations.

  • Jack.P_1PJack.P_1P

    Team Member

    Hey folks, thanks for bringing this back up!

    @m4gr01ino:

    Are you using 1Password 7, or 1Password 8? The screenshot you've shown is from 1Password 7 for Mac, not 1Password 8 for Mac. Let me know, and I can split off your posts and we can dig into it a bit further with you!

    @Sventek:

    As we rely on 1Password in the browser to do the heavy lifting on field detection, using ⌘+\ to fill does require 1Password in the browser to at least have "Offer to fill and save passwords" enabled in Settings (Right click the 1Password icon in your browser's toolbar, choose settings, then the Autofill section). The autofill menu can be configured to not drop down automatically on field focus however, using the option "Show autofill menu on field focus".

    Let me know how you get on with that!

    Jack

  • SventekSventek
    Community Member

    Hey @jack.platten,

    As we rely on 1Password in the browser to do the heavy lifting on field detection, using ⌘+\ to fill does require 1Password in the browser to at least have "Offer to fill and save passwords" enabled in Settings (Right click the 1Password icon in your browser's toolbar, choose settings, then the Autofill section). The autofill menu can be configured to not drop down automatically on field focus however, using the option "Show autofill menu on field focus".

    This helps a lot, thank you! Only enabling the top option and keeping the lower one disabled seems to get me rather close to the intended result. I'll try this for a while. :-)

  • Jack.P_1PJack.P_1P

    Team Member

    Hey @Sventek:

    Glad to hear that gets you close to what you'd like to see. Be sure to let us know how you like it!

    Jack

  • dgbeecherdgbeecher
    Community Member

    1Password 8 "Fill in Browser" works maybe half the time for me. I do have "offer to fill and save password" enabled in 1Password for Safari. I have standard US keyboard layout enabled.

    This feature worked 90% of the time on 1Password 7, so it's sad to now be running into this problem so often. Please let me know what I can test or try to improve this.

    I'm using 1Password for 8.5.0, 1Password for Safari 2.2.3, macOS 12.1.

  • Jack.P_1PJack.P_1P

    Team Member

    Hey @dgbeecher:

    Thanks for following up. We're actively investigating situations where the Fill in Browser shortcut doesn't work as expected, so stay tuned as we continue to work on this.

    Jack

  • guyrozendornguyrozendorn Junior Member
    Community Member

    It worked great for me w/ 1P7, but does not work at all in 1P8.

  • PeterG_1PPeterG_1P

    Team Member

    Thank you for letting us know, @guyrozendorn, and I'm sorry to learn this has been your experience. Can you let us know what platform (Mac, Windows, Linux) you're using, as well as what version of 1Password you're on? We'll be happy to further pursue this on our end.

  • guyrozendornguyrozendorn Junior Member
    Community Member
    • macOS 12.3.1
    • 1Password for Mac 8.7.0, 80700090, on BETA channel

    Tried with Safari, Opera, Chrome, same result.

  • MindFadMindFad
    Community Member
    edited April 25

    Just popping in to say that the autofill shortcut doesn’t seem to work any longer for me as well on the latest beta build (neither does ⇧ ⌘ Spacebar for Quick Access). Previously it would initiate asking for a password, but no longer. Have to manually click 1Password in the Dock or click the toolbar icon in Safari to get it to ask for the password unlock. After this, both shortcuts usually work fine (while the unlocked state is active; after it auto-re-locks, the shortcuts are dead again).

    • macOS 12.3.1
    • 1Password 80700090 beta.
  • Jack.P_1PJack.P_1P

    Team Member

    Hi @MindFad:

    That definitely isn't the experience we want you to have when using 1Password. I'd like to ask you to create a diagnostics report from your Mac, as well as a console log:

    Sending Diagnostics Reports (Mac)

    Save a console log for 1Password in your browser

    Attach the diagnostics report and the console log to an email message addressed to [email protected].

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

  • jjmzjjmz
    Community Member
    edited August 4

    I am using the production version of 1Password 8

    1Password for Mac 8.8.0

    80800203, on PRODUCTION channel

    And form fill is VERY unreliable. It does not work more times than it does. This is a HUGE step back from 1password 7 when it worked reliably. Not sure how this is even production software when it does not do the CORE function of what its purpose is. Not sure how this even passes unit testing, let alone functional testing.

    Almost always, I have to try 2-3 times of Cmd+/ for it to fill - and often I have to move cursor to a different field on second or third try for the form to fill..

    Is someone even looking into this? I am on Mac OS 12.5..

    Ticket # UNV-21149-852

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file