Not showing matching logins in Safari

After latest beta update, 1Password no longer shows matching logins when you click in the username or password field in Safari. It works in Firefox. See video

https://drive.google.com/file/d/1tEL2zx1BbbYVsPsZg3_n1--MzsBuJfFO/view?usp=sharing


1Password Version: 7.8.8 (70808005)
Extension Version: 7.8.8
OS Version: 12.0 Beta 9 (21A5543b)
Referrer: forum-search:Not showing matching logins in Safari

Comments

  • Having the same issue... Mac - 12.0 Beta (21A5543b), Safari - 15.1 (17612.2.9.1.1), 1Password - 7.8.9.BETA-0 (build #70809000)

  • ag_yaronag_yaron

    Team Member

    Hey guys,
    If you haven't already, please try restarting the computer and see if the issue persists.

    Some other suggestions that you can try if restarting didn't help:

    • Try going into Safari's preferences -> Extensions -> Turn off 1Password and then turn it back on.
    • Try going into 1Password 7's preferences -> Browsers -> Turn the inline menu off and then back on.
    • In Safari's preferences -> Advanced, turn on the "Show develop menu in menu bar", then select the Develop menu at the top and navigate to "Experimental features" -> "Reset all to default".

    Let us know which of the above helped (if any).

  • None of that seemed to help

  • I am having the same problem here. Guess I'll be back in Firefox for the time being.

  • ag_yaronag_yaron

    Team Member
    edited October 13

    Thanks for the update guys.
    This seems to be an issue with the latest Safari beta (15.1) - the 1Password inline menu won't work there. This has been filed with Apple and hopefully will be fixed in the next Safari beta.

    For now, you can:

    • Utilize the 1Password extension icon in Safari's toolbar to autofill.
    • Revert back to the stable version of Safari.
    • Install 1Password 8 and 1Password for Safari.

    ref: dev/core/core#10550

  • Install 1Password 8 and 1Password for Safari.

    Solved the problem

  • ag_chantelleag_chantelle

    Team Member

    @jjstipe

    Glad to hear updating to 1Password 8 and 1Password for Safari did the trick for you! :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file