[Docker] [Plesk] Updating / syncing not working as expected

GuntramGuntram
edited October 11 in Secrets Automation

We are running the Secrets Automation using Docker on Plesk Obsidian. Making everything work was a little bit tricky (as detailled in another question in this forum) but as of now, we can query the api as expected.

Recently, we added some new logins to the vault and tried to access them with the api. Unfortunately, that did not work. Turns out, the docker 1pw sync container doesn't sync the vault. When I query the full vault with Postman, the added logins are not there. They turn up on my local docker container however, so the sync should be working, it's just not doing that on Plesk.

We tried stopping / restarting the containser, recreating them, no luck so far. The logs (OP_LOG_LEVEL=DEBUG is set) don't reveal anything out of the ordinary. Maybe there is a way to force-sync the container?

Any help / ideas / suggestions will be greatly appreciated!!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Ubuntu 20.04.3 LTS

Comments

  • We figured it out, the permissions given to the folders / files created by docker / plesk were insufficient, we updated the permissions, recreated the containers, then it worked.

  • ag_anaag_ana

    Team Member

    Thank you for sharing the solution @Guntram! I am glad that everything is working as expected now :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file