The app was not correctly configured and cannot access your Dropbox

seanycseanyc
edited November 2 in Android

Just upgraded from a Pixel 2 XL (Android 11) to a Pixel 6 Pro (Android 12) and I cant seem to connect to Dropbox to access my vault. I couldn't seem to find anything relevant on the forums or google search.

At first I tried going directly through 1password, selecting dropbox, and signing in but that didn't work.

I then erased storage/cache for both dropbox and 1password and tried signing into Dropbox first, then connecting 1 password to dropbox only to end up with the same error message.


1Password Version: 7.9
Extension Version: Not Provided
OS Version: Android 12

«13

Comments

  • jack.plattenjack.platten

    Team Member

    Hi @seanyc:

    We're currently investigating this, and hope to have more information soon.

    As a workaround, we've discovered that uninstalling Dropbox will result in the authorization flow using your web browser without issue, rather than the Dropbox app.

    Let me know if that works, or if you're still running into trouble.

    Jack

  • Hey @jack.platten ,

    I was hopeful for this workaround but it didn't seem to work for me. 1Password correctly loaded the oauth screen, but when I press "Allow" nothing happens. Tried to do some network inspecting and it seems like the POST request to https://www.dropbox.com/1/connect_submit gets canceled for whatever reason.

    Open to any other workarounds to get this working ASAP while your investigation is ongoing.

  • I can confirm I'm having the exact same issue. App has the same error above when trying to link with Dropbox app installed, and website doesn't allow me to click 'Allow' when the Dropbox app isn't installed.

  • Ok so I'm not sure what happened, or how, but I got it working.

    I went to an app where the input field suggested "autofill with 1Password". I tried tapping it and a popup said something about 1Password not being configured yet. I pressed okay (or whatever the only CTA button said) and it seemed to actually find and load the vault from my dropbox. Not sure if this was fixed because of autofill after trying the web page authorization (which didnt seem to work). A part of me thinks maybe there's a race condition of some sort here? Maybe the fact, my dropbox is almost full, it could have taken a longer time than usual?

    In all honesty I was watching netflix and looked away for a bit. When I looked back down, it found the vault and was ready for importing.

    It might also be worth mentioning, for someone else having this issue, that I had removed my existing "1Password for Android" connection from the "Connected Apps" page in my dropbox settings. Not sure if that really had any effect but I've been desperate.

  • ag_anaag_ana

    Team Member

    Thank you for the update @seanyc, and for sharing it with the community! We will continue to investigate :+1:

  • I'm having the same issue (Pixel 6 Pro - Android 12). I uninstalled dropbox, got to the web page, logged in, and then couldn't move past the allow screen for granting rights to edit/view files. But found that going back from that page allowed the sync to complete, and I'm now functional again.

    Am I loosing anything from authorizing via the web vs the app? Can I reinstall the dropbox app now?

    Thanks!

  • jack.plattenjack.platten

    Team Member

    Hi @ClimbOn:

    There's absolutely no difference between authorizing between the Dropbox app or in the browser. Reinstalling the Dropbox app won't cause any issues now either.

    @lgnet:

    Did you have any luck using the methods @ClimbOn or @seanyc mentioned?

    Jack

  • @jack.platten Here's what I had to do based on the info above:

    • Delete Dropbox
    • Go to Dropbox website and remove 1Password for Android as a connected app.
    • Go back to 1Password and try to relink, it takes me to the dropbox web connect website.
    • Ultimately got to the decline/allow screen and clicked 'allow' but it didn't do anything.
    • Nonetheless, when I manually went back to the 1Password app it found the vaults.

    Not sure why all the hoops to jump through, whether it's 1Password, Dropbox, or Android at fault. Obviously it shouldn't need to take all this, but it connected for now.

    And while this may seem like a pointed question, it is not intended that way: 1Password's still planning on phasing us Dropbox users out I think, right? If so, I imagine fixing this won't be high on the priority list since we're eventually going away.

  • I'm having the same issue with Pixel 6 on Android 12.

    @jack.platten on your last step, "manually went back to 1Pass app". What do you mean by that?

  • I am experiencing the same problem. I just upgraded to Samsung Galaxy S20FE.

  • Same here too on my shiny new Pixel 6 pro on Android 12.

  • jack.plattenjack.platten

    Team Member

    Hi @jsc41, @Robertosky, and @Glenn_Bloke:

    It sounds like there might be a few issues at play here. Dropbox free accounts are limited to 3 devices as of recently, and when we were investigating this a few days ago, having 3 devices currently authorized to your Dropbox account before opening 1Password and attempting to link your Dropbox account caused issues.

    Please try this set of steps for me and let me know if you're still running into issues.

    1. Delete the Dropbox app from your phone.
    2. Go to the Dropbox website and disconnect the 1Password for Android app: Settings > Connected Apps > 1Password for Android > Disconnect
    3. Ensure that there's a spare device slot in your Dropbox account if you are using a free account: Settings > Security > Devices
    4. Re-open 1Password for Android, relink your Dropbox account using your web browser.
    5. If tapping allow to authorize didn't reopen 1Password for Android with your vaults connected, switch back to 1Password for Android and the file picker should be available then.

    We're still investigating and hope to know more soon.

    Jack

  • Great, following the steps worked for me. Thanks!

  • jack.plattenjack.platten

    Team Member

    Glad to hear that worked for you @jsc41. You're very welcome! :smile:

  • I'm experiencing the same issue. I followed the steps @jack.platten suggested but I'm stuck on the "Allow" window on Dropbox. Checking the Connected Apps on Dropbox, I can see that 1P has been added but the application on my Pixel 6 will not go past the "Allow" screen. Killing and even uninstalling, then starting the process all over again, was not successful. I'm still not past that screen. Any help you can provide will be greatly appreciated!

  • jack.plattenjack.platten

    Team Member

    Hi @cnaranjo,

    Sorry to hear you're still running into trouble. To confirm, that's with the Dropbox app uninstalled on your phone? Did switching back to 1Password for Android after tapping allow (even if it doesn't seem like pressing the button does anything) show the vault picker?

    Let me know, and I'll be able to investigate further.

  • Murphy was playing a joke on me... I had uninstalled Dropbox and followed all of the steps you suggested and it didn't want to work. So I uninstalled everything, restarted the phone, reinstalled 1P, followed the steps and now I can see the vault. Thank you!

  • jack.plattenjack.platten

    Team Member

    Glad to hear that worked for you @cnaranjo. You're very welcome! :smile:

  • lamenamelamename
    edited November 7

    @jack.platten Same issue here. Followed your steps and still not working on my Pixel 6. The "Accept" button just doesn't do anything. Neither does the "Cancel" button. All other links on that screen work though. I've tried switching back to the 1Password app but it just brings me back to Chrome and the Authorization screen. If I swipe up to close Chrome and switch back to 1Pass, it starts back at the beginning.

    If it matters, I've never had the Dropbox app on any of my phones, and I have a Dropbox Plus account.

    Now I can't sync on my old Pixel either since I disconnected all apps from Dropbox. Please help.

  • Super frustrating. I too am having same issue, and like @jack.platten I cannot get beyond the allow button. Allow button and cancel button do nothing. Going back to 1Password app just restarts the came endless loop that gets tuck on the allow button. Any other suggestions here?

  • I have exactly the same problem - "The app was not correctly configured and cannot access your Dropbox". However, I didn't change anything - did not upgrade to Android 12 nor change phones. I have Samsung Galaxy S21 and some time last week syncing just stopped working. I have a paid Dropbox account (so the devices limit can not be the problem here), and a paid version of 1Password.
    I tried removing "1Password for Android" from the list of authorized apps in Dropbox, and then launched 1Password again - it showed a dialogue asking to authorize, but after I clicked "authorize" it showed the same error message again. I tried to uninstall and re-install 1Password and Dropbox apps - not only it did not fix the problem, but it actually made worse, because now it can't even download the vault and shows the same error, so I don't have access to my passwords on my phone.
    Note that I also tried deleting Dropbox apps to force 1Password to use the web auth flow - this way, I get to the point where I'm asked which account to give 1Password access to (personal or work) and when I click "personal" nothing happens.
    Could someone from the support please escalate this to get it fixed, as there's simply no workaround for this issue.

  • Update: after writing a post here, I decided to do one more attempt, so I closed all open web auth pages (from the several previous attempts to authorize 1Password via web), went to 1Password again and suddenly this time it decided to sync without any additional questions asked. So I guess the workaround kind of works, but for whatever reason it may require several attempts (and a complaint on this forum :)).

  • jack.plattenjack.platten

    Team Member

    Hi @JFury:

    Glad to hear that worked for you.

    @dereksims / @lamename:

    Just to clarify, after tapping Allow on the Dropbox authorization on the web, returning to the 1Password app does not show the file picker?

    Jack

  • @jack.platten If I switch apps to return to 1password it just brings me back to Chrome and the Allow screen. If I swipe up to close Chrome then switch back to 1password, it starts back at the beginning.

  • periperi

    Team Member

    Hi @lamename. Can you please try connecting Dropbox again? When you get to the allow screen, tap the Allow button. At this point, don't exit Chrome or 1Password. Instead, tap the back arrow on your device to go back to the 1Password screen. Does that help?

  • @peri That did work. Could have sworn I did that before though. This time I closed all tabs in Chrome and closed all apps, plus used a different device for Google Authenticator. Not sure if switching between apps during the process caused it not to work, but thank you!

  • periperi

    Team Member

    I'm glad that did the trick! :+1:

  • @peri this worked for me as well. All is well again!

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation @dereksims, that is great to hear :)

  • I also had this issue on my Pixel 6, glad I found this thread as I was going crazy trying to get it to work. New phone, no passwords not a good combo. So I've synced using the dropbox web link, is it safe to now install drobox on the phone or wait till this gets sorted?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file