Defaults to main Collection on restart

With each restart of app, or seems even with enough inactivity to log out, the selected Collection reverts back to the main one. Meaning when using Quick Access it shows all Vaults and not the desired ones by custom Collection. So I have to manually go in again and select the desired Collection to get it to work...


1Password Version: 8.4.0
Extension Version: Not Provided
OS Version: 12

Comments

  • Hi @krusnof !

    This should be fixed in the latest nightly build 80400039. For me the collection and the category is remembered when restarting 1Password. Give it a try. :)

  • Hi @krusnof (and @DenalB ),

    The fix has also made it's way into 80400040, which is on the beta channel.

    Have a good weekend,

    James

  • Still not working on 80400047, on NIGHTLY channel
    However, it defaults to the the first Collection based on alphabetical order... So not main Collection...

  • @krusnof
    For me it works in 45-BETA. My selected vault (not the first one) is remembered...

    But I'm on the Windows version.

  • Still broken for me, on macOS (nightly) and Windows (beta).

  • namiaronamiaro
    edited November 10

    For me it works fine in 1Password for Windows 8.4.0 80400049 nightly - 1P8 remembers last used Collection, no matter what its name is.

  • PeterG_1PPeterG_1P

    Team Member

    Thanks for this update, @namiaro! 😀

    @XIII, what versions of the app are you currently running? If a fix isn't working post-update, we'll certainly want to follow up on that.

  • Seems OK now (80400049 nightly)

    Maybe I had to quit the App one more time after updating?

    (Maybe the bug was in saving the state, not in restoring it?)

  • ag_tommyag_tommy

    Team Member

    Thanks for the update XIII. Let us know if you have other suggestions/questions. Interesting thought on the save/restore state. I'll have to leave that to a developer.

  • @XIII, Thanks for following up. That makes sense. The solution was indeed a change to saving the state, instead of restoring. So your first launch on 80400040 would have nothing to restore.

  • Still and issue for me in 80500008. Problem is the main app is defaulting to the main collection and hence quick access does as well. Might be due to updating to new versions that resets it?

  • namiaronamiaro
    edited November 21

    For me it was fixed in the latest nightly but it stopped working again after updating to official stable release.

  • I'm on nightly builds (I've been pleasently surprised by progress!) and my main gripe now is after each lock the collection reverts to everything. I'd really like it to stick to the collection previously selected before the lock.

    80500011, on NIGHTLY channel

  • Still issue on 80500013

  • Seems to be a regression indeed; it worked on an earlier build, but is broken again on the nightly.

  • It doesn't seem to be a restart that does it for me but each time it's locked.

  • PeterG_1PPeterG_1P

    Team Member

    Hi folks, thanks for the update. We appreciate you letting us know about this one and have informed the developers.

    ref: dev/core/core#11004

  • Still.................... 80500036

  • ag_anaag_ana

    Team Member

    Thank you for the updates @krusnof! Hopefully our developers will be able to address this soon, keep an eye out on the release notes to see when this has been fixed :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file