Basic functionality on Android leaves something to be desired

MerryBitMerryBit
edited November 16 in Android

I want to begin by saying that the point of this post is not to deride 1Password's virtues, but my recent experience with saving new login credentials on my Android phone does leave me with an uneasy feeling about how much I trust can put into 1Password saving login credentials correctly and accurately.

Recently I signed up for an account with reedsy.com on my Android 11 phone. I entered some simple information like my name and email address as well as a strong password. The first hurdle I faced was that 1Password did not show up above the on-screen keyboard, so I had to open the 1Password app and create a new Login entry manually. I then copied the password and entered it into the signup form. Upon finishing the account creation process, 1Password did pop up, prompting me to save the information I had entered in the form. I accepted, and (another) Reedsy login item was added in the 1Password app. Since I expected this to be a duplicate of the first entry I created manually, I opted to deleted the first entry from the app and thought nothing more of it.

Some time later, I tried to log in to Reedsy, but it wouldn't accept the password. Puzzled, I opened the 1Password app and had a look at the password. A picture says more than a thousand words, so I'll share what I saw with you here:

The password you see in that screenshot is the actual password saved by 1Password, it's not masked out. It's obviously not the correct password, and amusing as this may seem on the face of it (I did manage to do a password reset, so that's not the issue here), my point with posting here is two-fold:

1) The whole experience on Android in this case--and indeed in most cases--is filled with friction, from 1Password not showing up above the keyboard when it should, to it saving my last name as the user name (also wrong) and an obviously incorrect password. Now, I'm not here to cast aspersions on 1Password the product or staff, because I know the fault may very well lie with the (lack of) third party integration possibilities in Android, but at the end of the day experiences like this make me question whether 1Password really makes my life any easier.

2) An experience like this why is a good example of why I cannot--yet, hopefully--recommend 1Password or indeed any third party password manager. Less technically inclined members of my family would never have the technical insight or patience to work around the quirks that I've described here, and they would be absolutely thrown off if 1Password had saved the password and then some site later would not accept it.

It's not often I create new Login items on Android, but when I do, I want to be able to trust that 1Password shows up when expected and that it saves the information I have entered correctly. I hope that the 1Password staff are able to provide some assurances that improvements to this basic functionality are in the works--at AgileBits or Google--because the current state of affairs on Android leaves some basic functionality to be desired.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided

Comments

  • ag_preetag_preet

    Team Member

    Hi @MerryBit, thanks for providing your feedback!

    Just for clarification, you're saying 1Password saved the concealing dots rather than the actual password? Have you noticed this behaviour with other sites as well or just Reedsy.com?

  • Hi @ag_preet Yes, 1Password saved the concealing dots as the password, which obviously didn't work when I tried to log in afterwards. I can't remember ever having seen this behaviour on any other site, no.

  • ag_preetag_preet

    Team Member

    Hi @MerryBit, the Android team has been informed of this issue and will be looking into it. From what you've stated, it seems as though reedsy.com is changing the password value into dots before 1Password is able to save it.

    Let us know if you see this issue anywhere else or if you have any other details to offer that might help.

  • mverdemverde

    Team Member

    @MerryBit thanks for continuing to follow up with us on this issue. @ag_preet brought this issue to my attention, so I was hoping that you could provide me with some additional information that will help us in tracking down the root cause of the issue. Could you provide me with answers to the following questions?

    1. What is the version number of 1Password that you're currently using on your Android device?
    2. What browser were you using when you saved your Login for reedsy.com and what's the version number for it?

    With your help, I'd like to rule out a recent change in our beta as a possible culprit for this before we move on to other causes.

  • @mverde I'm using 1P for Android version 7.9.1.BETA-2 and Chrome for Android version 95.0.4638.74 on Android 11. Thanks for taking the time to look into this!

  • mverdemverde

    Team Member

    @MerryBit Thanks for providing those details. Since you're using the beta version of 1Password, I've moved this over to our beta forum instead. I believe that the issue that you're encountering is due to a change that we made in 7.9.1BETA-2 that was specific to Chrome. Specifically, we turned on the ability to save manually entered details when using Chrome as it looked like they had resolved the previous issues that prevented that.

    @saad it looks like we'll need to take another look at this and either roll back the change or iterate on it to further refine the behaviour. I don't think this is something that will be specific to reedsy.com.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file