Saving Website Logins?

Hi,

How do you save passwords into 1Password with 1Password v8?

On v7 it used to pop-up a modal when submitting a form on Chrome to save into 1Password (or unlock to save if locked).

However, I don't get anything like this with 1Password v8? Visiting chrome://settings/passwords It says 1Password is controlling this setting so Chrome doesn't offer to save it but neither is 1Password (I assume this is controlled via "Make 1Password the default password manager" setting of the extension).

I've Connect with 1Password in the browser enabled in 1Password v8
I've Integrate with 1Password app enabled in the extension's settings.

Cheers.


1Password Version: 8.4.1
Extension Version: 2.1.4
OS Version: Windows 10

Comments

  • Hey @SugarRush:

    With 1Password in the browser enabled, saving passwords in the browser should be prompted like this when entering your current username/password on a website:
    image

    For more details on how to use 1Password in the browser, see here: Save and fill passwords in your browser

    If you're running into issues, let me know and I'd be happy to dig into it further with you!

    Jack

  • Hey @jack.platten,

    I see that now! It's much cleaner than 1Password 7 modal UI which looked like it was designed with XP in mind.

    However, sometimes It's in the way of the submit button if it's close to the form - for example say in the screenshot you provided the "Submit" button was below Password input and be behind "Save in 1Password" - maybe a setting in the extension itself to set where the Save button is left/right/below/above?

    Or even better make it so the Save appears in-line the input (obviously with a more 1Password looking design/blue this is just random) or instead render the save button on the submit button not password input.

    If I hit "Enter" after entering my login I miss being able to save the login vs where the modal method would pop-up and be open until I closed it myself. Anyway to enable this again? I've a habit of hitting Enter after filling the form so I lose out saving my login (unless I logout again > back in).

    I also had to disable 1Password controlling saved passwords. Mainly due to I do a lot of stuff in Incognito. A way around this would be If
    I enable 1Password extension to "Allow in Incognito", is this a good idea though?

    Cheers.

  • ag_yaronag_yaron

    Team Member

    Hey @SugarRush ,
    Thanks for the feedback and suggestions here!

    If the suggestions menu is blocking your view, simply click the little 1Password icon on the right side of the field to dismiss it. Click it again to reveal the suggestions menu on demand.
    Alternatively, if you don't like to use the mouse, you can press ESC or the Up Arrow key to dismiss it, then press the Down Arrow key to reveal it.

    As for pressing Enter, the old extension had a feature called Autosave, that would pop up the prompt to save/update the page in 1Password. The new 1Password in the browser doesn't work that way and instead you'll want to click/select the "Save in 1Password" button before you send the form.
    We do have a feature request to bring this feature into the new 1Password in the browser though, so we might see this functionality again in the future :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file