1Password always asks for master password when "Require Master Password" is not set to "Never"

Hi,

I'm new to 1Password, coming from KeePass, but wanted a more robust sync solution than managing my password database myself. So far I'm very impressed. 1Password seems to be both very functional as well as good looking :smile:

I have a OnePlus 5T on which I've also installed the 1Password app. I've enabled "Fingerprint Unluck" and set "Automaticall lock" to "After 10 minutes". Using those setting while the "Require Master Password" setting is set to "Never" I can unlock my phone using my fingerprint reader - nice.
I would like to add a little extra security by requiring the master password every other day. But no matter what setting I set for the "Require Master Password" setting I get prompted to enter the master password every single time. That's too inconvenient.

I might be understanding the feature incorrectly, so correct me if I'm wrong - but I suspected it to work as a "You're required to enter the master password every other day. So after entering the master password you will not be asked for it again for two days and can use biometrics to unlock as you please".

Thanks in advance.


1Password Version: Version 7.9
Extension Version: Not Provided
OS Version: Android 9

Comments

  • periperi

    Team Member

    Hi @psai_clux_bauh. Your understanding is correct, and you should be able to unlock with biometry most of the time, while you'll only need your Master Password when the keys get removed from the Android Keystore. If you're not being prompted for your fingerprint after setting up biometric unlock, it sounds like it may be malfunctioning.

    I'd like to ask you to create a diagnostics report from your Android device:

    Sending Diagnostics Reports (Android)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

  • Hi @peri,

    I've sent you an email with the info you requested and got back the ID [#LBW-46265-976].

    Feel free to ping me here or shoot me an email if I can be of further assistance.

    Thanks

  • ag_anaag_ana 1Password Alumni

    @psai_clux_bauh:

    Thank you! I confirm that I have managed to locate your diagnostics report in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: LBW-46265-976

  • On a similar note, I'd like to prevent 1P from asking me for any credentials once I've unlocked it the first time. I have all timeouts deselected/set to never, but I still get asked for my password. When I brought this up previously, I was told that it wasn't a good idea for security purposes and that it only takes a second to do a fingerprint scan. While that may be true, the app allows it to operate this way and I would like for it to actually work the way it's supposed to (not too hard of an expectation for a paid app that supposedly has the functionality already present). I already have a biometric unlock when I turn on my screen - to have a redundantly forced unlock on 1P (IMO) is unnecessary. TIA

  • ag_timothyag_timothy

    Team Member

    Hello @RobMendez thanks for your question.

    With 1Password for Android, any time the app is closed completely your account password (or biometrics) are required to unlock the app. The app is closed completely when you tap exit, when it is removed from recents and when your device restarts. Additionally, some devices can shut down 1Password in the background, battery savers are usually the culprit.

    If you'd like to unlock 1Password for Android as infrequently as possible you can turn Lock on exit off and set Automatically lock to never from Settings > Security. I use this setting arrangement on my testing device and I can unlock 1Password at the beginning of my day without the need to enter my account password through the day.

    If your settings match, I suspect 1Password is being closed inadvertently or your device is shutting down 1Password in the background. Removing 1Password from battery optimization may help with this.

  • Hi @ag_timothy thanks for the quick reply!

    I have my settings setup as you suggested and also disabled battery optimization, but it still does this behavior. I've had to leave biometric unlock enabled because otherwise I'd have to type my password every time.

    I can't think of anything else. Maybe having a persistent notification would alleviate this issue?

  • ag_timothyag_timothy

    Team Member

    Hello @RobMendez thanks for following up with us.

    Do you happen to be using a Samsung device? If so you can try disabling adaptive battery from settings > battery > more battery settings. You can also try turning put unused apps to sleep from settings > battery > background usage limits. Let us know how that goes.

  • @ag_timothy I'm using a One Plus phone but, as previously stated, I have disabled all battery optimizations (set to Don't Optimize under Battery Optimization). Not sure what else to do.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file