Black screen when launching

fultonmfultonm
edited January 5 in Linux

Screenshot attached here.. All 1Password windows are just a black window. I noticed I can still input my password on the Lock Page. (the mouse cursors changes shape when mousing over the master password text box.) So if I enter my password and hit enter it unlocks (but it is still Black. You can see in the screenshot the vault is unlocked by the window title bar). I can see elements in the Firefox extension, but the 1Password standalone app is still black. I have uninstalled, restarted my computer, reinstalled 1Password and the issue remains. I am using the 1Password repository to download.


1Password Version: Latest -- I can't check; black screen
Extension Version: 2.1.4
OS Version: Fedora 35

Comments

  • SavanniSavanni

    Team Member

    Hi, @fultonm.

    I have a few questions for you, and some suggestions that sometimes help in this situation.

    • What desktop manager are you using?
    • Is this X.Org or Wayland?
    • What graphics card do you have?
    • Is this a Flatpak installation?

    Starting 1Password from the command line with the --disable-gpu-sandbox is one of the things that we've seen fix this problem. Also, some NVIDIA users have fixed it by installing libglvnd-glx, libglvnd-opengl, and libglvnd-devel.

    Unfortunately, we don't know what causes this, nor can we reliably reproduce it ourselves. We're still collecting data.

  • fultonmfultonm
    edited January 5

    Hi Savanni,

    Thanks for your help and information. You have correctly guessed the company my GPU is from haha. ~~ And I understand, Supporting Linux must be a huge undertaking and I applaud 1password for doing that.

    Launching from command line with --disable-gpu-sandbox worked for me. Installing those packages you listed also worked for me for launching the application normally.

    To answer your questions:

    What desktop manager are you using? Gnome 41.2
    Is this X.Org or Wayland? Wayland
    What graphics card do you have? NVIDIA GTX 1060
    Is this a Flatpak installation? I do not believe so. It is installed from the 1Password Stable Channel and its files are in /opt/1Password/ and /usr/lib which seems "native" to me.

    Thanks again and let me know if you want any other data from my system.

  • SavanniSavanni

    Team Member

    Thank you. This is an important data point.

    I think that there are several problems with rendering on a few platforms, but it does seem that this one, where you're running directly on the host system and not in a VM, is related to XWayland (because 1Password doesn't run well in native Wayland mode yet) + Nvidia.

  • SavanniSavanni

    Team Member

    Oh, are you able to use Nvidia's native drivers, or are you using the Nouveau drivers?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file