cannot use 1Password on Samsung Tablet with Keyboard Cover

Community Member

I have seen this asked at least twice before but both questions were closed without resolution ???

I am using a Samsung S7+ tablet with keyboard cover, and I cannot find anyway to get 1Password to work withe keyboard attached ( which is all the time !)

Sorry if this has been solved and I havent found it, hope someone can help?

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Android


  • tyler_tyler_

    Team Member

    Hey, @swooding!

    I'm sorry your previous questions were closed without resolution. If you have links to those questions, I'd be happy to take a look at them.

    Can you elaborate on what is not working with the 1Password app while the keyboard is attached? Any information about the steps you are taking in the 1Password app as well as what keyboard make/model you are using would be helpful.

  • swoodingswooding
    Community Member

    Hi Tyler, thanks for the reply, the previous questions were not mine, but when I searched the community before posting i found a few similar, but there seemed to be no resolution.

    The issue I am facing is that when I attach the keyboard cover, then obviously there is no longer an onscreen keyboard, and I am finding that there are no autofill prompts nor any way to bring up 1Password other than switching out of current app and launching 1Password then switching back.

    I am using the samsung internet browser, which i find works really well on my mobile with great 1Password integration suggestions at the top of the on screen keyboard, but no good with the tablet. I am using 1Password 8

    any ideas welcome !

  • ag_timothyag_timothy

    Team Member

    Hello @swooding thanks for clarifying that. I'd like to ask you to update to our 1Password for Android beta on your tablet and try a new Autofill option:

    After updating to the beta, open and unlock 1Password, tap Settings > Autofill and turn Display Autofill suggestions inline off. After turning inline suggestions off, do you see prompts to fill with 1Password on screen?

  • odxodx
    Community Member

    Just found this thread searching for a solution for the same issue. I can confirm that 1password beta is working just fine with keyboard attached to the tablet (using a Galaxy Tab S7 with book cover). The usage in general is much better now. Thanks!

  • ag_timothyag_timothy

    Team Member

    Hello @odx thanks for letting us know that worked for you!

  • swoodingswooding
    Community Member

    Hi @ag_timothy can i check whether the Version 8.80 Beta for Android is compatible with using external keyboard? I dont seem to see the same autofill options as you advised previously, so I am currently unable to use with keyboard attached? Do I just need to wait and use the prod version until the Beta adds this functionality ?

  • ag_timothyag_timothy

    Team Member

    Hey @swooding thanks for following up with us. 1Password 8 does work with external keyboards. However, at the moment we have not included the Always show Autofill suggestions below fields setting.

    When a physical keyboard is in use, 1Password 7 and 8 should default to suggestions below fields. The Always show Autofill suggestions below fields setting helped ensure that would happen if there was an issue with the device or keyboard.

    I just tested a Bluetooth keyboard with 1Password 8 for Android and the Autofill settings showed up on screen as expected. If you don't see the suggestions when using an external keyboard, let me know and I would be happy to help look into it. Thanks again!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file