Request: identity agent compatibility with data grip

alfgalfalfgalf
Community Member
edited May 3 in SSH

I can't seem to get data grip (https://www.jetbrains.com/datagrip/) SSH tunnelling working with the 1-password identity agent. It has a feature to support identity elements and when I try connect it pops up with a authentication window but then fails to connect.

(Datagrip version: 2021.3.4)


1Password Version: 8.6.0
Extension Version: Not Provided
OS Version: macOS 12.2.1

Comments

  • floris_1Pfloris_1P

    Team Member

    Is there anything showing in the 1Password logs when you run the SSH command? On macOS that's ~/Library/Group Containers/2BUA8C4S2C.com.1password/Library/Application Support/1Password/Data/logs/1Password_rCURRENT.log.

  • pedronofuentespedronofuentes
    Community Member

    Hi, I don't know if this thread is active or not.

    I'm having issues to create the SSH tunnel with DataGrip (and PHPStrom). The app pops an alert saying that it won't be able to connect to the host. Checking its log the error is this:

    Authentication using ssh-agent
    
    Unable to connect to ssh-agent: "~/Library/Group Containers/2BUA8C4S2C.com.1password/t/agent.sock" path to socket is incorrect.   
    
    Using ssh-agent during SSH key-based authentication is disabled.
    

    I've tried to create a symlink like ~/.1password-agent.sock or use the real path without ~ but it does not work.

    I also checked the 1Password log but nothing happens when DataGrip tries to connect.

    Any clue about this? Could be more an IntelliJ issue?

    Thanks!


    1Password: 8.7.0
    Macos version: 12.3.1
    DataGrip version: 2022.1

  • dmirdmir
    Community Member

    Did you already solve that error? I got exactly the same error with PHPStorm on the latest MacOS. Using the 1Password SSH Agent via iTerm does work nicely but using it with Jetbrains IDEs does fail with the same error from above.

  • Marton.Soos_1PMarton.Soos_1P

    Team Member

    Thanks for reporting this issue! We will investigate it.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file