Chrome Classic Extension not working

kc1005kc1005
Community Member
edited March 18 in 1Password 3 – 6 for Mac

I started seeing an issue with 1Password classic extension on Mac OS Big Sur running Google Chrome this morning.

On starting Chrome i see an error "1Password can't verify the identity of the browser". I have tried restarting the browser, restarting my Mac, reinstalling chrome/1password extension and tried the fix "mkdir -p ~/Library/Application\ Support/Google/Chrome" recommended in other posts with no luck so far.

The Firefox extension on the same machine works as expected. Here are some additional details:

I am using:

  • 1Password 6 Version 6.8.9 (689001) AgileBits Store
  • 1Password Chrome Extension 4.7.5.90
  • Mac OS Big Sur Version 11.4 (20F71)

Wondering if others are seeing similar problem, and any pointers to fix the problem.


1Password Version: 1Password 6 Version 6.8.9 (689001) AgileBits Store
Extension Version: 4.7.5.90
OS Version: Mac OS Big Sur Version 11.4 (20F71)

Comments

  • Jack.P_1PJack.P_1P

    Team Member

    Hi @kc1005:

    Thanks for reaching out. On March 15, Google released Chrome 99, which contained a new code signing certificate. Because of this change, 1Password 6 for Mac no longer works in Chrome 99 or later. The last major update to 1Password 6 for Mac was almost 4 years ago, and as 1Password is a security product, we strongly recommend keeping it up to date.

    At this point, updating to 1Password 7 for Mac would be the best option if you want to continue using 1Password in Chrome. Please reach out to us directly at [email protected] to discuss the options that are available now. After emailing in, you'll receive a reply from BitBot with a support ID that looks something like [#ABC-12345-678]. Post that here, and I'll be able to connect the dots and locate your email conversation.

    Jack

  • SnicksSnicks
    Community Member

    Oh wow, this is frustrating. I've tried so many uninstalls and re-installs, there is zero mention of the fact that 1Password is no longer supporting Chrome in the support pages.

    I've paid a one-off fee for 1Password, and can't believe that it no longer works with Chrome - it's a really popular browser. Having to pay $3 a month just for browser integration is just too expensive. I don't need any fancy features over and above what I've paid for already, I am shocked that 1Password is taking away functionality to force people to upgrade or migrate to Apple.

    As 1Password can't be bothered to update the certificate for Chrome, I won't be bothering to upgrade.

  • ag_tommyag_tommy

    Team Member

    @Sincks

    This is a recent change. We're sorry to see you go if that is your choice. That said, you are always welcome to join us again should you change your mind. The license for 1Password 6 or any version would have been for as long as that version continues to work. This is a recent change to the Chrome browser. 1Password 6 stopped receiving support more than a few years ago. I would recommend talking to the staff using the email address Jack provided. You never know, you might just be surprised. You will have lost nothing with a short email to them.

  • BeleeboyBeleeboy
    Community Member

    Hi,
    same issue here very annoying... do you have update offer for an old 1Password 6 user ?
    Thanks.

  • BenBen AWS Team

    Team Member

    @Beleeboy

    Absolutely; we'd be happy to work with you. Please reach out to [email protected] via email for help upgrading. If you have a copy of your 1Password 6 license handy please include that, but no big deal if not. 👍️

    Ben

  • carsten69carsten69
    Community Member

    Hi,
    same on my side. With the add-on, that even after migration to 1password 7, the extension in chrome is still not working.

    Since a recent chrome on mac update, I spent hours of research and trials to fix the broken 1password browser extension for chrome.
    Recently - only by chance - I red in an article, that for the newest chrome release, 1password 7 would be required.
    But after upgrading to 7 and installing the new extension, the error ist stell the same:
    Something went wrong
    An unknown database error occurred.

    I have no idea, what to try next. And there is no support article on this issue.

    Please help or simply tell me, if there is a close perspective for a fix.

    Thanks and best,
    Carsten

  • BenBen AWS Team

    Team Member

    Hi @carsten69,

    We have a dedicated support team that helps folks through migrations. Please reach out to them via email at [email protected] and they'll be happy to help make sure your data transfers properly. 😃

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file