ssh-agent asking for authentication with each terminal session

mpcshmpcsh
Community Member
edited May 18 in SSH

I'm trying out the new ssh-agent feature, and I'm finding it frustrating that the agent seems to start fresh with each terminal session. It's frustrating because most of the time my laptop is docked to my desk setup in clamshell mode, and the Touch ID sensor isn't available, so it asks for my vault password. Is there a way to make the ssh-agent run in the background, such that I need to authorize only once, and then subsequent uses (in the same terminal or a new one) automatically happen?


1Password Version: 8.8.0
Extension Version: Not Provided
OS Version: macOS 12.3.1 (21E258)

Comments

  • steviecsteviec
    Community Member

    The same thing is happening to me. I usually use quite a few terminal windows, and requiring a password for each terminal session is pretty painful.

  • Marton.Soos_1PMarton.Soos_1P

    Team Member

    Currently, having to authorize each terminal session separately is the expected behavior of the SSH Agent. However we are considering adding more customization options to cover use cases such as this one.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file