1password for firefox refuses to connect to the Linux desktop app

mdanielmdaniel
Community Member

I've tried it with the production version that "Get 1Password for Your Browser" sends me to, as well as the beta version which I've traditionally had better luck using. They both behave the same way

I don't want to "login to 1password.com" because I have (and I'm not exaggerating) 17 containers just in this one profile, so the desktop app is the source of truth for credentials and previously worked fine

This is with "firefox 100.0 (64-bit)"


1Password Version: 8.7.0
Extension Version: 2.3.3
OS Version: ubuntu 22.04

Comments

  • mamashinmamashin
    Community Member

    Same error

  • mdanielmdaniel
    Community Member

    so, after going down a "forums rabbithole" based on this NativeMessagingHosts mention, it turns out this comment about `$HOME/.config/1Password/logs/BrowserSupport`` was the secret sauce, although the error message was aggressively unhelpful

        Additional error context: Failed to verify browser permissions
    

    It seems by "browser permissions," they mean that the binary must be chown 0:0 -- having it owned by your UID causes the extension to silently nope out

    How hard would it have been to say that in the logs, or for heaven's sakes to include something helpful in the "Browser" settings panel that says "oh, we saw your connection from firefox-bin but it's currently owned by user 1000 and we require it to be owned by 0" or even "we rejected a browser connection, please check $HOME/.config/1Password/logs/BrowserSupport for more details"

    So much waste of human capital

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file